View Single Post
Old 11-26-2012, 05:12 PM   #255
MarcusLSB
Registered User
 
Join Date: Aug 2010
Location: Bay Area
Posts: 4,367
My Ride: BMW's
Quote:
Originally Posted by basar13 View Post
Thanks bro thank you for feeling my pain.

I want to make a summary of my situation.

There wasnt any plug and play ecu for Z4M and so i wanted to put M3 ecu on my car to use the plug and play ecu of HPF. So i have bought E46 M3 ecu, keys and EWS 2 days later on e46fanatics.com (05-05-2011) Jason (Pro-efi) said


''Anybody who wants to get me a Z4M to do a kit on, I'll give you a smoking deal! Just PM me or email me at jason@proefi.com ''

So i returned the ecu, key and EWS because i thought it was a great news and i was not going to have to work on E46 M3 ecu to work on Z4M.

Then on 05-20-2011 MarcusLSD replied

'' We're bringing the car down this Saturday. ''

That saturday was 05-22-2011.... Friend of Marcus have given his Z4M to Pro-efi to make a plug and play kit so then they were going to sell a ''Z4M plug and play ecu''



I have received the ''Pro-Efi plug and play Z4M kit'' NEXT YEAR ! @05-18-2012 and it was not working. It was also missing igniters and pins. I have paid extra for those but still Pro-efi didn't work and now Jason doesnt take the ecu back claiming that HPF was going to develop and complete the ''kit''. (He didn't take the responsibility and blamed on HPF)

Then i waited for 5 months for Pro-Efi to solve this issue NOTHING HAPPENED! SO i have bought e46 m3 Ecu, key and EWS once again....

Then 7 days later Chris told me that John Reed was going to build the harness and the tune so due to reputation of John Reed i agreed to put my E46 M3 ecu project on hold once again.

Right now everything excluding injectors are installed on car. If i can get a working ecu and the harness my car is good to go. (Didnt install the injectors because i am still using stock ecu.)


Right now it has been 1 year and 5 months since i have been waiting for a plug and play ecu for my Z4M. I wish i had gone to my M3 ecu route.

I have installed the turbo kit on my car 05-26-2012 and since then i cannot use my car. So it has been 6 months... This was the worst part and i hope it ends soon.

Thats it for now lets see how it will go with John Reed. Such a simple thing costed me 1 and a half year.
We haven't given up on ProEFI in the Z4M yet.
__________________


youtube.com/marcuslsb -- Check out photography by Gheybe!

New Build by Lab22

MarcusLSB is offline   Reply With Quote