View Single Post
Old 01-08-2013, 08:03 PM   #1
Pig_Pen
Registered User
 
Join Date: Feb 2012
Location: mn
Posts: 24
My Ride: 325xi
Question Help, Replaced CV boot & wheel bearings, now dsc on and noise, what did I do?

Hope you guys can help me out. I searched, but couldn't find info specific to my problem.

Over the last week I replaced a torn outside cv boot on my 2003 325xi using the diy here. While I had it apart I figured I might as well do the wheel bearings since the car has 100k on it.

I didn't pull either axle out of the diff, on the side that I replaced the boot, I just tapped off the outer joint with the axle still attached, cleaned the joint, grease, new boot and then tapped the outer joint back on the axle.

Did the wheel bearings and all went smooth.

Now my problem: if I get going over 5mph, the dsc light comes on and the engine cuts power to the pedal. I do hear a faint intermittent noise that sounds like it is from the driveline somewhere. I checked and both axles are still fully seated in the diff. When I spin the front wheels while on jackstands, there isn't any binding or unusual noise. Grabbing the axles, there isn't any more play than normal. The wheel sensors are in and everything else appears to be correct.

One thing I was thinking, does the outer cv joint need to be lined up on the axle in a certain position? I just put it on, but maybe that is what is throwing the wheel sensor off?

Is it possible that I pulled the inner joint apart, but can't tell now that it is back together?

Anyone have any ideas or suggestions? My car is undrivable right now....

Thanks in advance for any help.
Pig_Pen is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.