View Single Post
Old 01-09-2013, 05:16 PM   #1
R0B
Registered User
 
Join Date: Jul 2009
Location: Northern Virginia
Posts: 729
My Ride: zhp sedan
Shutter/EML 2004 330 zhp

I have two issues. One is the shutter at start up, another is an EML issue.

The shutter occurs when I start the car, and lasts for about 5 seconds. Idle drops, then slowly rises to correct idle. Doesn't matter if it is cold/warm.

The EML issue arises when I try to accelerate, typically from below 3k rpm. Sometimes it happens above 3k rpm. Wide open throttle decreases the chances of the EML being triggered. At times, it doesn't pull smoothly through the rpm band. Once the EML is triggered, the engine has an erratic idle, bouncing between ~800-1200 rpm. I do not have control of the throttle when the engine/computers are in this state. I must reset the key to restart everything. I also noticed that I get a power surge if I hold the gas peddle in a position to slowly accelerate. This is not the famous surge or bump around 2400 rpm as result from the DESA.

No boost leaks, blower is making 12lbs.


EDIT: Just checked the fuel pressure. Primes to 46psi, idles at 38psi. Not sure if this is ok.
Thinking it may be the DISA valve, bottom bolt broke off. D:

Thanks in advance!
__________________
Merhaba

:Headers: :Header-back Magnaflow Exhuast: :UUC clutch/lightweight flywheel: :AA stage 1 supercharger: :VMR V710:
For sale: 3.46 differential, 18x8.0 style 135/18x8.5 style 135/ 19x8.5 varrstoen 1.1.2

Last edited by R0B; 01-10-2013 at 11:04 PM.
R0B is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.