View Single Post
Old 02-18-2013, 12:22 AM   #1
Rotha
Account Under Review
 
Join Date: Dec 2006
Location: N/A
Posts: 4,817
My Ride: N/A
Torn out Sway bar Rivets

out of the subframe. A little background on the car (only suspension and drivetrain) skip if you dont care:


2001 325iT
D2 Coil overs with corner balance 50/50
Hotchkis sway bars with Hotchkis end links
Front custom machined end links with spherical... eye.. things (not ball joints?)
Almost every rubber component is polyurethane
UUC Motormounts
UUC Tranny Mounts
Eurobahn subframe reinforcement kit welded in & installed
gs6-37bz transmission swap with 3.46 final drive
During the time the sway bar was on I had a fidanza aluminium flywheel and 330 clutch with the s5d 320...d? (5 speed tranny)
CSL reps 18"
meyle HD control arms and a bunch of other misc stuff

History:
~220,000 miles, sway bar has been on since 75K, also was the first suspension mod I did. before coilovers it has been through about 18 auto-x, 6 circuit X, and 4 HPDEs. Has been driven hard pretty consistently throughout its life on the street (mostly curves and country drives)

OK

first day of noticing


passenger side is fine.


undo the nuts on the passenger side and the driver side falls right out


studs are actually rivets. of some sort.


picture of the damage


so what my best friend and I did was we took it down, hotchkis supplied a swaybar spacer/reinforcement plate which was about 1/4 inch thick, I didnt think it was supposed to be welded on, because it was painted but we used it for that purpose anyway. We flattened out the pucker, welded the rivets back in, and then welded the reinforcement plates on top of that all around (we were going to drill the middle and weld in a vignette but decided that perimeter was enough and there was a structural bead there that we didn't want to compromise. so the load is distributed on a larger surface area. then we painted it black so it doesnt rust.



Tested it and it's all quiet again. At first symptoms sounded like I just had bad control arm ball joints, then the sound got worse and my car's handling capabilities were off. this had been an ongoing problem for a while and it finally just failed. I am pretty confident that this setup is solid, but if it isnt. Then it's back to the drawing board with some a656g80 steel.

hope this helps anyone. Doubt you'll see this problem, but if you do. here you go. youre not the only one. also the other side was welded in too.

Last edited by tim330i; 10-23-2014 at 08:20 AM. Reason: spam links removed
Rotha is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.