View Single Post
Old 05-16-2013, 12:22 AM   #634
knsaber
Registered User
 
Join Date: Apr 2005
Location: Fort Lee, NJ
Posts: 328
My Ride: 2005 330xi
Quote:
Originally Posted by tpm23 View Post
Aaaargh! I did my right rear regulator last year with no problems. Now I'm in the middle of doing the right front.... with a definite problem.

This one wasn't as messed up as the right rear so I went with the ziptie approach instead of buying a new unit. I had one broken part on one plastic clip but went ahead and ziptied both sides of both clips as shown in the DIYs.

I've got enough bits and pieces back together to test things. With the window unattached, the carrier pieces move up and down as they should. But with the window attached, the motor runs out of steam with the window about 60% of the way up. It slows down, is obviously straining, then just stops. Also, note that it is pretty difficult for me to physically push the window (when not attached to the regulator) all the way up. The DIY says to tape it in place so it doesn't fall while you're removing/installing the regulator...... no way I need to do that. It's a tight friction fit up there as it is!

So I'm thinking the motor may be going out and is weak, but, since it's so hard for me to get the window all the way up by pushing it manually, I'm also thinking something else might be wrong there. I've installed/uninstalled/reinstalled everything twice now and can't see anything that might be interfering with the window's path. Suggestions?

By the way, it's an '02 325i with about 56k miles.
The friction with the windows is very tight unless you make sure it's aligned properly to the track. That requires you to either push the window outwards to let it slide, or grab the rear end and lift it up with enough force to "loosen" the window to slide up and down. Simple up and down force will never get it to move.
__________________

Predator Orion | AC Style Deck + Roof Spoiler | K&N 57-Series CAI | UUC StrutBarbarian | H&R Rear Sway Bar | Enkei EKM3 18x8 | Philips 6000K HID Fogs | LED Tail Lights

2007 Z4 M Roadster Imola Red




knsaber.com
knsaber is offline   Reply With Quote