View Single Post
Old 07-12-2013, 03:16 PM   #1
id3550
Registered User
 
Join Date: May 2013
Location: Bay Area, California
Posts: 290
My Ride: 09 M3/4, 95 M3
Stock spring binding?

I recently repaired my strut tower using the 2x4 and reinforcement plate method and it worked like a charm. While I was there I replaced all struts/shocks as I was sure the damaged strut tower probably belt the strut too somewhere, there was somewhere in the neighborhood of 3 degrees of negative chamber. The old perches and pads were used; there was no apparent damage to any of them. The new Bilstien HD's show no sign of damage during shipping and rebounded normally

The issue I'm having only affects the repaired strut tower. It squeaks whenever it's compressed and feels stiffer than the other side. I've had someone compress that side and noticed a good amount of vibration coming from the spring. I've take the assembly off a few times and checked the inside of the tower and there doesn't seem to be any rubbing. The spring and pads were put in the right way and perches mounted properly and aren't rubbing the strut piston.

Could it be possible that the spring was damaged in a way that's not apparent in a visual inspection that would cause this? Everything was fine up until the repair. Everything attached to the suspension is torqued properly and the ride height is normal.

Anyone have any ideas? I'm at a loss.
id3550 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.