View Single Post
Old 09-11-2013, 09:14 PM   #120
shawnhe46
Registered User
 
Join Date: Sep 2013
Location: charleston,sc
Posts: 2
My Ride: 2002 325ci
First time poster on this blog - have used bimmerfest before. Wanted to thank various other posters for helping me solve my charging system problem on my 2002 325 ci and share some lessons learned. History - battery went dead suddenly - was almost 6 years old and aftermarket so thought first step was just to replace the battery. After replacing battery the fun started. After cranking up, the battery indicator came on along with headlight out indicator and the transmission reset to factory default light and the car would only run in "limp mode" . searching the web found someone who had similar problem due to their voltage regulator putting out to much voltage. Found a great Youtube video how to display the voltage output on the dashboard and sure enough I was getting 15 to 17 volts - way high (). Using this post I was able to replace the voltage rgulator using a $39 peilican replacement (Boscch 120 amp)- the dealer wanted $260. It was pretty easy to replace the VR without removing the alternator - the only issue I had was that I was not able to pry the plastic cap/thread protector off the positive lead terminal as another poster suggested. I finally just put a socket (17mm?)on the plactic cap and the nut came off with it. I did make frequent use of a basic telescoping mirror - but it really wasn't to hard. Had to take most of the air box connecting hose off and move the power steering resevoir around several times. After putting it back together I did end up having to replace the high beam ligths which the excess voltage had taken out -figured this out pretty quickly thanks to another post on this forum. http://www.bimmerfest.com/forums/sho...d.php?t=459428. anyway appreciate all the posters and pictures._nr_
shawnhe46 is offline   Reply With Quote