View Single Post
Old 07-25-2006, 07:05 PM   #48
tyroneshoe
Registered User
 
Join Date: Jul 2006
Location: Cleveland
Posts: 5
My Ride: 2004 325xi
Hi Tom,

I've been really disappointed with my DICE unit so far. The controls and everything work great but I have had massive problems with background noise both while in ipod mode and while in aux mode with my satellite unit. I never had any problems with my old BMW ipod interface.

The problem was much worse with the satellite so I installed a ground loop isolator between the DICE unit and the stereo mini-jack for my satellite (I am using shielded cables too). While this helped with *some* of the alternator whine, it still did not completely fix it. I also get the alternator whine when in iPod mode and when there is nothing plugged into the AUX port as well. The other really annoying thing is this "dit-dit-dit" sound which is relatively faint however, I tend to crank up my stereo a lot and it really ruins a lot of songs as it is quite audible at higher volumes.

I tried a few experiments and here were the results:
1) Unplugged the sat radio unit from power and unplugged the aux port on the DICE unit: still heard background noise and "dit-dit" sound while the DICE unit was in aux mode. Worse when revving engine, of course.
2) Killed engine and listened in both AUX and iPod mode: no whine but still hearing the "dit dit" sound.
3) Paused iPod while in iPod mode: more whine and the annoying dit sound.

I saw you had another power isolator on your site that you mentioned previously. Will this completely eliminate the alternator whine? If so, why doesn't DICE ship the unit with one integrated into the cable? Also, do you have any instructions on how to integrate that isolator into my installation (where, how, etc)? Will this also help with the "dit-dit-dit" sound?

Any help would be greatly appreciated.

--Matt

2004 325xi
Business CD

Last edited by tyroneshoe; 07-25-2006 at 07:07 PM.
tyroneshoe is offline