View Single Post
Old 07-26-2007, 12:44 AM   #1
ports
Registered User
 
Join Date: Jul 2003
Location: St. Louis
Posts: 297
My Ride: '09 Audi A4
Send a message via AIM to ports
Bimmian experiences



Has anyone had trouble buying parts with Bimmian?

Somehow I've drawn the short straw in this. I bought an HID upgrade kit, and a Raptor CWP kit from Bimmian in January. The Raptor kit took about a month to show up. The HID kit took about 2 weeks.

The HID kit was missing some parts and didnt have enough plugs to wire up everything that needed to be wired.. There was no place to wire up power. That's pretty important. And yes, I did it right. 3 plugs from the bulbs, and 3 available ports on the ballast. Plug them all in, and that leave you with zero ports to plug in the power connector from the car. Not like the power connector on the car would fit the plugs on the ballast.

So I return the kit in February via USPS. Bimmian says they never received it, but my tracking and customs stuff from the USPS says it was delivered. So there goes $300.

The raptor cwp kit came as a box of some parts, no instructions, or inventory list. I started to assemble the kit in May when the weather was nicer here, and what do you know. According to the instructions from e46fanatics, and google that I found, I'm missing parts. My harness didnt have enough plugs to connect up anything other than the ballasts from the light rings. There was no extra plugs to hook up the heater inverters, and the heater inverters weren't included either. And i was missing connector plugs so i had to buy some from radio shack.

I get in touch with Bimmian about the missing parts and they tell me they'll ship them out.

Now pausing, I was only able to reach Bimmian on the phone once, because they never answered the phones. Almost all of this was done via e-mail.

A month later a box shows up at my house, with 1 heater inverter. Great. What do i plug it into? My power harness has no plugs for it. And having one side heated is rather worthless too. I email them again, and they tell me theyll fix it and get me the correct harness, and ballasts. Then a few days later I get an email stating itll be shipped out that day. Nothings here 5-6 weeks later.

Supposedly a service manager looked into my return and said it never showed up.

So here I am 8 months later, out almost $600, and sitting around with probably $100 in parts.


What can I do to resolve this?
__________________
Nothing good can come from staying with normal cars.
ports is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.