View Single Post
Old 04-29-2009, 06:00 PM   #1
chris98891
Registered User
 
Join Date: Mar 2007
Location: greenville, sc
Posts: 1,723
My Ride: '01 325i
Send a message via AIM to chris98891
For anybody on the fence re the V1

definitely dont let their customer service hold you back. i got my unit a couple months ago to replace my rx65 (speaking of which, reception is no better, you just get the arrows), and i couldn't get it to switch modes.

i figured it was something i was doing wrong so today i finally decided to read up on it, and it says it may be caused by a faulty power cord. well i switch around all my cords, no help. switch cards, no help. call around 3:30, phone picked up by a PERSON within 2 rings. shes knows exactly what shes talking about and helps me troubleshoot.

she finds out there is something wrong with the unit, double checks with a technician, and tells me to ship it out asap, she has a file set up under my name (no rma, personalized enough to use a name) and address. she also said don't worry about shipping, for me just to call after they get it and they'll refund whatever the shipping cost is to my card. they'll also fix it the day they get it and have it shipped out by the time ups gets there.

now THAT is customer service.

i shall add them to my list of great CS:
BSW
Bimmerworld
Valentine Reasearch
Elemental Designs
Sony
Tischer/getbmwparts

no other sponsors have been worth mentioning in my cases
__________________
-Chris





Last edited by chris98891; 04-29-2009 at 06:03 PM.
chris98891 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.