E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Motorsports & Track Forum by BimmerWorld

Motorsports & Track Forum by BimmerWorld
From Auto-X to Trackday to Racing and Professional Motorsports this is the place to discuss making BMWs fast
Sponsored by BimmerWorld

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 10-19-2005, 01:46 PM   #1
Joaqo1010
Registered User
 
Join Date: Oct 2004
Location: Atlanta
Posts: 15
My Ride: 02 330CI
Track not so good

I went to the track last weekend in commerce Ga. It didnt go as well as i thought. My best time was 15.1. I have a 330 ci with a dinan chip in it. I really thought i would hit 14s at least but i guess not. The track is kinda shitty but thats no excuse i think my launch was just horrible didnt feel like i was getting to much power off of it. Can anyone help.n Ill probably go back in a couple of weeks
Joaqo1010 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 10-19-2005, 02:58 PM   #2
rana
Registered User
 
Join Date: Aug 2003
Location: White Rock, BC Canada
Posts: 1,543
My Ride: 04' 320i, 03' 745Li
how were you launching?

where were your RPM's? How did you let the clutch out?
__________________
rana is offline   Reply With Quote
Old 10-19-2005, 04:49 PM   #3
Joaqo1010
Registered User
 
Join Date: Oct 2004
Location: Atlanta
Posts: 15
My Ride: 02 330CI
Quote:
Originally Posted by rana
how were you launching?

where were your RPM's? How did you let the clutch out?
I was launching at about 3000 but i feel like i was letting the clutch out to fast but i tried to let it out slowly and it wouldnt catch.
Joaqo1010 is offline   Reply With Quote
Old 10-20-2005, 01:04 AM   #4
vaio76109
Registered User
 
Join Date: Nov 2003
Location: Fort Worth, TX
Posts: 8,828
My Ride: Race Cars
what are your 60' times?
vaio76109 is offline   Reply With Quote
Old 10-20-2005, 07:36 AM   #5
PEI330Ci
58mm of Bliss
 
PEI330Ci's Avatar
 
Join Date: Jul 2003
Location: PEI,Canada
Posts: 3,993
My Ride: 330i, 330Ci
3000 sounds really high with stock tires.

My best advice for launch is to start at 1500 RPM dumping the clutch, and then try increasing the launch RPM by 200 RPM on each successive launch. At some point you will find a good balance between avioding wheel spin, and avoiding a bog that will show up on your 60 ft.

With a Stock 5 sp manual 330, Do NOT shift into 4th. Bounce it off the rev limiter in 3rd...it's faster.

Powershift! That is, shift with your foot held to the floor on the accelerator. If you are fast enough, the clutch and fuel cut-off won't be an issue.

Personal result with the above: 14.4

Lastly, practice. It took me no less than 18 passes to get my time down to 14.4 with a 2.1 60 ft. I started at 15.3 if it makes you feel better.

Have fun,

Adam
PEI330Ci is offline   Reply With Quote
Old 10-20-2005, 10:23 AM   #6
Joaqo1010
Registered User
 
Join Date: Oct 2004
Location: Atlanta
Posts: 15
My Ride: 02 330CI
Quote:
Originally Posted by pei330ci
3000 sounds really high with stock tires.

My best advice for launch is to start at 1500 RPM dumping the clutch, and then try increasing the launch RPM by 200 RPM on each successive launch. At some point you will find a good balance between avioding wheel spin, and avoiding a bog that will show up on your 60 ft.

With a Stock 5 sp manual 330, Do NOT shift into 4th. Bounce it off the rev limiter in 3rd...it's faster.

Powershift! That is, shift with your foot held to the floor on the accelerator. If you are fast enough, the clutch and fuel cut-off won't be an issue.

Personal result with the above: 14.4

Lastly, practice. It took me no less than 18 passes to get my time down to 14.4 with a 2.1 60 ft. I started at 15.3 if it makes you feel better.

Have fun,

Adam
Thanks yea i definetly shifted into fourth everytime and i was dumping the clutch too fast the track was full so i only passed about 5 times i do think i need alot more practice.
Joaqo1010 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 09:13 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use