E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 06-10-2009, 10:08 PM   #1
BlackBmmer12
Registered User
 
Join Date: Aug 2008
Location: Pierre, SD
Posts: 76
My Ride: 02' 325 Ci
Curious on what is wrong with my car? :(

When starting my car, there is a click click click noise like when the battery would be dead. it was awhile since i drove it last so i charged the battery and drove away. From now on when i start my car, it still does the clicking noise, but when i turn the key off the back on and then my car starts. But the light come on the dash that there are transmission malfunctions.

Would i be safe driving this or no? the closest BMW dealership is 400 miles away.
__________________
BlackBmmer12 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 06-10-2009, 10:11 PM   #2
jbeurotech
Regional Sponsor
 
Join Date: Aug 2006
Location: New Brighton MN
Posts: 5,019
My Ride: 2000 E46 with 254K
You have a weak battery or a voltage drop on the positive or negative cable. Get the battery tested.
__________________

Seth Thorson
Service Manager/BMW Tech
JB Eurotech Service "Your Reasonable Dealer Alternative"

General Questions can be sent to appointment@jbeurotech.com

1. Do not argue with an idiot. He will drag you down to his level and beat you with experience.
2. Light travels faster than sound. This is why some people appear bright until you hear them speak.
jbeurotech is offline   Reply With Quote
Old 06-10-2009, 10:15 PM   #3
BlackBmmer12
Registered User
 
Join Date: Aug 2008
Location: Pierre, SD
Posts: 76
My Ride: 02' 325 Ci
so replace my battery and i should be fine?
__________________
BlackBmmer12 is offline   Reply With Quote
Old 06-10-2009, 10:17 PM   #4
jbeurotech
Regional Sponsor
 
Join Date: Aug 2006
Location: New Brighton MN
Posts: 5,019
My Ride: 2000 E46 with 254K
Quote:
Originally Posted by BlackBmmer12 View Post
so replace my battery and i should be fine?
No TEST the battery first NO RANDOM PARTS replacement (tweek tweek) LOL
__________________

Seth Thorson
Service Manager/BMW Tech
JB Eurotech Service "Your Reasonable Dealer Alternative"

General Questions can be sent to appointment@jbeurotech.com

1. Do not argue with an idiot. He will drag you down to his level and beat you with experience.
2. Light travels faster than sound. This is why some people appear bright until you hear them speak.
jbeurotech is offline   Reply With Quote
Old 06-10-2009, 11:05 PM   #5
matterhorn
Registered User
 
Join Date: Dec 2008
Location: Bothell, WA
Posts: 179
My Ride: 2000 328i
Quote:
Originally Posted by jbeurotech View Post
no test the battery first no random parts replacement (tweek tweek) lol
+1
matterhorn is offline   Reply With Quote
Old 06-10-2009, 10:31 PM   #6
lister1919
Registered User
 
Join Date: Jul 2008
Location: EC Canada,
Posts: 31
My Ride: s are red and black
Happened to me, except about 20 click clicks later it would start. Battery was wrote, got a new one works fine to this day
lister1919 is offline   Reply With Quote
Old 06-10-2009, 10:35 PM   #7
bender
hammer talks like this
 
Join Date: Dec 1969
Location: Houston
Posts: 4,293
My Ride: 2006 Honda insight
Send a message via AIM to bender
Something similar happened to me, I changed the battery and that did not help. It turns out it was a problem with my key. Try your spare key, see if that helps.
bender is offline   Reply With Quote
Old 06-10-2009, 11:07 PM   #8
IdahoToyo
Registered User
 
Join Date: May 2009
Location: A Sunny Town in Idaho
Posts: 375
My Ride: 4WD Tundra / GS500F
Do not just go an replace the battery. I did this when I had the same type of problem, I wanted to purchase a new optima one anyways, but after I had it replaced the shop checked the old battery and said it was fine. I then had the same problems and found out it was the alternator...so def. get it checked before you go and and buy things that aren't necessary.

Good luck with it though!
__________________
-- Kyle --

The difference between school and life? In school, you're taught a lesson and then given a test. In life, you're given a test that teaches you a lesson.
IdahoToyo is offline   Reply With Quote
Old 06-10-2009, 11:07 PM   #9
Penguin Koolaid
Banned
 
Join Date: Feb 2004
Location: Chitown
Posts: 6,701
My Ride: Inline Six
Quote:
Originally Posted by BlackBmmer12 View Post
When starting my car, there is a click click click noise like when the battery would be dead. it was awhile since i drove it last so i charged the battery and drove away. From now on when i start my car, it still does the clicking noise, but when i turn the key off the back on and then my car starts. But the light come on the dash that there are transmission malfunctions.

Would i be safe driving this or no? the closest BMW dealership is 400 miles away.
Alternator
Penguin Koolaid is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 02:34 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use