E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 12-25-2009, 05:49 PM   #1
mkaria
Registered User
 
Join Date: Sep 2008
Location: London, UK
Posts: 9
My Ride: 330 sport convert
Unhappy Hesitation/start up 330 2001

Hi Guys, this is my first post so here goes... the car is a 2001 330 ci sport convertible with 46K miles on the clock

When my e46 2001 330 conv sport is cold it starts up and drives perfect. Problem is, when the car has warmed up and I turn it off, it has a problem starting up again and only "dribbles" back to life after turning the key. It normally has problems starting up another two times after and starts properly on the third attempt. Occasionally after restarting the car feels odd and lacks power.

This problem happens only when the car is restarted once warmed and usually sorts itself out on the third attempt at starting. Also, I think the thermostat is bad as the car takes ages to warm up and now the temp needle very really goes to the middle point as it should (unless im stuck in traffic). When on the motorway (highway) it stays between the blue bit and middle point.

Do you think these two issues are related?

The car is not registering any faults on the CEL.

There are a lot of posts on here advising the coils are likely to be bad but wanted your help for any pointers please... I've seen a few other posts on Camshaft position sensor and vacuum leaks etc.

To be honest, I've just spent 1.5k on the car with new wheels and replacing the tensioner and oil sensor and am trying to keep repairs as cheap as poss. so any help would be appreciated-

Thanks in advance and very Merry Christmas to all-
mkaria is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 12-25-2009, 06:40 PM   #2
dmax
Registered User
 
dmax's Avatar
 
Join Date: Aug 2006
Location: NJ
Posts: 22,789
My Ride: '99 328i 1.04646 mu
I think you sort of guessed that you, at least, have a thermostat problem...almost undoubtedly. They 'fail safe' as in staying opened and will take longer to warm up and run cooler on highway or constant speed. Idling for 5 mins. probably brings temp back closer to center. Anyway, I've been through this twice and it's always therm.

On starts, just read today about someone with similar 'loss of power' and it was MAF for him...ymmv Maybe try to clean it carefully and at least eliminate that as issue.

GL

Doug
dmax is offline   Reply With Quote
Old 12-25-2009, 06:48 PM   #3
dmax
Registered User
 
dmax's Avatar
 
Join Date: Aug 2006
Location: NJ
Posts: 22,789
My Ride: '99 328i 1.04646 mu
some other quick thoughts ...to give you a chance at saving money...

I just went through therm and read probably 200 posts on it...I'd say maybe one or two members 'just' had low coolant, so check that properly (many threads on that and of course yet some controversy about how to do that right...how to do the filling right, I should say, not the checking...in morning when cold open up cap and make sure level is good--top off and bleed if necessary--the bleeding is the controversial stuff for some)

Doubt this is it, but if you haven't changed either air or fuel filters--not too expensive, easy diy, certainly wouldn't hurt if neither has been done in a while, or if you're using gas from many different sources...and that 'might' do it for you.

Think that's all I got!

Doug
dmax is offline   Reply With Quote
Old 12-25-2009, 07:03 PM   #4
mkaria
Registered User
 
Join Date: Sep 2008
Location: London, UK
Posts: 9
My Ride: 330 sport convert
Thanks Doug, appreciate your help with this, I'll have a look at the points you've suggested

Hope you're having a good Christmas!
mkaria is offline   Reply With Quote
Old 05-02-2010, 05:25 PM   #5
mkaria
Registered User
 
Join Date: Sep 2008
Location: London, UK
Posts: 9
My Ride: 330 sport convert
Just thought I'd post a follow up... it turned out to be bad cam position sensors. Replaced and car is running 100% better with much better MPG, acceleration, no hesitation and generally much better. Found out about the sensors after hooking up to diagnostics... I thought it was the coils before diagnostic test
mkaria is offline   Reply With Quote
Reply

Tags
coils, help!, hesitation, start up, thermostat

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 06:59 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use