E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Suspension & Braking Forum by BimmerWorld

Suspension & Braking Forum by BimmerWorld
Have some questions about suspension or brake setups for your E46 BMW? Get all your answers here!
Sponsored by BimmerWorld

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 09-16-2010, 05:54 PM   #1
CopTzrM3
Registered User
 
Join Date: Jun 2010
Location: Portland, OR
Posts: 20
My Ride: 2005 ZHP
Angry Damn Suspension Noises Continue!!!

Hey Guys,

So far in the front end of my car I have replaced CAB's, control arms (meyle), and anti-roll bar links. Most all of my knocking/clanking sounds went away at first. I am replacing tie-rods this weekend which I think should eliminated the rest.

After only about 4 days of having both new control arms and sway bar links installed, it seems as though they are getting louder already! Mostly when I hit small bumps which I'm assuming means this is more the links than the arms.

My Question: I have searched and read a few threads in which people have suggested to "retorque" the arms and links. I don't know the torque specs but if anything, I overtightened them. Could this really create a noise issue? Also, if I overtightened them, are they ruined or do I just need to retorque?

Thanks!
CopTzrM3 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 09-16-2010, 06:05 PM   #2
SalM
Registered User
 
Join Date: Aug 2009
Location: Long Island,NY
Posts: 6,530
My Ride: Shhh
Buy My Sports Suspension to Solve your Problem!
__________________


SalMPhotography
SalM is online now   Reply With Quote
Old 09-16-2010, 06:10 PM   #3
ChasCan
Registered User
 
Join Date: Jan 2010
Location: Connecticut
Posts: 1,066
My Ride: 2001 330xi
Check your strut mounts. They are the tops of the strut. They will give you a rattle/knock when driving over smaller type bumps. Plus, you will not have any sound if you over torqued anything. Chas

Last edited by ChasCan; 09-16-2010 at 06:11 PM.
ChasCan is offline   Reply With Quote
Old 09-16-2010, 06:12 PM   #4
InDiGlOM3
Registered User
 
Join Date: Jan 2006
Location: Copperas Cove
Posts: 1,505
My Ride: HPF M3 stg 2.5
Send a message via AIM to InDiGlOM3 Send a message via Yahoo to InDiGlOM3
do you have after market motor mounts? bad motor mounts will do this and u wont know til u take them off they are bad.
__________________
InDiGlOM3 is offline   Reply With Quote
Old 09-17-2010, 12:03 PM   #5
hummer
Registered User
 
Join Date: Apr 2003
Location: Haverhill, MA
Posts: 3,323
My Ride: 2001 330CI
How many miles? Original shocks and mounts? The strut is the main structural member of the front suspension. If it is worn out, it can start knocking. The strut mount has a bearing that can wear out and cause noise also.
hummer is offline   Reply With Quote
Old 09-19-2010, 01:19 AM   #6
CopTzrM3
Registered User
 
Join Date: Jun 2010
Location: Portland, OR
Posts: 20
My Ride: 2005 ZHP
Guys thanks for your input. As it turns out, i must have not torque one of the ball joints on the linkages correctly as it got a little loose. Got it tightened correctly and it is all good!

@ SalM, I have the sport package on my car from the factory. Is the suspension you are selling different?

Thanks.
CopTzrM3 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 04:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use