E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > New Member Introductions

New Member Introductions
New members check-in, introduce yourselves, and post a picture of your BMW here!

Reply
 
Thread Tools Search this Thread Display Modes
Old 07-06-2011, 03:17 PM   #1
jcruz1994
Registered User
 
Join Date: Jul 2011
Location: NY
Posts: 3
My Ride: 2002 325ci
Unhappy Hi, New member here- trouble w/Instrumental Cluster

having problem with Instrumental Cluster on a 2002 BMW 325ci. Blinking lights on panel don't work, cant open convertible, radio buttons on steering wheel not working, etc I've disconnected the battery overnight and after reconnecting all seemed back to normal, only for a few seconds then problem started again. Please help as I don't want to bring to dealer and get ripped off. Thanks

Last edited by jcruz1994; 07-06-2011 at 03:40 PM.
jcruz1994 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 07-06-2011, 08:52 PM   #2
rizwan1377
Registered User
 
Join Date: Nov 2010
Location: Rockland county, NY
Posts: 1,782
My Ride: 04 M56,LC 100,RX300
Send a message via AIM to rizwan1377 Send a message via MSN to rizwan1377 Send a message via Yahoo to rizwan1377
I am not sure about the problem but is battery good? Have it tested because bad battery causes weird problems.
__________________
rizwan1377 is offline   Reply With Quote
Old 07-07-2011, 08:53 PM   #3
jcruz1994
Registered User
 
Join Date: Jul 2011
Location: NY
Posts: 3
My Ride: 2002 325ci
Thanks for responding. Yes, the battery is almost new. A mechanic says it needs to be reprogrammed, but no gaurantees it will work. Any other ideas?

Please help, still having problems. Some are intermittent, still cant open convertible top, radio said disabled, then started working again, blinking lights on dash started to work then stopped, same w/ radio buttons on steering wheel, many more, sometimes all is normal then starts up again. Thanks in advance for your time. I love the car but these issues r driving me nuts.

Last edited by jcruz1994; 07-10-2011 at 08:24 PM.
jcruz1994 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 08:51 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use