E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 1 votes, 5.00 average. Display Modes
Old 09-17-2011, 08:17 PM   #1
volcom_da6
Registered User
 
Join Date: Jan 2011
Location: San Antonio, Texas
Posts: 13
My Ride: 03 325i
Exclamation HELP!!! Car shuts off when i give it gas....

so recently my 03 325i has been acting up on me.the car turns on and stays on untill i put it in reverse or drive and give it gas it shuts off. I ran it low on gas one day and the next day it felt weird. It felt like it was miss-firing and sputtering. I thought it might the spark plugs since i hadn't changed them in over 8 months. so i changed the plugs out and its still the same. Also i just recently replaced the fuel filter about 4 months ago so i thinking it might just be clogged up? the car fight now has 96k miles on it. has anybody ever had this problem? im also thinking its my fuel pump.... please peps help me out i need to get my car running asap thanks for you help!
volcom_da6 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 09-18-2011, 08:06 AM   #2
volcom_da6
Registered User
 
Join Date: Jan 2011
Location: San Antonio, Texas
Posts: 13
My Ride: 03 325i
Anybody ever had this problem?
volcom_da6 is offline   Reply With Quote
Old 09-18-2011, 08:27 AM   #3
Cengawer
Registered User
 
Join Date: Jul 2011
Location: NYC
Posts: 51
My Ride: 325ci Convertible
I would say it's the fuel pump since you said you were running low on gas one day. When you have low gas, all the dirt n gunk in your tank sinks to the bottom and when you add gas on top of that to fill it up, all that gunk mixes therefore going into ur engine through the fuel pump. That would be my best guess.
Cengawer is offline   Reply With Quote
Old 09-18-2011, 06:44 PM   #4
volcom_da6
Registered User
 
Join Date: Jan 2011
Location: San Antonio, Texas
Posts: 13
My Ride: 03 325i
ok any idea where i could find one for a good price? will i have to drop the tank to get to it?
volcom_da6 is offline   Reply With Quote
Old 09-19-2011, 07:16 PM   #5
Cengawer
Registered User
 
Join Date: Jul 2011
Location: NYC
Posts: 51
My Ride: 325ci Convertible
No they go around 30-50 bucks online. You don't need to drop the tank. It's a simple DIY. I've seen posts on how to do it
Cengawer is offline   Reply With Quote
Old 09-19-2011, 07:17 PM   #6
Cengawer
Registered User
 
Join Date: Jul 2011
Location: NYC
Posts: 51
My Ride: 325ci Convertible
Just search ull find it
Cengawer is offline   Reply With Quote
Old 09-20-2011, 09:15 PM   #7
volcom_da6
Registered User
 
Join Date: Jan 2011
Location: San Antonio, Texas
Posts: 13
My Ride: 03 325i
Cool thanks bro!
volcom_da6 is offline   Reply With Quote
Old 09-22-2011, 05:01 PM   #8
volcom_da6
Registered User
 
Join Date: Jan 2011
Location: San Antonio, Texas
Posts: 13
My Ride: 03 325i
just replaced the fuel pump and its still giving me the same problem. the car still shakes and and shuts off asfter a few minutes. what could it be now? i wanna replace the fuel filter again but who knows if that would be the problem....
volcom_da6 is offline   Reply With Quote
Old 10-23-2011, 05:47 PM   #9
HyphyMovementZ
Registered User
 
Join Date: Sep 2010
Location: 510 Bay Area, Ca
Posts: 142
My Ride: ZSP, DC5, EM2
Send a message via Skype™ to HyphyMovementZ
I had the same for me it was the camshaft position sensor
__________________
HyphyMovementZ is offline   Reply With Quote
Old 07-01-2014, 01:59 PM   #10
FERNY_M3
Registered User
 
Join Date: Jun 2014
Location: los angeles
Posts: 11
My Ride: 325i
I have the same problem, now it got worse and even in D when i gently very gently press on the gas pedql and hold it the egine starts to gargol or choke idk but its sounds like its dieing and somtimes it turns off completely. Back then it was just when i was going in reverse now it happens somtimes when its in D. To add this only happens when the car is just turned on in the begining of every day only when its just warming up, aftr that trought the day f i turn it on or off put it in reverse or D its b just fine only does it when the car is turned on for the first time of the day.
FERNY_M3 is offline   Reply With Quote
Old 11-21-2011, 12:43 PM   #11
330i lover
Registered User
 
Join Date: Jan 2011
Location: Nashville
Posts: 53
My Ride: e46 330i
Did this fix the issue? My car is having similar sputtering issues.
330i lover is offline   Reply With Quote
Old 11-21-2011, 12:48 PM   #12
Custom3
Registered User
 
Join Date: Sep 2005
Location: Dirty Jersey
Posts: 5,437
My Ride: HellRot 330CI
any codes?
Custom3 is offline   Reply With Quote
Old 11-23-2011, 11:46 PM   #13
BMWUSMC3051
Registered User
 
Join Date: Nov 2011
Location: California
Posts: 94
My Ride: 2000 BMW 323i
Check intake and exhaust hoses if they have a hole the engine will choke its self out exhaust hose is near washer resivor Intake obvious cost 2$ for a new hose hope this is the problem n this solves it for u did for me
BMWUSMC3051 is offline   Reply With Quote
Old 11-27-2011, 08:27 PM   #14
330i lover
Registered User
 
Join Date: Jan 2011
Location: Nashville
Posts: 53
My Ride: e46 330i
Resolution?
330i lover is offline   Reply With Quote
Old 12-04-2011, 08:36 PM   #15
Rhudeboye
Registered User
 
Join Date: Aug 2010
Location: MD
Posts: 101
My Ride: 968 330i
Yes, please check in on the status.
Rhudeboye is offline   Reply With Quote
Old 12-13-2011, 01:05 AM   #16
howie1971
Registered User
 
Join Date: May 2010
Location: Melbourne, Australia
Posts: 215
My Ride: BMW E46 325Ci
I had this problem I replaced fuel pump yesterday and it seems to have fixed the problem (I ran out of fuel twice, it seems they are pretty sensitive) however I still have a vacuum leak, I have taken off the intake hoses and can not see anything perhaps I will try the exhaust hose.
howie1971 is offline   Reply With Quote
Old 12-19-2011, 05:45 AM   #17
330i lover
Registered User
 
Join Date: Jan 2011
Location: Nashville
Posts: 53
My Ride: e46 330i
Yeah, I'm still having the issues. If my warranty doesnt cover it then i'll buy a pump from pelican parts. Did you have to replace anything else other than the fuel pump assembly? Fuel pump seal or a relay?
330i lover is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 06:58 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use