E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 01-04-2012, 02:20 PM   #1
traxem
Registered User
 
Join Date: Nov 2011
Location: Seattle
Posts: 6
My Ride: 325i
Send a message via AIM to traxem
Angry 2004 E46 - TCU buzzing and whining problem

I recently swapped my TCU (with assist) out for a new one (with assist and bluetooth). Picked it up brand new at the dealer. Right out of the box, it paired up and voice command was functional. However, when the system is activated (either when phone is in-use or voice command is activated), there is a constant background "hum" when the key is on position II (DRL on) and a high-pitch whine when the engine is on. It sounds like a bad ground. The system is flawless when the key is on the I position (radio power only).

I asked the dealer to diagnose the problem. After an hour of labor ($$), the tech told me that he couldn't figure it out and recommend programming since it was never programmed. After another 1.5 hours (more $$$) for programming, the problem is still there!

Refusing to declare the unit defective, the tech is telling me that there was an install kit that came with a harness. The dealer suspects that the missing harness (that BMW NA doesn't make anymore) might cure the problem. They won't install another TCU to test it because they can't resell it after it's been installed. They told me that I can buy another TCU and if that fixes the problem, then they'll take the old TCU back (as defective). But if the new TCU also has the same problem then I'm stuck with two TCUs.

The sound is similar to a bad ground. I saw similar problems in other threads but no solution.

Does anyone have any suggestion other than to buy another TCU to test it?
traxem is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 01-04-2012, 10:37 PM   #2
traxem
Registered User
 
Join Date: Nov 2011
Location: Seattle
Posts: 6
My Ride: 325i
Send a message via AIM to traxem
Anybody?

My symptoms are identical to this thread:
http://forum.e46fanatics.com/showthr...tooth+retrofit

No solution posted in that one. I'm at a lost here. I rechecked all the connection to the TCU. Nothing is loose.
traxem is offline   Reply With Quote
Old 10-27-2012, 06:54 PM   #3
traxem
Registered User
 
Join Date: Nov 2011
Location: Seattle
Posts: 6
My Ride: 325i
Send a message via AIM to traxem
Problem resolved

I recently swapped out my CD player with a newer one (that plays Mp3). My original unit had some problems so I had to swap it out anyway. After swapping out the CD player, the entire problem went away. The buzz and whining noise is gone. The bluetooth is also now crystal clear to the other side now; no more complaints about wind and road noise.

Apparently, my original CD player (late 2003 production) wasn't compatible with the new TCU.
traxem is offline   Reply With Quote
Reply

Tags
bluetooth, e46, tcu

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 03:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use