E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 02-09-2012, 09:58 AM   #1
Jono149
Registered User
 
Join Date: Oct 2010
Location: Overland Park, KS
Posts: 22
My Ride: 2001 330ci
330ci Power Loss / Limp Mode?

My car (2001 330ci) has been acting up occasionally for the past several months. It will basically go into (what I think is) limp mode. It just doesn't have nearly as much power, almost like not all the cylinders are firing although it still runs smooth.
The service engine light came on about the time it started acting up, I ran the codes and it kicked back all 4 O2 sensors and the camshaft position sensor (all of which I replaced, but it's still acting up). I also replaced the spark plugs at the same time.
It doesn't do it every time I start the car, but it's happening more and more often. Sometimes it will have to crank a couple of seconds before the engine starts.
The only other thing I can think to try is replacing the ECU.

Any other ideas? Thanks in advance for your help!!!
__________________
Jono149 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 02-09-2012, 11:43 AM   #2
Akovski
Registered User
 
Join Date: Dec 2008
Location: ATL
Posts: 474
My Ride: 323CI
try cleaning your throttle body
Akovski is offline   Reply With Quote
Old 02-09-2012, 12:17 PM   #3
van
Registered User
 
Join Date: Apr 2006
Location: Orlando
Posts: 133
My Ride: 330ci
Send a message via AIM to van
My car is having the same issue, so far I have replaced the Vanos Seals, DISA valve and 02 sensors but no DICE. Just ordered both CPS sensors and hopefully that would cure my powerloss. Have you changed your Vanos seals? I say try doing that.
__________________
van is offline   Reply With Quote
Old 02-09-2012, 01:52 PM   #4
Snash756
Registered User
 
Join Date: Mar 2009
Location: UK
Posts: 1
My Ride: 330 Ci Sport
Hey guys, my 330Ci M Sport had similar issues and turned out to be a split in the intake rubber hose, the small pipe that cmes off the main intake pipe to the throttle body. This is where they usually split.... Might be worth a look...

Item 6 on here
http://realoem.com/bmw/showparts.do?...05&hg=13&fg=15
Snash756 is offline   Reply With Quote
Reply

Tags
2001 330ci, diagnostic, ecu, limp mode, power

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 08:58 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use