E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 1 votes, 5.00 average. Display Modes
Old 03-06-2012, 05:13 AM   #1
Mc 007
Registered User
 
Join Date: Nov 2006
Location: Cittanova d'Istria-Croazia(Europa)
Posts: 2,237
My Ride: 325ci Performance
Question 325ci trouble over 4000rpm

hello,i have one trouble with my 325ci,over 4000-5000 rpm the yellow motor light switch on and the motor work 5 cilinders,stop and restart the motor works fine

pc control tells trouble on the 4 cilinder,change the ignition coil and the same...

can be the trouble the spark plug or the injection valve?

spark plugs are ngk and have 20 000km

thanks
__________________
Mc 007 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 03-06-2012, 07:19 AM   #2
dmax
Registered User
 
dmax's Avatar
 
Join Date: Aug 2006
Location: NJ
Posts: 22,859
My Ride: '99 328i 1.04646 mu
It could be either the plug or the injector...you did change the coil boot with coil I assume? I'm not sure you can even get the coil without the boot, but I don't know.

Your plug might just be loose...
__________________


Performing at the Comedy Cove--595 Morris Ave. Springfield NJ reservations 973 376-3840

A recent set Skip to 1:30
dmax is online now   Reply With Quote
Old 03-06-2012, 09:22 AM   #3
Mc 007
Registered User
 
Join Date: Nov 2006
Location: Cittanova d'Istria-Croazia(Europa)
Posts: 2,237
My Ride: 325ci Performance
we have change today all 6 spark plugs,we have move the the injector and always the same on the 4 cilinder,trouble over 4000rpm

i have this
http://bmwfans.info/parts/catalog/E4...il_spark_plug/
__________________

Last edited by Mc 007; 03-06-2012 at 09:24 AM.
Mc 007 is offline   Reply With Quote
Old 03-06-2012, 09:35 AM   #4
Drewfus2101
Registered User
 
Join Date: Jan 2009
Location: N/A
Posts: 626
My Ride: N/A
I would try a compression test and a leak-down test. It sounds like there is something wrong with that cylinder head, valves, piston, etc.
Drewfus2101 is offline   Reply With Quote
Old 03-06-2012, 09:39 AM   #5
Mc 007
Registered User
 
Join Date: Nov 2006
Location: Cittanova d'Istria-Croazia(Europa)
Posts: 2,237
My Ride: 325ci Performance
compression test made 12,5-13 on all the cilinders...
the car works fine,no noises,goes perfect to 4000rpm in all the speeds
__________________
Mc 007 is offline   Reply With Quote
Old 03-06-2012, 10:21 AM   #6
AquaRelliux
Registered User
 
Join Date: Oct 2010
Location: Sweden
Posts: 456
My Ride: 330ci 03 M-sport
Maybe a longshot but since u checked everything else, hows your fuel filter and pump doing?
AquaRelliux is offline   Reply With Quote
Old 03-06-2012, 10:27 AM   #7
Solidjake
Zero. Leaks.
 
Solidjake's Avatar
 
Join Date: May 2008
Location: NYC
Posts: 23,140
My Ride: 2002 330i
Any rattling with your DISA?
Solidjake is offline   Reply With Quote
Old 03-06-2012, 10:29 AM   #8
Mc 007
Registered User
 
Join Date: Nov 2006
Location: Cittanova d'Istria-Croazia(Europa)
Posts: 2,237
My Ride: 325ci Performance
the fuel filter has maybe 20 000km,the pump is old 5 years(i change it 1 year after i buy the car),the disa has 2 years
__________________
Mc 007 is offline   Reply With Quote
Old 03-06-2012, 10:31 AM   #9
straight_beamin
Registered User
 
Join Date: Apr 2010
Location: niagara falls
Posts: 797
My Ride: 2000 bmw 323i
swap cyl 4 coil with cyl 5 if the misfire moves with the coil you have your answer. i had same prob, tried everything. turns out its a 60 dollar coil
__________________
straight_beamin is offline   Reply With Quote
Old 03-06-2012, 10:34 AM   #10
Mc 007
Registered User
 
Join Date: Nov 2006
Location: Cittanova d'Istria-Croazia(Europa)
Posts: 2,237
My Ride: 325ci Performance
i have try this solution,change coil,spark plug,injector...and always cilinder 4 error

maybe is a trouble with engine wiring harness
http://bmwfans.info/parts/catalog/E4...trical_system/
__________________

Last edited by Mc 007; 03-06-2012 at 10:36 AM.
Mc 007 is offline   Reply With Quote
Old 03-06-2012, 11:14 AM   #11
Drewfus2101
Registered User
 
Join Date: Jan 2009
Location: N/A
Posts: 626
My Ride: N/A
Was the compression test done correctly? Dry or wet? Hot or cold? Also, we have no idea what those numbers mean, so we can't really tell if those are within spec. But usually if all cylinders are within a few % of each other, thats a good sign.

Also, a leak down test is more accurate than a compression test, but the tester is much harder to find.
Drewfus2101 is offline   Reply With Quote
Old 03-06-2012, 11:28 AM   #12
Mc 007
Registered User
 
Join Date: Nov 2006
Location: Cittanova d'Istria-Croazia(Europa)
Posts: 2,237
My Ride: 325ci Performance
all 6 cilinders have the same compression
__________________
Mc 007 is offline   Reply With Quote
Old 03-06-2012, 12:48 PM   #13
jasonbimmer
Registered User
 
Join Date: Sep 2011
Location: Omaha, NE
Posts: 5,686
My Ride: 2001 BMW 330xi
injector?
__________________
2009 Mazda RX-8 R3
2013 Toyota FJ Cruiser
2008 YAMAHA YZF-R6
jasonbimmer is offline   Reply With Quote
Old 03-06-2012, 12:52 PM   #14
Mc 007
Registered User
 
Join Date: Nov 2006
Location: Cittanova d'Istria-Croazia(Europa)
Posts: 2,237
My Ride: 325ci Performance
injectors are ok,tested,engine wiring tested and are ok,error code is P1349

tomorrow we can test the disa,we can put the disa of my fathers 320i on my 325
__________________
Mc 007 is offline   Reply With Quote
Old 03-06-2012, 12:54 PM   #15
jasonbimmer
Registered User
 
Join Date: Sep 2011
Location: Omaha, NE
Posts: 5,686
My Ride: 2001 BMW 330xi
Quote:
Originally Posted by Mc 007 View Post
injectors are ok,tested,engine wiring tested and are ok,error code is P1349

tomorrow we can test the disa,we can put the disa of my fathers 320i on my 325
usually with that specific kind of missfire/fuel cut off, its caused by compression.
__________________
2009 Mazda RX-8 R3
2013 Toyota FJ Cruiser
2008 YAMAHA YZF-R6
jasonbimmer is offline   Reply With Quote
Old 03-06-2012, 01:22 PM   #16
Mc 007
Registered User
 
Join Date: Nov 2006
Location: Cittanova d'Istria-Croazia(Europa)
Posts: 2,237
My Ride: 325ci Performance
compression is perfect,all 6 cilinders have the same compression
__________________
Mc 007 is offline   Reply With Quote
Old 03-07-2012, 08:41 AM   #17
Drewfus2101
Registered User
 
Join Date: Jan 2009
Location: N/A
Posts: 626
My Ride: N/A
Quote:
Originally Posted by Mc 007 View Post
compression is perfect,all 6 cilinders have the same compression
This doesn't mean that there isn't a problem. A true leak-down tester can show you more specifically where a potential problem is. Google it. They are cheap.

Or...just keep throwing parts at it...
Drewfus2101 is offline   Reply With Quote
Old 03-06-2012, 01:48 PM   #18
Mc 007
Registered User
 
Join Date: Nov 2006
Location: Cittanova d'Istria-Croazia(Europa)
Posts: 2,237
My Ride: 325ci Performance
tomorrow we can control the disa...other is perfect
__________________
Mc 007 is offline   Reply With Quote
Old 03-06-2012, 11:06 PM   #19
///Mostarac
Registered User
 
///Mostarac's Avatar
 
Join Date: Jun 2010
Location: Bosnia-Hercegovina, New Jersey
Posts: 4,972
My Ride: SiennaE46 & Cbr600rr
neznam sta bi ti reko brate, nikad nisam cuo za ovo. maybe a vacuum leak?
__________________
PARTING OUT MY CAR!!!!!! CLICK HERE
Eurowerkz | East Coast
-Benny
///Mostarac is offline   Reply With Quote
Old 03-07-2012, 04:34 AM   #20
Mc 007
Registered User
 
Join Date: Nov 2006
Location: Cittanova d'Istria-Croazia(Europa)
Posts: 2,237
My Ride: 325ci Performance
my fathers car is now in the mechanic station,we must test
__________________
Mc 007 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 09:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use