E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 4 votes, 5.00 average. Display Modes
Old 07-25-2012, 03:21 PM   #1
Sk8orkidd
Registered User
 
Join Date: Jul 2012
Location: Orlando, FL
Posts: 10
My Ride: 2003 BMW 325ci
Exclamation EML Light Issue

I recently bought a 2003 325 ci with about 120k on it. I am a very mechanically inclined person, so I normally do all the work on my cars myself. I was driving the bimmer for about 6 hours after purchasing when the EML light turned on. I did a lot of forum research trying to figure out what it was. I took it to Advanced auto parts to have the codes run, and they told me it was the idle control valve. I took that out, cleaned it, replaced it. The EML light comes on, usually at lower speeds at this point, but turns off every time you shut the car off. it doesn't turn on when the car is sitting still, only when moving. I took it to a Eurosport shop then, and they told me the same thing, saying that the Idle control valve had thrown 261 error codes since the last reset. They said the best route was to replace the valve. I bought a new valve and just replaced it yesterday. About 24 hours later when going to lunch today, the EML light turns back on. I am rather confused on what this could be. If anyone else has this problem, maybe there is a common issue?
Sk8orkidd is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 07-26-2012, 01:34 AM   #2
TynWarrior
Registered User
 
Join Date: Mar 2012
Location: Ithaca, NY
Posts: 154
My Ride: '95 M3, '00 323i
Shitty. I guess first/obvious question is did you replace ICV right? haha Either way don't think ICV would trip EML.
what exactly is the code are getting, has it thrown 261 codes or is the code 261?
__________________
TynWarrior is offline   Reply With Quote
Old 07-26-2012, 01:57 AM   #3
zbi701
Registered User
 
Join Date: Aug 2009
Location: Malaysia
Posts: 250
My Ride: E46 318i
EML normally related to your throttle body and accelerator pedals if you have drive by wire option.
zbi701 is offline   Reply With Quote
Old 07-26-2012, 10:04 AM   #4
Sk8orkidd
Registered User
 
Join Date: Jul 2012
Location: Orlando, FL
Posts: 10
My Ride: 2003 BMW 325ci
The code that was thrown 261 times was a p1500 (Idle speed control valve stuck open), which to me doesn't make sense because the idle speed seemed to be fine and it wasnt fluctuating. The other thing is I think it is temperature related, I live in orlando, fl so its hot a ballz out right now. It seems to want to turn the EML light on more when the car is hot, thus if driving around noon to 6 its about 97 out during that time of day. The only reason I tried to change the ICV is that was the most prevalent code on the system. There were no codes about failing Mass Air flow, or throttle body. What can I do about the drive by wire if that is the case? Any way to test that? I am going to the shop today, because they said they would re-diagnose for free because I already paid them for the diag last time.
Sk8orkidd is offline   Reply With Quote
Old 11-08-2012, 07:04 PM   #5
03E40sick
Registered User
 
Join Date: Feb 2009
Location: Metairie, La
Posts: 228
My Ride: 2003 bmw 325ci
Send a message via Yahoo to 03E40sick Send a message via Skype™ to 03E40sick
What was the issue , did you fix the problem ?
__________________
bimmers is the way to go........
03E40sick is offline   Reply With Quote
Old 11-08-2012, 08:02 PM   #6
alinfaraonu
Registered User
 
Join Date: Nov 2012
Location: coventry
Posts: 6
My Ride: 320i
I hawe problem ENGINE, EML and DSC,hand brake on all yellow.U find the problem pls help me
alinfaraonu is offline   Reply With Quote
Old 11-19-2012, 07:10 PM   #7
wasp9166
ima touching member
 
wasp9166's Avatar
 
Join Date: Dec 2007
Location: straight out da bronx
Posts: 5,259
My Ride: 04 330i jet black
Send a message via Yahoo to wasp9166
Quote:
Originally Posted by alinfaraonu View Post
I hawe problem ENGINE, EML and DSC,hand brake on all yellow.U find the problem pls help me
the last 3 are all related to dsc system, you have a bad wheel sensor, need an indy with carsoft or the like to find which one

the cel, is prob the bad sensor code
__________________

"if polarity comes from protons, does morality come from morons?"

Quote:
Originally Posted by russ330 View Post
"Mommy and Daddy are getting a divorce now because wasp9166 had to piitb with Mom."

Last edited by wasp9166; 11-19-2012 at 07:11 PM.
wasp9166 is offline   Reply With Quote
Old 11-08-2012, 08:25 PM   #8
Dippinwandy
Registered User
 
Join Date: Oct 2011
Location: SoCal- 310
Posts: 254
My Ride: 325i
This sounds very similar to my problem.. Did you ever find out what the problem was ?
Dippinwandy is offline   Reply With Quote
Old 11-08-2012, 08:29 PM   #9
Sk8orkidd
Registered User
 
Join Date: Jul 2012
Location: Orlando, FL
Posts: 10
My Ride: 2003 BMW 325ci
No fix yet

No fix yet, but now that the weather is cold, the problem occurs much less frequently. But the car now has a hard time starting in the morning and is rough idle until the engine warms up. Seems to me that I have a faulty idle control valve or somethign that sense the idle in that area.
Sk8orkidd is offline   Reply With Quote
Old 11-08-2012, 08:41 PM   #10
Barneyhyphen
Registered User
 
Join Date: Aug 2005
Location: Nashville, Tn
Posts: 277
My Ride: 2004 M3 Convertible
ICV will DEFINITELY throw you a EML, did it for me. The problem with mine was that the valve, although cleaned out, was actually stuck.

My resolve was to take the ICV out and take it apart to thoroughly clean it. All now resoled for me.

the ICV should open and close very freely, if you hold the unit in your hand a oscillate it, you will be able to see/feel it rotating back and forth. But you say you've fitted a new ICV? Actually New or a used one from elsewhere?

BH
Barneyhyphen is offline   Reply With Quote
Old 11-08-2012, 08:36 PM   #11
SweTurbo
Big Pimpin'
 
Join Date: Nov 2008
Location: Europe
Posts: 2,899
My Ride: 323i -98
EML is throttle related , might be ICV aswell but not sure.

Wiring could be a problem so if you can get another harness for your ecu then try that
SweTurbo is offline   Reply With Quote
Old 11-08-2012, 09:59 PM   #12
Dippinwandy
Registered User
 
Join Date: Oct 2011
Location: SoCal- 310
Posts: 254
My Ride: 325i
Quote:
Originally Posted by Sk8orkidd View Post
No fix yet, but now that the weather is cold, the problem occurs much less frequently. But the car now has a hard time starting in the morning and is rough idle until the engine warms up. Seems to me that I have a faulty idle control valve or somethign that sense the idle in that area.
This sounds exactly like my symptoms
Dippinwandy is offline   Reply With Quote
Old 11-08-2012, 10:00 PM   #13
Dippinwandy
Registered User
 
Join Date: Oct 2011
Location: SoCal- 310
Posts: 254
My Ride: 325i
Quote:
Originally Posted by Barneyhyphen View Post
ICV will DEFINITELY throw you a EML, did it for me. The problem with mine was that the valve, although cleaned out, was actually stuck.

My resolve was to take the ICV out and take it apart to thoroughly clean it. All now resoled for me.

the ICV should open and close very freely, if you hold the unit in your hand a oscillate it, you will be able to see/feel it rotating back and forth. But you say you've fitted a new ICV? Actually New or a used one from elsewhere?

BH
When i replaced it i got a used one off of a totaled e46
Dippinwandy is offline   Reply With Quote
Old 11-08-2012, 10:49 PM   #14
Barneyhyphen
Registered User
 
Join Date: Aug 2005
Location: Nashville, Tn
Posts: 277
My Ride: 2004 M3 Convertible
I believe you MAY have TWO stuck ICV's, your old one and the "new" one from the totaled car?

Take the ICV apart to clean it. The three blobs on the end, that look kind of like rivets are actually allen bolts with a blob of hard epoxy stuff on them, presumably to dissuade you from taking it apart. Practice on your old one first. I did a little write up on it a couple of weeks ago. Search ICV by barneyhyphen.

BH
Barneyhyphen is offline   Reply With Quote
Old 11-09-2012, 06:21 AM   #15
Sk8orkidd
Registered User
 
Join Date: Jul 2012
Location: Orlando, FL
Posts: 10
My Ride: 2003 BMW 325ci
update

I bought a refurbished ICV from autohauaz.com and it seemed to help for a while. I also did a valve cover gasket job and the oil filter stand gasket at the same time. The car had an oil leak, but that was solved easily. The funny thing is once i replaced the ICV the EML problem would only occur maybe twice a week and could be fixed by cycling the engine on/off. When the weather became colder (Florida) the car now barely starts in the AM and tends to want to quit when at idle, either at traffic lights or in the parking lot. Just last night i believe that the car is now misfiring a result of these problems. If i clean the ICV and the problem persists, what do you think it coulds be?
Sk8orkidd is offline   Reply With Quote
Old 11-09-2012, 12:14 PM   #16
03E40sick
Registered User
 
Join Date: Feb 2009
Location: Metairie, La
Posts: 228
My Ride: 2003 bmw 325ci
Send a message via Yahoo to 03E40sick Send a message via Skype™ to 03E40sick
Did you check for any vacuum leaks, I would suggest to start with that, then clean the ICV, throttle body, and MAF... I get the eml,traction control, and brake ( all in yellow ) once a day at least .. Haven't not replaced anything yet, but my car idles good and there are no leaks at alll.. I have a check engine light with- idle control valve stock open which is code p1500 .. I might end up replacing that soon...keep us updated
__________________
bimmers is the way to go........
03E40sick is offline   Reply With Quote
Old 11-09-2012, 03:06 PM   #17
Dippinwandy
Registered User
 
Join Date: Oct 2011
Location: SoCal- 310
Posts: 254
My Ride: 325i
I will open up my old icv once i find it. I replaced my intake boots, and i have a brand new oe maf
Dippinwandy is offline   Reply With Quote
Old 11-09-2012, 04:27 PM   #18
03E40sick
Registered User
 
Join Date: Feb 2009
Location: Metairie, La
Posts: 228
My Ride: 2003 bmw 325ci
Send a message via Yahoo to 03E40sick Send a message via Skype™ to 03E40sick
Do you still have the same issue ?
__________________
bimmers is the way to go........
03E40sick is offline   Reply With Quote
Old 11-09-2012, 06:22 PM   #19
Dippinwandy
Registered User
 
Join Date: Oct 2011
Location: SoCal- 310
Posts: 254
My Ride: 325i
Yes i do.
Dippinwandy is offline   Reply With Quote
Old 11-09-2012, 06:57 PM   #20
Mango
A full five stars, son
 
Mango's Avatar
 
Join Date: Mar 2006
Location: Southern California
Posts: 23,223
My Ride: M54B30
If your car ever develops a fault such as this one, the best thing to do is do things that need to be done anyway. In this particular case, cleaning and resealing the TB, DISA, ICV, and MAF would be a great start.
__________________
A lifetime free of problems if you follow my guides
Cooling | Maintenance | Suspension | Vacuum | Supreme Reliability | Details

OVER A MILLION VIEWS
Mango is offline   Reply With Quote
Reply

Tags
325i, emission, eml, error code

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 11:17 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use