E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 01-18-2013, 10:37 AM   #1
glhx
Registered User
 
Join Date: Jan 2012
Location: Nashville, Tennessee
Posts: 923
My Ride: 2002 BMW 330ci
CEL light on....SAP bad and other engine performance problems

I received an item that allows me to use the torque pro app today.

vacuum 24 according to torque pro
engine rpm 700
engine rpm in drive 640 rpm
coolant temp was 84C
throttle showed at 10
o2 sensor data bouncing between .1and .7 volts will post pictures between the bank 1 and 2
they do look different. bank 1 is more up and down and bank two is more smooth.
post cat o2 runs live at .45 straight across

obd rediness....evap is unready
SAP system unready (because its not even on the car right now) The electric motor melted.

o2, catalyst, o2 heater.....show ready

I used PA soft to get bmw specific codes because the CEL was on
The first time was
P0491 = Secondary Air Injection System Insufficient Flow (Bank 1)
P0492 = Secondary Air Injection System Insufficient Flow (Bank 2)

I cleared it and a day later i got
E4/B1 - Oxygen sensor controller, bank 2, deviation too great, deviation rich
E3/B1 - Oxygen sensor controller, bank 1, deviation too great, deviation rich

I know the SAP is not working and that the pump is bad.

Could this be why my car is running so rich? Average gas mileage is decreasing and is now down to 15mpg on the obc

Last edited by glhx; 01-18-2013 at 02:18 PM.
glhx is online now   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 01-18-2013, 12:53 PM   #2
enzo_the_baker
Registered User
 
Join Date: Oct 2003
Location: Scenic Hudson Valley, NY
Posts: 115
My Ride: 328Ci, 328iC, X3
Quote:
Originally Posted by glhx View Post
I know the SAP is not working and that the pump is bad.

Could this be why my car is running so rich? Average gas mileage is decreasing and is now down to 15mpg on the obc
The SAP would not affect fuel economy, since it only operates for the first couple of minutes after a cold start. Look elsewhere-- maybe the MAF is mis-measuring the intake air and throwing too much fuel into the cylinders?
__________________
Got Miles?

2000 328Ci Steptronic
Original Engine & Transmission
Original Transmission Fluid
15K Oil Changes
So there!
enzo_the_baker is offline   Reply With Quote
Old 01-18-2013, 02:31 PM   #3
glhx
Registered User
 
Join Date: Jan 2012
Location: Nashville, Tennessee
Posts: 923
My Ride: 2002 BMW 330ci
My SAP may have been bad for a long time and I not know it because i dont know what its supposed to sound like. I know ive never heard any distinct noises from that area while under the hood ever.

The SAP sends fresh air to warm up the cats....also sends fresh air to help burn the rich fuel when cold starting. This is where i could think they are related.

Did running rich for a long period of time on cold starts carbon foul the o2 sensor.....which is past its replacement date anyway. only speculating here.

my thoughts on this are that one or both of my precat o2 sensors are bad and went bad over time due to lack of SAP and wear and tear.

i would like a diagram or picture of which connectors go to all 4 o2 sensors just to make sure they are in the right spots. i believe they are but i want to be sure. Who knows who worked on this thing before i owned it. Whoever it was neglected it and ive had to sort all kinds of stuff out.

It could be the MAF....i found an app to measure MAF in g/sec. havent done this yet.

Last edited by glhx; 01-18-2013 at 02:57 PM.
glhx is online now   Reply With Quote
Old 01-18-2013, 02:51 PM   #4
jdstrickland
Registered User
 
Join Date: Apr 2010
Location: Murrieta, CA
Posts: 6,947
My Ride: '94 325iC & '00 323i
Quote:
Originally Posted by glhx View Post
My SAP may have been bad for a long time and I not know it because i dont know what its supposed to sound like. I know ive never heard any distinct noises from that area while under the hood ever.

The SAP sends fresh air to warm up the cats....also sends fresh air to help burn the rich fuel when cold starting. This is where i could think they are related.

Did running rich for a long period of time on cold starts carbon foul the o2 sensor.....which is past its replacement date anyway. only speculating here.

my thoughts on this are that one or both of my precat o2 sensors are bad and went bad over time due to lack of SAP and wear and tear.

It could be the MAF....i found an app to measure MAF in g/sec. havent done this yet.
The SAP _only_ provides fresh air to help the CAT work efficiently while it is still cold. There is no other purpose for the SAP.

The CAT uses a chemical process and heat to help clean the exhaust and reduce emissions. The CAT does not work well while it is cold, but it works better if cold AND there is fresh air available as a substitute. Once the CAT warms up, the fresh air is not needed, until the CAT warms up the fresh air helps the CAT do what it is supposed to do.

The SAP has no bearing on your mileage. None. Not any. Not ever.
jdstrickland is offline   Reply With Quote
Old 01-18-2013, 03:01 PM   #5
enzo_the_baker
Registered User
 
Join Date: Oct 2003
Location: Scenic Hudson Valley, NY
Posts: 115
My Ride: 328Ci, 328iC, X3
Quote:
Originally Posted by glhx View Post
My SAP may have been bad for a long time and I not know it because i dont know what its supposed to sound like. I know ive never heard any distinct noises from that area while under the hood ever.

The SAP sends fresh air to warm up the cats....also sends fresh air to help burn the rich fuel when cold starting. This is where i could think they are related.

Did running rich for a long period of time on cold starts carbon foul the o2 sensor.....which is past its replacement date anyway. only speculating here.

my thoughts on this are that one or both of my precat o2 sensors are bad and went bad over time due to lack of SAP and wear and tear.

It could be the MAF....i found an app to measure MAF in g/sec. havent done this yet.
The SAP doesn't "warm up" the cats (can't warm something with cold fresh air), it just pumps additional air into the exhaust to help burn off uncombusted fuel until the cats get hot enough to do so on their own. I suppose it's possible that you have a bad O2 sensor, but for both to come up with faults at the same time makes me suspect that it's something else upstream that's causing both sensors to throw fuel mixture codes.

Also, if your SAP had not been working it should have lit up the SES light.
__________________
Got Miles?

2000 328Ci Steptronic
Original Engine & Transmission
Original Transmission Fluid
15K Oil Changes
So there!

Last edited by enzo_the_baker; 01-18-2013 at 03:03 PM.
enzo_the_baker is offline   Reply With Quote
Old 01-18-2013, 03:07 PM   #6
jfoj
Registered User
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 10,441
My Ride: '06 330CiC, '03 M5
Careful before you get ahead of yourself on these issues.

Once you get tools in your hands that can read codes and data, you have to stop and think EVERYTHING through!

SAP actually is there to both warm Catalytic converters quickly but also to help warm O2 sensor and to allow sensor to toggle to full Lean before going into closed loop, which actually takes less time than you may think with SAP and heated O2 sensors.

Here is a BIG suggestion. Do not worry about fuel economy yet. Let this work its way out while you sort all your other problems.

Also sort your problems 1 at a time. This will allow you to check off things each step of the way.

Not sure your mileage or history on the car. The biggest things that impact mileage are: Pre-cat O2 sensors, spark plugs and secondary ignition MAF, thermostat, DISA, VANOS. VANOS is more than the VANOS seals, this could be Camshaft position sensors, VANOS solenoids and other items.

Here are some suggestions.

1. See the 3rd link in my signature, run a cluster test for your dash and make sure your CEL and other indicators are working. Many times when people cannot get the CEL out, the put take over the CEL behind the cluster face or worse, they get out the wirecutters or epoxy!!

2. Using the 3rd link in my signature and/or some of your software tools verify your engine cooling temp. Your engine should get up to 90-95C in under 10 minutes even in cold temps. The engine should stay at or above about 90C unless you are running the engine over 3k RPM when the electrical heating element starts to reduce the engine temp. See this link - http://forum.e46fanatics.com/showthread.php?t=964491

3. Try to get your SAP sorted, used pump would be what I would suggest of now.

4. If you Pre-cat O2 sensors are OLD, suggest replacing them new Bosch units. Replace them in pairs, I get mine on Amazon for about $50 each. These are consumable and do not last for ever. The worse the engine runs, the shorter time they last.

5. Make sure someone has not swapped the O2 sensor wiring wither up top or down below. This is pretty easy to do. The simple way to figure this out is disconnect any 1 O2 sensor wire and see what code is triggered and what bank the code is for. This way you can verify the proper O2 sensor is connected. Once you know the O2 sensors are for the correct bank, suggest you label them to help with future maintenance and troubleshooting.

6. If you have not checked your intake air path, intake boots, DISA and CCV, suggest you do this and also read the first link below in my signature.

7. BE CAREFUL about nomenclature on some of the tools. I believe the PA Soft deviation Rich actually means the engine is running lean and has deviated to enrich the mixture the maximum it can and has hit a wall on the adjustment. Suggest you use your Torque Pro App and compare readings and see what Torque Pro is finding.

8. Try to use Torque Pro to graph your O2 sensor performance on cold start once you have the SAP operational. This is kind of important as you can compare your car to some baseline good cars. O2 sensors should read about 0.45 Volts when cold and inactive and should then toggle between 0.1-0.9 Volts pretty rapidly. See this post here - http://forum.e46fanatics.com/showthread.php?t=954362

9. Note there are some cheap/counterfeit MAF's on the market that use thermistors rather than hot film sensor and they usually under report the airflow even at idle an cause lean problems.

10. If you are getting freeze frame codes, please capture the info and post it as well.

Try to provide updates with what you have found correct and/or repaired and advise what is still outstanding.

Also try to list at some point what new parts have been installed on the car so we can all figure out what parts have been updated. Also please note that not all new parts work correctly, so hold on to the originals until you have your problems fully solved.

Good luck and keep at it, you will get the issues resolved.
__________________
Solve your misfires, lean codes, rough idle - http://forum.e46fanatics.com/showthread.php?t=897616

Fuel pump failures - http://forum.e46fanatics.com/showthread.php?t=929501

Temp Info - http://forum.e46fanatics.com/showthread.php?t=964491

Hidden OBC Menu - Check Voltage, Temps, Fuel Level - http://forum.e46fanatics.com/showthread.php?t=239619

E46/E39 GM5 Door Lock Info - www.bmwgm5.com

Lower hose fan switch O-ring - BMW #13621743299
jfoj is offline   Reply With Quote
Old 01-18-2013, 03:57 PM   #7
glhx
Registered User
 
Join Date: Jan 2012
Location: Nashville, Tennessee
Posts: 923
My Ride: 2002 BMW 330ci
on a retest.....i am getting

readiness for obd
catalyst
secondary air
o2 sensor
evap ......all incomplete

o2 sensor heater was incomplete.....when i turned off the car and turned it back on it showed complete.

the bmw scanner 1.4,0 showed everything to be in the green.

temperature at idle after ten minutes was 96C
Attached Thumbnails
Click image for larger version

Name:	screenshot.jpg
Views:	63
Size:	231.5 KB
ID:	486669   Click image for larger version

Name:	screenshot_2.jpg
Views:	57
Size:	54.7 KB
ID:	486670   Click image for larger version

Name:	screenshot_3.jpg
Views:	47
Size:	58.8 KB
ID:	486671   Click image for larger version

Name:	screenshot_4.jpg
Views:	45
Size:	62.2 KB
ID:	486672  

Click image for larger version

Name:	screenshot_8.jpg
Views:	53
Size:	57.2 KB
ID:	486673   Click image for larger version

Name:	screenshot_9.jpg
Views:	54
Size:	219.5 KB
ID:	486674  

Last edited by glhx; 01-18-2013 at 04:45 PM.
glhx is online now   Reply With Quote
Old 01-18-2013, 04:54 PM   #8
glhx
Registered User
 
Join Date: Jan 2012
Location: Nashville, Tennessee
Posts: 923
My Ride: 2002 BMW 330ci
what ive replaced.....1 year ago or 15k

car has 130,000 on it

ccv
Correct Disa O-ring. its in there snug
lower intake boot
throttle body gasket
spark plugs
water pump
thermostat....3 days ago
upper intake boot well checked for cracks
intake vacuum caps
sap vacuum lines
fuel filter and vac lines
cleaned ICV....didnt really need it
cleaned every connection point for sensors with contact cleaner

SAP was checked.....vacuum to check valve was 18
check valve open and i can blow into it....closes and i cant
SAP not getting power from relay
SAP hot wired directly....not pumping air....disassembled and found to be overheated and burned up base where the brushes go......RELAY BAD, SAP BAD.....relay probably caused SAP to go
bad. with a better relay that would take more amps it would not have burned up. with regular maintenance of the check valve every 100,000 miles with a seafoam cleaning....hose replaced and carbon cleaned i dont think it would ever fail. the most complex part is the electric motor and the top bearing...the bottom bearing is just a bushing. Thats why im going to get one used. I might get a new check valve for it.

car ran 25mpg average.....last month went to 19mpg average. Whatever failed...just failed recently. and your right.....both 02 sensors probably didnt go bad at the same time but could have.

will check connections to make sure they are right at the o2 sensors.

pa soft cluster test shows everything good. cel works fine

cannot find fuel trims in the torque pro app. I would like to thank all of you for help with this. This car is challenging and bring me to a level of understanding i didnt have before.

Last edited by glhx; 01-18-2013 at 06:01 PM.
glhx is online now   Reply With Quote
Old 01-18-2013, 05:30 PM   #9
glhx
Registered User
 
Join Date: Jan 2012
Location: Nashville, Tennessee
Posts: 923
My Ride: 2002 BMW 330ci
found fuel trims in torque pro...had to download a plugin. will check them
at idle cold, warm and cruising.

Last edited by glhx; 01-18-2013 at 06:05 PM.
glhx is online now   Reply With Quote
Old 01-18-2013, 02:47 PM   #10
jdstrickland
Registered User
 
Join Date: Apr 2010
Location: Murrieta, CA
Posts: 6,947
My Ride: '94 325iC & '00 323i
Quote:
Originally Posted by glhx View Post
I received an item that allows me to use the torque pro app today.

vacuum 24 according to torque pro
engine rpm 700
engine rpm in drive 640 rpm
coolant temp was 84C
throttle showed at 10
o2 sensor data bouncing between .1and .7 volts will post pictures between the bank 1 and 2
they do look different. bank 1 is more up and down and bank two is more smooth.
post cat o2 runs live at .45 straight across

obd rediness....evap is unready
SAP system unready (because its not even on the car right now) The electric motor melted.

o2, catalyst, o2 heater.....show ready

I used PA soft to get bmw specific codes because the CEL was on
The first time was
P0491 = Secondary Air Injection System Insufficient Flow (Bank 1)
P0492 = Secondary Air Injection System Insufficient Flow (Bank 2)

I cleared it and a day later i got
E4/B1 - Oxygen sensor controller, bank 2, deviation too great, deviation rich
E3/B1 - Oxygen sensor controller, bank 1, deviation too great, deviation rich

I know the SAP is not working and that the pump is bad.

Could this be why my car is running so rich? Average gas mileage is decreasing and is now down to 15mpg on the obc
<;quote>
I cleared it and a day later i got
E4/B1 - Oxygen sensor controller, bank 2, deviation too great, deviation rich
E3/B1 - Oxygen sensor controller, bank 1, deviation too great, deviation rich

<;/quote>


<;HINT>
Sensors

<;/HINT>

Last edited by jdstrickland; 01-18-2013 at 02:47 PM.
jdstrickland is offline   Reply With Quote
Old 01-18-2013, 03:18 PM   #11
dmax
Registered User
 
dmax's Avatar
 
Join Date: Aug 2006
Location: NJ
Posts: 22,834
My Ride: '99 328i 1.04646 mu
You're getting my vote next year, jfoj! Just saying!

OP, I scanned jfoj's post...on the SAP pump...you sure it's not working? Once it's come on first thing in the morning, it typically won't come on again unless the car has sat a long time.

Check the hose from sap to valve...bet yours is corroded...and check vac line heading underneath the O2 wires...the middle part of that line is hard plastic and often cracks...guys replace with continuous rubber line since that plastic line is stupid expensive (for what it is). Anyway, a crack in that line would, when starting the car, show up as rich, I think, because it's adding lots of fuel for a cold start, but isn't getting the air pressure it needs from sap to get the mixture right.

Sort of a theory, but I have to say I like it!

GL!
__________________


Performing at the Comedy Cove--595 Morris Ave. Springfield NJ reservations 973 376-3840

A recent set

dmax on the radio every Wednesday 7-9 p.m. NYC time. Call in! (661) 449-9340 watsonnwatson.com
dmax is offline   Reply With Quote
Old 01-18-2013, 03:26 PM   #12
jfoj
Registered User
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 10,441
My Ride: '06 330CiC, '03 M5
glxh,

Also forgot to mention you need to provide both idle and cruising Fuel Trims at some point.

If your car is running rich, the fuel trims will be negative or proceeded with a - sign, they will be displayed like -2.3%.

If your car it running lean, which happens most often your fuel trims will be usually not be proceeded with a value or + sign, they will be displayed like 3.4%.

In my world I try to keep my fuel trims under 3%, prefer under 2% but sometimes this is not very feasible.

Forget about anyone that tells you that fuel trims just below 6% are fine, they may not trigger a CEL but they are NOT fine. This is too close to the threshold for triggering the CEL.
__________________
Solve your misfires, lean codes, rough idle - http://forum.e46fanatics.com/showthread.php?t=897616

Fuel pump failures - http://forum.e46fanatics.com/showthread.php?t=929501

Temp Info - http://forum.e46fanatics.com/showthread.php?t=964491

Hidden OBC Menu - Check Voltage, Temps, Fuel Level - http://forum.e46fanatics.com/showthread.php?t=239619

E46/E39 GM5 Door Lock Info - www.bmwgm5.com

Lower hose fan switch O-ring - BMW #13621743299
jfoj is offline   Reply With Quote
Old 01-18-2013, 03:45 PM   #13
jfoj
Registered User
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 10,441
My Ride: '06 330CiC, '03 M5
Just wanted to add since I was typing and had to address some management issues with the kids, I noticed other commented on the SAP purpose and function.

The SAP or air pump system purpose it to add extra air (that includes oxygen) into the cylinder head exhaust ports to add additional oxygen into the exhaust stream to allow the richer cold start fuel mixture to continue burning in the exhaust stream, kind of like an afterburner in a way, but not using fuel, just supplying additional oxygen to allow secondary combustion of any unburnt fuel in the exhaust as it exists the cylinders.

This extra air introduced in the exhaust stream will reduce the initial hydrocarbon emissions on cold start as well as rapidly increase the exhaust temperature to allow both the O2 sensors and catalytic converters to warm up faster and attempt to bring the engine into closed loop operation in typically under 2 minutes.

Another little known fact is stainless steel either reacts and/or heats up faster to allow more efficient hydrocarbon burning to again reduce both cold start and normal hydrocarbon emissions. This is another reason there has been a large amount of stainless steel exhaust components used over the last 10+ years on most cars.
__________________
Solve your misfires, lean codes, rough idle - http://forum.e46fanatics.com/showthread.php?t=897616

Fuel pump failures - http://forum.e46fanatics.com/showthread.php?t=929501

Temp Info - http://forum.e46fanatics.com/showthread.php?t=964491

Hidden OBC Menu - Check Voltage, Temps, Fuel Level - http://forum.e46fanatics.com/showthread.php?t=239619

E46/E39 GM5 Door Lock Info - www.bmwgm5.com

Lower hose fan switch O-ring - BMW #13621743299
jfoj is offline   Reply With Quote
Old 01-23-2013, 04:54 PM   #14
jfoj
Registered User
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 10,441
My Ride: '06 330CiC, '03 M5
Did you buy your MAF off of ebay? If so, this is where a lot of the questionable ones are coming from
__________________
Solve your misfires, lean codes, rough idle - http://forum.e46fanatics.com/showthread.php?t=897616

Fuel pump failures - http://forum.e46fanatics.com/showthread.php?t=929501

Temp Info - http://forum.e46fanatics.com/showthread.php?t=964491

Hidden OBC Menu - Check Voltage, Temps, Fuel Level - http://forum.e46fanatics.com/showthread.php?t=239619

E46/E39 GM5 Door Lock Info - www.bmwgm5.com

Lower hose fan switch O-ring - BMW #13621743299
jfoj is offline   Reply With Quote
Old 01-23-2013, 05:01 PM   #15
glhx
Registered User
 
Join Date: Jan 2012
Location: Nashville, Tennessee
Posts: 923
My Ride: 2002 BMW 330ci
in the o2 picture...up till time 240 was idle warmed up......the rest were steady 2000 rpm.

so far the only screen it will allow me to get into is screen shots.....no other way to save the log

i have not been able to find a supplier that i would trust......only ebay and places like alibaba....have it shown with those part numbers. but i would like to further diagnose with charts that the maf is bad.

it is looking like this is Chinese.....im almost 100% it is a knock off. When i type in that number all i find is china suppliers

the former owner told me it was replaced. with the way he took care of this car and the money i have spent on it getting it right. i am not surprised

everyone else that sells BMW parts has this #
13 62 7 567 451

Last edited by glhx; 01-23-2013 at 08:42 PM.
glhx is online now   Reply With Quote
Old 01-23-2013, 09:14 PM   #16
jfoj
Registered User
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 10,441
My Ride: '06 330CiC, '03 M5
O2 graph looks pretty good.

You really need a MAF based upon the Gram per Second values you are reading. I had my 1.8T VW out today and it even was getting up to 70+ Grams per Second when I jumped on it a bit, not wide out.

I was still using my Launch Creader VI for this.

Suggest a source like ECS, BimmerZone, AutoHausAZ, BMA Parts, possibly even Amazon.

I will try to see what my 2006 E46 330cic looks like if I can get any info without removing it.

Since it is not original, I would think it is a counterfeit or wrong application??

I put the Siemens number you had on Google and almost everything came up Ebay and had China associated with it.

DO NOT BUY ON EBAY.

Replace your MAF, you will be likely have a good running engine.
__________________
Solve your misfires, lean codes, rough idle - http://forum.e46fanatics.com/showthread.php?t=897616

Fuel pump failures - http://forum.e46fanatics.com/showthread.php?t=929501

Temp Info - http://forum.e46fanatics.com/showthread.php?t=964491

Hidden OBC Menu - Check Voltage, Temps, Fuel Level - http://forum.e46fanatics.com/showthread.php?t=239619

E46/E39 GM5 Door Lock Info - www.bmwgm5.com

Lower hose fan switch O-ring - BMW #13621743299

Last edited by jfoj; 01-23-2013 at 09:15 PM.
jfoj is offline   Reply With Quote
Old 01-24-2013, 04:50 PM   #17
glhx
Registered User
 
Join Date: Jan 2012
Location: Nashville, Tennessee
Posts: 923
My Ride: 2002 BMW 330ci
could this simply be a vacuum leak. o2 is reading air in the system (reading a lean condition) ....reporting it to the computer....computer adjusts the injectors to run rich. this extra air being down stream from the maf sensor could do that.
glhx is online now   Reply With Quote
Old 01-24-2013, 05:00 PM   #18
jfoj
Registered User
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 10,441
My Ride: '06 330CiC, '03 M5
No likely a Chinese make fake MAF??

Your readings are WAY off from where they should be.

There is no way you have any vacuum leak that would cause your MAF readings to be SO low, the engine just could not run.

Just make sure you are reading Grams per Second with Torque and not Liters per Min or some other wacked out setting.

If you are reading Grams per Second, get your self a real MAF, the minute you install it on the car it will be night and day difference.

I looked at my 330 breifly, no stickers what so ever on the MAF. My car is a 2006 and it is original. I was unable to look inside as it was TOO cold out, 22F.

Also your MAF looked like it had window screen in it?? Most MAF have honey comb cast plastic to straighten the airflow path. Was yours actually like a window screen??
__________________
Solve your misfires, lean codes, rough idle - http://forum.e46fanatics.com/showthread.php?t=897616

Fuel pump failures - http://forum.e46fanatics.com/showthread.php?t=929501

Temp Info - http://forum.e46fanatics.com/showthread.php?t=964491

Hidden OBC Menu - Check Voltage, Temps, Fuel Level - http://forum.e46fanatics.com/showthread.php?t=239619

E46/E39 GM5 Door Lock Info - www.bmwgm5.com

Lower hose fan switch O-ring - BMW #13621743299
jfoj is offline   Reply With Quote
Old 01-26-2013, 08:06 PM   #19
jdstrickland
Registered User
 
Join Date: Apr 2010
Location: Murrieta, CA
Posts: 6,947
My Ride: '94 325iC & '00 323i
Quote:
Originally Posted by glhx View Post
could this simply be a vacuum leak. o2 is reading air in the system (reading a lean condition) ....reporting it to the computer....computer adjusts the injectors to run rich. this extra air being down stream from the maf sensor could do that.
What a minute!

Air that leaks into the system (intake) after the MAF is an unknown, and always results in a lean condition. The O2s will report a lean if they cannot call for enough gas to overcome the extra air that is not known.

If the O2s are reporting a rich, then it is not because of a leak in the intake.

O2s report the state of the exhaust. If they report rich, then there is too much gas in the exhaust. If they report lean, then there is too much air. If the O2s are failing, have failed, then there is no way to know that what they report is true or not. If they report rich AND there is an intake leak, then they are failing. They are unreliable at best.
jdstrickland is offline   Reply With Quote
Old 01-26-2013, 04:09 PM   #20
jdstrickland
Registered User
 
Join Date: Apr 2010
Location: Murrieta, CA
Posts: 6,947
My Ride: '94 325iC & '00 323i
IGNORE THE READINESS MONITORS. When you Reset the codes, all monitors begin again. They do not get to Ready for several drive cycles. Just because they are not ready is meaningless, EXCEPT that if they are not ready, you cannot get your car smogged. If you reset codes, the monitors do not come to ready for several drive cycles. If you check codes again and again, and reset each time, then the readiness monitors will never complete.

The SAP does nothing for rich or lean. The _only_ job of the SAP is to provide fresh air to the exhaust stream to assist the CATs to do what they do before they come up to operating temp. The SAP turns off after 120-ish seconds, and it only comes on with Cold Engine Start. Rich and lean are conditions that exist long before the exhaust gets to the CAT, and I don't even think the car's computer looks at rich and lean while the SAP is supposed to be running. CATs don't work well when cold, so the SAP was added to help reduce emissions immediately after Cold Engine Start. The SAP is not part of the Rich condition. Period.
jdstrickland is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 11:50 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use