E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 03-07-2013, 04:24 PM   #1
clio
Registered User
 
Join Date: Mar 2013
Posts: 12
Engine Management Light does not come on

I donít know if this has already been discussed here, but I bought my car in December 316i 1999 model, and up until Friday I realised that the carís engine management light does not come on at all, I tried to disconnect a few sensors from the engine bay including the MAF Sensor and still the light didnít come on, though the engine was so shaky after disconnecting the sensors. I have removed the Instrument Cluster to check for bulbs only to find that thereís LEDís instead of bulbsÖ.
Why I was looking for management light is because since I bought the car, the car has never run smooth, it feels like itís a bit shaky or judders sometimesÖI really donít know.
Has this happened to anyone before (the light not coming on I mean)? I have other cars too and the light comes on every time I turn the ignition to on, start the car and the light goes off.
__________________
1999 BMW 316i - Other Run around
2008 Mercedes Benz GL420 - Sold
1988 Mercedes Bens 420SL - My Weekend Toy
2005 Alfa Romeo 156 Selespeed - Other Run around
2006 Volvo XC90 - Sold
2004 Volvo XC90 - Winter Car
clio is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 03-07-2013, 04:29 PM   #2
clio
Registered User
 
Join Date: Mar 2013
Posts: 12
Quote:
Originally Posted by clio View Post
I donít know if this has already been discussed here, but I bought my car in December 316i 1999 model, and up until Friday I realised that the carís engine management light does not come on at all, I tried to disconnect a few sensors from the engine bay including the MAF Sensor and still the light didnít come on, though the engine was so shaky after disconnecting the sensors. I have removed the Instrument Cluster to check for bulbs only to find that thereís LEDís instead of bulbsÖ.
Why I was looking for management light is because since I bought the car, the car has never run smooth, it feels like itís a bit shaky or judders sometimesÖI really donít know.
Has this happened to anyone before (the light not coming on I mean)? I have other cars too and the light comes on every time I turn the ignition to on, start the car and the light goes off.
Please help i tried on bimmer forums and been a week now no replies maybe i offended someone...lol
__________________
1999 BMW 316i - Other Run around
2008 Mercedes Benz GL420 - Sold
1988 Mercedes Bens 420SL - My Weekend Toy
2005 Alfa Romeo 156 Selespeed - Other Run around
2006 Volvo XC90 - Sold
2004 Volvo XC90 - Winter Car
clio is offline   Reply With Quote
Old 03-07-2013, 04:31 PM   #3
Mango
Over 15,000 visitors
 
Mango's Avatar
 
Join Date: Mar 2006
Location: Southern California
Posts: 22,489
My Ride: M54B30
When you scan for codes, do any come up?
__________________
A lifetime free of problems if you follow my guides
Cooling | Maintenance | Suspension | Vacuum | Supreme Reliability | Details

OVER A MILLION VIEWS
Mango is offline   Reply With Quote
Old 03-07-2013, 04:46 PM   #4
clio
Registered User
 
Join Date: Mar 2013
Posts: 12
No I haven't, don't know how to and I don't even have a software or scanner. I will need to take it to someone local and pay £30 minimum let alone dealers as they will charge me 3 times that.
__________________
1999 BMW 316i - Other Run around
2008 Mercedes Benz GL420 - Sold
1988 Mercedes Bens 420SL - My Weekend Toy
2005 Alfa Romeo 156 Selespeed - Other Run around
2006 Volvo XC90 - Sold
2004 Volvo XC90 - Winter Car
clio is offline   Reply With Quote
Old 03-07-2013, 04:46 PM   #5
jfoj
Registered User
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 9,552
My Ride: '06 330CiC, '03 M5
Check engine light should come on when key is turned but before engine starts, during bulb check.

You can also run a cluster test as mentioned in the 4th link below in my signature.

Suggest you read this thread, you will see toward the end of the thread what the original poster found wrong with his dash to cause the CEL not to light!

http://forum.e46fanatics.com/showthr...light=monitors
__________________
Solve your misfires, lean codes, rough idle - http://forum.e46fanatics.com/showthread.php?t=897616

Fuel pump failures - http://forum.e46fanatics.com/showthread.php?t=929501

Temp Info - http://forum.e46fanatics.com/showthread.php?t=964491

Hidden OBC Menu - Check Voltage, Temps, Fuel Level - http://forum.e46fanatics.com/showthread.php?t=239619

E46/E39 GM5 Door Lock Info - www.bmwgm5.com

Lower hose fan switch O-ring - BMW #13621743299
jfoj is online now   Reply With Quote
Old 03-07-2013, 05:03 PM   #6
clio
Registered User
 
Join Date: Mar 2013
Posts: 12
Thank you, am gonna remove that instrument cluster again tomorrow and try and take it apart to see if there's nothing covering the light there. That scanner you mentioned in the post, can I buy it in the UK as well? Just thought I might as well ask.
__________________
1999 BMW 316i - Other Run around
2008 Mercedes Benz GL420 - Sold
1988 Mercedes Bens 420SL - My Weekend Toy
2005 Alfa Romeo 156 Selespeed - Other Run around
2006 Volvo XC90 - Sold
2004 Volvo XC90 - Winter Car
clio is offline   Reply With Quote
Old 03-07-2013, 05:29 PM   #7
jfoj
Registered User
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 9,552
My Ride: '06 330CiC, '03 M5
You should be able to purchase the Launch CReader VI on ebay. Most likely will come from Asia?

But also look over this thread as well - http://forum.e46fanatics.com/showthr...light=software

I know you guys have customs and VAT issues, so not sure how that impacts both price and simplicity of ordering things like scanners and such.

I believe there is an ebay seller in the UK that offers BMW GT1 type of software?
__________________
Solve your misfires, lean codes, rough idle - http://forum.e46fanatics.com/showthread.php?t=897616

Fuel pump failures - http://forum.e46fanatics.com/showthread.php?t=929501

Temp Info - http://forum.e46fanatics.com/showthread.php?t=964491

Hidden OBC Menu - Check Voltage, Temps, Fuel Level - http://forum.e46fanatics.com/showthread.php?t=239619

E46/E39 GM5 Door Lock Info - www.bmwgm5.com

Lower hose fan switch O-ring - BMW #13621743299
jfoj is online now   Reply With Quote
Old 03-07-2013, 05:25 PM   #8
clio
Registered User
 
Join Date: Mar 2013
Posts: 12
Looks like the only place I can buy the scanner is Hong Kong, China and shanghai. Now aware of CCC(cheap Chinese cr*p)
Has anybody bought this from China before? Is there anyone on eBay UK got it got sale?
__________________
1999 BMW 316i - Other Run around
2008 Mercedes Benz GL420 - Sold
1988 Mercedes Bens 420SL - My Weekend Toy
2005 Alfa Romeo 156 Selespeed - Other Run around
2006 Volvo XC90 - Sold
2004 Volvo XC90 - Winter Car
clio is offline   Reply With Quote
Old 03-07-2013, 05:37 PM   #9
clio
Registered User
 
Join Date: Mar 2013
Posts: 12
You sure this will read my car? I have just searched on eBay I can buy one in the UK infact it's only 15-20 miles from my place to where tha scanner is. But am not sure if it will work on my car, as its showing for cars from 2001 - 2006...what do you think?
__________________
1999 BMW 316i - Other Run around
2008 Mercedes Benz GL420 - Sold
1988 Mercedes Bens 420SL - My Weekend Toy
2005 Alfa Romeo 156 Selespeed - Other Run around
2006 Volvo XC90 - Sold
2004 Volvo XC90 - Winter Car
clio is offline   Reply With Quote
Old 03-07-2013, 06:20 PM   #10
jfoj
Registered User
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 9,552
My Ride: '06 330CiC, '03 M5
Not sure what I can tell you, I believe the OBDII standard was not fully required in the EU area until 2001, however, your car may support OBDII??

You may also have the round underhood BMW interface that may require an adapter cable?
__________________
Solve your misfires, lean codes, rough idle - http://forum.e46fanatics.com/showthread.php?t=897616

Fuel pump failures - http://forum.e46fanatics.com/showthread.php?t=929501

Temp Info - http://forum.e46fanatics.com/showthread.php?t=964491

Hidden OBC Menu - Check Voltage, Temps, Fuel Level - http://forum.e46fanatics.com/showthread.php?t=239619

E46/E39 GM5 Door Lock Info - www.bmwgm5.com

Lower hose fan switch O-ring - BMW #13621743299
jfoj is online now   Reply With Quote
Old 03-08-2013, 03:19 PM   #11
clio
Registered User
 
Join Date: Mar 2013
Posts: 12
Hi, today I took the instrument cluster out and inspect it thoroughly and nothing was put up to hide the EML light coming on. Anyway out of curiosity and me thinking am going crazy...I borrowed my friends instrument cluster and connect it to my car. Still no EML light.
And I did what jgoj suggested to look at the hidden OBD features the last link on his signature.
Now what will it be? Really confused...
__________________
1999 BMW 316i - Other Run around
2008 Mercedes Benz GL420 - Sold
1988 Mercedes Bens 420SL - My Weekend Toy
2005 Alfa Romeo 156 Selespeed - Other Run around
2006 Volvo XC90 - Sold
2004 Volvo XC90 - Winter Car
clio is offline   Reply With Quote
Old 03-09-2013, 03:47 PM   #12
lszlszx
Registered User
 
Join Date: Jan 2013
Location: Socal
Posts: 4,531
My Ride: 328i, XC70
Try to swap in the DME from your friend's car. If the light is still not on,
then it must be a wiring issue. Trace the wire from the EML light in the cluster
to the relay panel/DME, checking for continuity.
__________________
lszlszx is offline   Reply With Quote
Old 03-09-2013, 04:04 PM   #13
clio
Registered User
 
Join Date: Mar 2013
Posts: 12
I am totallywith this car after removing the cluster and checking if there was a tape or something like that at the back to cover the lightÖ.and also after swapping the clusters and still the same??? Ok I donít have experience mechanically let alone auto electrics I have no clue what the DML is and even if I knew I donít know how to check for the currents flowing and continuities.
Apart from people finding tapes taped on their EML light what else will cause this???
It seems I just have to buy myself an OBD scannerÖ.need one that I can use for all my cars than just buying one for each of my carsÖ.so if anyone has an idea of this too pls let me knowÖnot expensive though
__________________
1999 BMW 316i - Other Run around
2008 Mercedes Benz GL420 - Sold
1988 Mercedes Bens 420SL - My Weekend Toy
2005 Alfa Romeo 156 Selespeed - Other Run around
2006 Volvo XC90 - Sold
2004 Volvo XC90 - Winter Car
clio is offline   Reply With Quote
Old 03-09-2013, 04:18 PM   #14
lszlszx
Registered User
 
Join Date: Jan 2013
Location: Socal
Posts: 4,531
My Ride: 328i, XC70
The DME is the computer, it's located under the plastic cover on the driver's side at the firewall. It's not any harder to remove it, than the cluster, which
you've already done. I'd swap DME, see what happens.
__________________
lszlszx is offline   Reply With Quote
Old 03-09-2013, 04:28 PM   #15
clio
Registered User
 
Join Date: Mar 2013
Posts: 12
Quote:
Originally Posted by lszlszx View Post
The DME is the computer, it's located under the plastic cover on the driver's side at the firewall. It's not any harder to remove it, than the cluster, which
you've already done. I'd swap DME, see what happens.
Please tell me exactly what the DME will look like (sorry to sound a bit ignorant) i just dont know what i will be looking for. Where will i find it on the firewall, how does it look like, any colours to look out for or shape, size...
__________________
1999 BMW 316i - Other Run around
2008 Mercedes Benz GL420 - Sold
1988 Mercedes Bens 420SL - My Weekend Toy
2005 Alfa Romeo 156 Selespeed - Other Run around
2006 Volvo XC90 - Sold
2004 Volvo XC90 - Winter Car
clio is offline   Reply With Quote
Old 03-09-2013, 05:16 PM   #16
clio
Registered User
 
Join Date: Mar 2013
Posts: 12
My car doesn't run fine...it has a bit of misfiring and also juddered when in reverse and first gear. I have changed the coil pack before from another car and it was still the same. The car also hisses when for about 3-5 minutes at first start in the morning, now am not sure if that hiss is normal. I have other cars too and their EML light is on when key is turned to on position and goes out when the car starts. Now tjhisnis the reason why am concerned with the way this car drives and the EML light not coming on at all even after I disconnected about 3 sensors in the engine bay including MAF sensor, still the light didn't come on.
__________________
1999 BMW 316i - Other Run around
2008 Mercedes Benz GL420 - Sold
1988 Mercedes Bens 420SL - My Weekend Toy
2005 Alfa Romeo 156 Selespeed - Other Run around
2006 Volvo XC90 - Sold
2004 Volvo XC90 - Winter Car
clio is offline   Reply With Quote
Old 04-10-2013, 03:19 PM   #17
clio
Registered User
 
Join Date: Mar 2013
Posts: 12
My car is misfiring...I don't know what's causing it, I have changed spark plugs and coil park...but still sluggish. What could be causing this?
My car is 316 1.9 Petrol engine. Pls help I love the car, but now I have noticed I am using a lot more fuel that I did when I just bought the car 6 months ago.
__________________
1999 BMW 316i - Other Run around
2008 Mercedes Benz GL420 - Sold
1988 Mercedes Bens 420SL - My Weekend Toy
2005 Alfa Romeo 156 Selespeed - Other Run around
2006 Volvo XC90 - Sold
2004 Volvo XC90 - Winter Car
clio is offline   Reply With Quote
Old 04-10-2013, 03:46 PM   #18
jdstrickland
Registered User
 
Join Date: Apr 2010
Location: Murrieta, CA
Posts: 6,698
My Ride: '94 325iC & '00 323i
Quote:
Originally Posted by clio View Post
I donít know if this has already been discussed here, but I bought my car in December 316i 1999 model, and up until Friday I realised that the carís engine management light does not come on at all, I tried to disconnect a few sensors from the engine bay including the MAF Sensor and still the light didnít come on, though the engine was so shaky after disconnecting the sensors. I have removed the Instrument Cluster to check for bulbs only to find that thereís LEDís instead of bulbsÖ.
Why I was looking for management light is because since I bought the car, the car has never run smooth, it feels like itís a bit shaky or judders sometimesÖI really donít know.
Has this happened to anyone before (the light not coming on I mean)? I have other cars too and the light comes on every time I turn the ignition to on, start the car and the light goes off.
Turn the key to Position II (RUN) but leave the engine off. The check engine light MUST be on else there is a fault that will cause the car to fail emissions testing in many jurisdictions.

Your car conforms to the OBD II specification, so if you think there is a problem then you should pull codes. Normally, you would pull codes tyo find out why the light was on, but you said your light does not work. The light comes on to tell you why the engine does not run well, and when the light comes on there are codes stored. Pull codes to find out what the engine computer thinks is wrong, then go from there.
jdstrickland is offline   Reply With Quote
Old 04-10-2013, 04:37 PM   #19
jaymemaurice
Registered User
 
Join Date: Aug 2008
Location: Anchorage Alaska or Kitchener, Ontario, Canada
Posts: 757
My Ride: 01 330ci, 03 Passat
LOL IN THIS THREAD - WHO THE HELL ADVISES SOMEONE TO SWAP THE DME/CLUSTER FROM ANOTHER CAR!!
The DME is paired to the IMMO and specific to the engine type.

WHO THE HELL ADVISES SOMEONE TO TRACE THE CHECK ENGINE LIGHT BACK TO THE DME?
The KOMBI communicates with the DME over a communications bus shared with other functions.


Clio, take it to someone who is specializes in this. It is possible the DME has been re-flashed/tuned to disable the CEL... unlikely, but possible.


Anyway point is, many of these guys will have you rip apart your car until you damage something.

Misfires can be caused by a number of things including intake gasket leaks... take it to a good mechanic or be prepared to do a lot of reading from qualified sources before following any advice or opening your wallet.
__________________


Rain Sensor Retrofit: Here
Coupe Headline Replacement: Here

Last edited by jaymemaurice; 04-10-2013 at 04:41 PM.
jaymemaurice is offline   Reply With Quote
Old 05-07-2014, 03:25 AM   #20
shaddy007
Registered User
 
Join Date: May 2014
Posts: 4
breaking the law about sleeping dogs however, I would like to know how this problem concluded if you don't mind, I have an m sport e46 320d and since I bought it the engine management light hasn't been coming on when starting. The car runs pretty well good on fuel and all that unless I am missing something.please share your remedy.

Sent from BimmerApp mobile app
shaddy007 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 01:49 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use