E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 08-17-2003, 02:54 AM   #1
tmckinl
Registered User
 
Join Date: Aug 2003
Location: Pine Bluff, AR, USA
Posts: 90
My Ride: Jet Black 1999 328i
Send a message via ICQ to tmckinl
Question shift indicator problem on auto trans

The indicator next to the automatic trans shifter on my 328i has started to malfunction. It dosn't indicate the correct gear. If I shift into park and then carefully shift back to gear it sometimes corrects itself, but only temporarily. Does anyone have any idea what's wrong and how I can fix it.
tmckinl is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 08-17-2003, 03:07 AM   #2
gmhl10
Resident CF Whore
 
Join Date: Mar 2003
Location: Honolulu, HI
Posts: 2,624
My Ride: '05 A08 M3
Send a message via AIM to gmhl10 Send a message via MSN to gmhl10
Whoa.... never heard of that happenning.
I got an auto tranny problem on my 2002 325i where say when I go up to like around 5000 or 6000 rpm in 2nd gear and then switch to 3rd gear... instead it went down to 1st gear and I freaked the hell out because it went to total redline!
I pushed on brake and kept trying to shift up.
I know I didn't "ACCIDENTALLY" push down to gear 1 because it happened to me twice...
__________________
'05 Silbergrau M3 - mfg date: May '05
Modifications: WAY too much to list

gmhl10 is offline   Reply With Quote
Old 08-17-2003, 10:16 AM   #3
sfzBimmer2
Registered User
 
Join Date: Jun 2003
Location: New York, NY
Posts: 1,287
My Ride: '05 Ducati Monster
I think someone else on this forum had a similar problem. It's a known problem, though, and your dealer should be able to fix it
sfzBimmer2 is offline   Reply With Quote
Old 08-17-2003, 10:17 AM   #4
Liscia
Registered User
 
Join Date: Sep 2002
Location: Gaithersburg, MD, USA
Posts: 584
My Ride: 2002 BMW 330Ci
Could it just be a loose connection to the indicator light module?or gearshift lever position sensor.
Haven't had mine open but looks easy enough to pry off and
check connections underneath or you may want the dealer to
do this if you've got warranty left and if you're not confident of
doing it yourself. Good luck
Liscia is offline   Reply With Quote
Old 08-17-2003, 11:33 AM   #5
Trax
Registered User
 
Join Date: Jul 2003
Location: T.O., So. Calif
Posts: 191
My Ride: 99' 323i Sedan
Send a message via ICQ to Trax Send a message via AIM to Trax Send a message via Yahoo to Trax
I had the same problem on my 1999 323i couple years ago. Took it to the dealer and they fixed it. Happened after my brother drove it...should tell you something
__________________
---


This sig has been viewed by fanatics since March 14, 2004
Trax is offline   Reply With Quote
Old 08-21-2003, 02:10 AM   #6
tmckinl
Registered User
 
Join Date: Aug 2003
Location: Pine Bluff, AR, USA
Posts: 90
My Ride: Jet Black 1999 328i
Send a message via ICQ to tmckinl
Thanks for the ideas. I think it's something mechanical with the indicator because of the sounds it makes when shifting. I think I'll get it to the dealer when I have a chance. It's really just a minor anoyance because the dashboard readout is still reading correctly.
tmckinl is offline   Reply With Quote
Old 08-21-2003, 02:46 PM   #7
Cheburashka
Registered User
 
Join Date: Apr 2003
Location: Folsom, CA
Posts: 108
My Ride: '99 328i
Seems to be a more common problem these days. I had same problem a year ago. Dealer fixed it by replacing something.
__________________


Improving with Age!
Cheburashka is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 12:10 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use