E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 12-20-2008, 09:15 PM   #1
ELDawson
Registered User
 
Join Date: Jun 2005
Location: Chesapeake, VA
Posts: 315
My Ride: 2008 M3 Vert
ATF/Expansion Tank Thermostat

Hey guys, did a complete cooling system overhaul today.

Problem is I broke the ATF Thermostat when I took off the expansion tank. I only saw one or two threads on here talking about this problem, but they were worthless.

I haven't received any lights on the dash, and the car seems to be driving fine. My question is, how long has anyone driven with the ATF thermostat like this? I plan to replace it this week, but I want to know if it can make it up to Williamsburg (~100 miles) and back safely.

I know what the damn thing looks like, but does anyone know how it works. When I took off the expansion tank, the black cap broke off and shot up a spring. Is my tranny getting cooling right now? Or will it overheat?

Thanks in advance.
__________________
ELDawson is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 12-20-2008, 10:00 PM   #2
330ciandr6
Registered User
 
Join Date: May 2007
Location: .
Posts: 6,605
My Ride: .
Send a message via AIM to 330ciandr6 Send a message via Yahoo to 330ciandr6
honestly i'm not sure how it works...but i've seen this happen quite alot. happended to me twice...replaced 'em both at the time i did it so i'm not sure about driving without it. i don't THINK it would hurt anything but i'm not sure.
__________________
Have a oil or coolant leak? Click here!:http://forum.e46fanatics.com/showthr...732&highlight=
ABS/DSC/Brake/Airbag light on?? Click here!:http://forum.e46fanatics.com/showthr...648&highlight=
330ciandr6 is offline   Reply With Quote
Old 12-20-2008, 10:10 PM   #3
reynaldo
Registered User
 
Join Date: Sep 2006
Location: Overseas
Posts: 967
My Ride: 2001 325i Sedan
Send a message via Yahoo to reynaldo
I did overhauled my cooling system and replaced everything except rad and middle hose (thin hose connected to the exp tank) Dont know If I kept mine. WIll send it to you for free just pay the shipping.
reynaldo is offline   Reply With Quote
Old 12-21-2008, 07:52 AM   #4
ELDawson
Registered User
 
Join Date: Jun 2005
Location: Chesapeake, VA
Posts: 315
My Ride: 2008 M3 Vert
Quote:
Originally Posted by reynaldo View Post
I did overhauled my cooling system and replaced everything except rad and middle hose (thin hose connected to the exp tank) Dont know If I kept mine. WIll send it to you for free just pay the shipping.
I can't wait to get one shipped, I am going to the dealership on Monday. Thanks for the offer though.
__________________
ELDawson is offline   Reply With Quote
Old 12-22-2008, 09:07 AM   #5
hongchu
Registered User
 
Join Date: Dec 2007
Location: fall river, ma
Posts: 271
My Ride: bmw328ci
mine is broken too, there are two tabs the the thing is connected too which is holding the spring down right? well the tab on my broke off but when i removed the exp tank. I had it aligned dead center before i shoved the exp tank down on it... i've been driving it since and no issues... its been about 5000 miles give or take...
hongchu is offline   Reply With Quote
Old 12-22-2008, 10:06 AM   #6
330ciandr6
Registered User
 
Join Date: May 2007
Location: .
Posts: 6,605
My Ride: .
Send a message via AIM to 330ciandr6 Send a message via Yahoo to 330ciandr6
Quote:
Originally Posted by hongchu View Post
mine is broken too, there are two tabs the the thing is connected too which is holding the spring down right? well the tab on my broke off but when i removed the exp tank. I had it aligned dead center before i shoved the exp tank down on it... i've been driving it since and no issues... its been about 5000 miles give or take...
next time it opens...it will stay open then
__________________
Have a oil or coolant leak? Click here!:http://forum.e46fanatics.com/showthr...732&highlight=
ABS/DSC/Brake/Airbag light on?? Click here!:http://forum.e46fanatics.com/showthr...648&highlight=
330ciandr6 is offline   Reply With Quote
Old 12-23-2008, 04:52 PM   #7
ELDawson
Registered User
 
Join Date: Jun 2005
Location: Chesapeake, VA
Posts: 315
My Ride: 2008 M3 Vert
Thanks for the help, got the part at the dealership and put it in today.
__________________
ELDawson is offline   Reply With Quote
Old 03-08-2009, 01:57 PM   #8
bimmerguy323
Registered User
 
Join Date: Sep 2008
Location: new-brunswick
Posts: 2
My Ride: e46 323i
Unhappy expantion tank busted open

hey guys recently change electronic thermostat , was wundering if , to much prestone could ,or air in the system could cause the expantion tank to have crack. in the car the thermstat was operating at perfect temperature, and no sign that is was overheating , when i got back from a test drive , the tank was crack and lost all of my prestone, any of you guys had this happend to you , and know a reason why the tank would of done that , or is it just a bad luck , usually things happends for a reason . let me know
bimmerguy323 is offline   Reply With Quote
Old 03-08-2009, 03:37 PM   #9
01bim325
Registered User
 
Join Date: Aug 2005
Location: US
Posts: 91
My Ride: Bimmer
The expansion tank will fail after a certain amount of time/miles. I don't think too much coolant or air in the system will cause it to fail. However, I have heard speculation that a bad cap may lead to a tank crack - the cap may not release pressure when it should. If this is true, then overfilling the cooling system could lead to a crack in the tank because it won't allow the release of excess pressure. But this is purely speculation. The more probable explanation is that, like many other parts, the expansion tank will only perform to specs for a certain amount of time before it cracks under pressure.

Last edited by 01bim325; 03-08-2009 at 03:44 PM.
01bim325 is offline   Reply With Quote
Old 03-09-2009, 08:36 AM   #10
JJJ Dom
Registered User
 
Join Date: Sep 2004
Location: Tx
Posts: 13
My Ride: 2000 323i
ATF Thermostat cap Problem!

I was also in the process of removing my expansion tank and removed with retainer or monting bracket as called by the service book, and of course when pulling these two apart the cap which holds the spring and ATF thermostat broke, not only that but the tabs which hold the cap also broke off, so my question is, the retainer/mounting bracket looks fine, but can I replace the damaged parts inside this inlet tube and is it an easy DIY or if I purchase a new retainer/mounting bracket will it come with these parts already installed . Thanks for any help you can provide.
JJJ Dom is offline   Reply With Quote
Old 03-09-2009, 09:29 AM   #11
hongchu
Registered User
 
Join Date: Dec 2007
Location: fall river, ma
Posts: 271
My Ride: bmw328ci
i have had the same tab broken and spring issue when replacing my tank... i aligned it dead center and push the tank in and everything have been working fine... its be almost a year and no issue. My heat and ac works fine and as good as when i first bought my car. I really don't see any real function in it but what do i know lol... its a spring with a metal thingy that seems to do have very little importance.
hongchu is offline   Reply With Quote
Old 06-10-2009, 10:27 PM   #12
Black325CI02
Registered User
 
Join Date: Mar 2009
Location: Ohio
Posts: 19
My Ride: 325 CI
got a problem i changed my thermostat and expantion tank but when i start the car up the tank and the upper hose get so hot like its about to explode , i think i bleed the system the right way
Black325CI02 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 05:52 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use