E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 06-27-2009, 09:16 PM   #1
byke818
Registered User
 
Join Date: Dec 2006
Location: wembley
Posts: 3
My Ride: 2001 bmw 318i
Post blower not working

hi all! Maybe someone could help me? I have a 2001 318i (UK) , i recently replaced it's expansion tank and i followed the DIY guide that i've read here. After putting it back together everything went fine. After a few days, while driving the coolant indicator flashes. I have checked the water/coolant level and it's within the limit. Other than that, when i turned the a/c on no air is coming out from the vents but the controls seemed to be alright. Can anyone help me please? Cheers!
byke818 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 06-27-2009, 09:20 PM   #2
Dninty9
Registered User
 
Join Date: Oct 2008
Location: Florida, USA
Posts: 128
My Ride: BMW 330I, VOLVO 850R
For the air it could be your final stage resistor has gone out


Dninty9 is offline   Reply With Quote
Old 06-27-2009, 09:54 PM   #3
//TRD power
Registered User
 
Join Date: Jun 2008
Location: Zero Maintenanceville
Posts: 2,556
My Ride: 3.0 | 200hp | 214trq
def your fsr. As for the coolant problem, try bleeding the air out.
__________________
//TRD power is offline   Reply With Quote
Old 06-28-2009, 06:15 PM   #4
byke818
Registered User
 
Join Date: Dec 2006
Location: wembley
Posts: 3
My Ride: 2001 bmw 318i
Hi! Thank you for your quick reply. I just don't understand why the blower malfunctioned lately, does it have any connection with the recent replacement that i did? or was it just the normal wear and tear? or did i mess up any electrical system? Just really worried... As for the bleeding, would it be alright to do eventhough the blower is not working? sorry to be a nuisance but i know that your expertise and experience will truly help a new guy like me... Cheers!
byke818 is offline   Reply With Quote
Reply

Tags
coolant, heating and a/c

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 05:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use