E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 09-09-2009, 12:57 PM   #1
pgillpro
Registered User
 
Join Date: Sep 2007
Location: Los Angeles
Posts: 42
My Ride: 99 323i 5 speed
Radiator Leak

Ok so on my 99 323i I replaced the expansion tank several months ago, a short while after that my coolant light would come on and off randomly while driving, it would stay on for 10 minutes or so then just go off for a couple minutes then go back on. my engine temperature never rose above normal and i would just put coolant in it once a week until now when im finally getting around to fixing it. The coolant in my expansion tank would go down but not drastically, i could see signs that coolant was spewing from the upper hose connection area with the radiator, yesterday i replaced the upper hose but on my way to work today the coolant light came on again, looks like its coming from the radiator side of the connection, any chance you can replace that part of the radiator or is it all one system? how hard is a radiator to install? any help would be greatly appreciated!
thanks
pgillpro is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Reply

Tags
coolant, leak, manual, radiator, upper radiator hose

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 12:40 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use