E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 12-29-2009, 06:04 PM   #1
vancityrealtor
Registered User
 
Join Date: Dec 2009
Location: Vancouver
Posts: 1
My Ride: 2004 BMW 330i
Question Transmission Light Troubleshooting

Hi, I'm new to the site. I've taken a look for previous threads on this topic, but haven't found what I'm looking for...

I bought a 2004 BMWi 330i from a wholesaler, and have a few bugs to work out. Recently the transmission light started to come on. I read in the owner's manual that "if the light comes on, and you shut the car off for 15 seconds with the parking brake on, and the light goes off when you re-start the vehicle, the transmission will operate as normal. If the light stays on then it will only operate in 3rd & 4th in safe mode."

I noticed the light comes on when the car is in 'park' while the car is running, (like when I warm the car up in the morning.) It also happened today while the car was in neutral going through the auto-car wash.

Every time I restart the car and put the car in gear the light stays off. I've driven over 500kms since I bought the car and the light hasn't come on while in gear. It seems to operate normally, although I do notice a pronounced shift into low gear when coming to a stop, especially when cold.

One other thing I notice is a faint moaning sound or humming while at cruising speed and the rpm's are between 1200-1400. If you let off the gas or step on the gas to change the rpms the sound goes away.

My mechanic is away for 2 weeks. I don't know the code. Any idea what this might be? From the reading I've done on this site and other blogs, I think it might be low on trans. fluid, but I'm new to BMW's.
vancityrealtor is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Reply

Tags
2004, 330i, e36, light, transmission

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 07:48 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use