E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Bavarian Soundwerks' Mobile Electronics Forum

Bavarian Soundwerks' Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by Bavarian Soundwerks

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 01-15-2010, 07:16 PM   #1
Orion329
Registered User
 
Join Date: Jun 2007
Location: Chicago, IL
Posts: 480
My Ride: MKV GTI
Speaker and Carputer Installation. Pics.

Take a look and see if this helps you out...

The following is a brief compilation of images that record the series of steps I took in installing new component speakers, two subwoofers, two amps, and eventually a carputer. I had previously documented my speaker and amp install here.

Thanks to all of you on e46fanatics.com for helping me bring this project to life.

The Speaker Installation:

Since I started off simply wanting to upgrade the stock 10-speaker setup, I installed two pairs of Infinity Kappa 60.9cs speakers as well as the Infinity Kappa Four amplifier. Clean and simple.


This was the original installation of the crossovers and amp. The amp location was chosen to avoid any excess space consumption and keep it cool.


Front Speaker Installation:



The only effective way to cleanly install speakers in the front doors is to mount them to the metal body, not the interior trim panel.



No rattles made the work worthwhile.



There’s a lot of ways to mount the tweeters, but since they create very little movement, I went with a simple application of some Dynamat to keep them in place.


Rear Speaker Installation:



I wanted to save some money by not purchasing a bracket, but also ensure a very solid mounting point for the rear speakers, So I used some ˝” hardwood to create these horseshoe brackets. Here’s the link to the extensive write-up I did on that part of the install: DIY: 6.5” Rear Deck Speaker Mounting



The install left no room for rattles in the back.



A lot of people will recommend getting coaxial speakers in the back, or mounting the tweeters near the woofers, but since I hadn’t read too much into it and wanted to give my passengers the ability to hear the high notes clearly, I prepped the rear doors to hold my tweeters.



By luck my tweeter’s diameter was a near perfect fit for a very snug install in the existing mounting holes.


Subwoofer Installation:



I eventually decided that even though the bass response was good with the upgraded speakers, I needed more—but not too much more. I found a pair of 8” subwoofers (JL 8W3v3-4) that fit the bill to be paired pretty well with the Infinity Kappa One amplifier (I wanted the trunk install to look very clean, so buying an amp that matched aesthetically was key.) The subs small depth and their custom matched grills made them a good choice for the small enclosure I wanted.



I was happy with the bass I got from the two speakers, but after removing a rear deck speaker to allow the bass to get to the cabin, I decided to try to find a way to get rid of some of the bass isolation I was getting in my e46. I popped out the ski pass and put some holes in the front façade. They’re hardly visible, but seem to augment the sound transmission a bit.



The size and design of the box allowed for me to easily access the full-sized spare I have as well as remove them quickly and easily with the use of two large thumbscrews at the top.
Orion329 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 01-15-2010, 07:17 PM   #2
Orion329
Registered User
 
Join Date: Jun 2007
Location: Chicago, IL
Posts: 480
My Ride: MKV GTI
The Carputer Install:

I ran my setup with the two amps, two subs, four component pairs, and stock head unit for almost half a year, using an Audiocontrol LC6i in conjunction with an Audiocontrol 6XS to get signal to the subs.

I was content with the DICE Silverline Pro and my 80gb fifth gen iPod, but since my media library extended beyond that and I wanted to add more features, I decided I’d have to either get a double-din head unit, or install a carputer. I weighed the pros and cons of both for quite some time.

A single din install was out of the question, since I have yet to see a good looking single din head unit that would match the e46 interior. The upgradability, lack of AC modification, functionality, my love of computers, and the coolness factor all led me to go for the carputer install.

I built the machine with the following components:

Lian-Li PC-Q07 (Lian-Li makes the most excellent cases)
Zotac GF9300-G-E (HDMI, WiFi, LGA 775…)
Intel Core 2 Duo E7500 Processor (2.93Ghz)
Intel X25-M 80Gb SSD SATA HD (for quick booting)
WD Caviar Black 1TB SATA HD (for media storage)
Kingston HyperX 2Gb DDR2 800 SDRAM (would have gone bigger, but hibernation concerns limited it to 2Gb)
AuzenTech X-Fi Forte Sound Card
and of course, Arctic Silver 5

I built the machine, ran some tests, installed Windows XP Pro, configured some software (ultimately settling on Centrafuse 3.0). I had it configured the best I could outside of the car, so I started the install.


Wiring To Trunk and USB Hub:



Running the cables to do a test run was the first priority.



It took a lot of work to do this part of the install, and I had to remove a good amount of the material below the rear center console storage compartment.



Cleaned up.



Wire management to keep cables from being pinched.



I used the existing cable route to get them all into the trunk.



Next I wanted to get the USB hub powered up front. I used a D-Link 7 port USB hub and a 15 watt DC-DC power source from Opus Solutions.



I tapped the leads in the engine bay and ran them through the grommet that was also used for the turn-on wire for my myCarr 81 LED angel eyes.



Routing the cables through the rear of the glove compartment and up into the center console wasn’t too tricky. I used a fuse-tap to get an accessory ignition wire from the upper left block of the fuse box.


Center Console Installation:



Preliminary test of the system, still running the computer off of an AC-DC power supply in my trunk. USB hub works!



Differences in the existing sunglass holder trim versus the new AC relocation trim. I had the single-block button setup.



My next task was creating a clean way to access two USB ports up front, as well as give an AUX in port for allowing others to share their music on the fly. I decided to re-use my spec.dock 2point5 as a starting point (since I no longer was using the DICE).



A little bit of help from Bondo body filler led me to having a decent set of jacks for up front.



Modifying the spec.dock to fit the modified iPod plate.



I wanted to be able to turn off the amps ignition wire if I was concerned with saving battery power, and throwing in a second one to control the PC’s ignition line was an easy addition.



Originally I was going to rely on the auto-on feature of my PSU to turn on the carputer, but I decided it would be better to be able to not turn it on for short trips. Not the prettiest switch, but it isn’t visible to anyone but the driver.



I removed the screen from the original housing to get it ready to mount to the bezel from Rich at mybimmer.net.



Even though the bezel was designed to fit all Xenarc 7” screens, my 706TSA didn’t seem to fit quite right, so I used a Sharpie marker to cover up the visible touchscreen features.


Rear Deck Hardware Installation:


After getting the front all put back together, I started in on the back of the car. The HD radio I bought needed to interface with the Diversity antenna amplifier in the back.



Removing the rear deck liner was necessary to put in the GPS, WiFi antenna, and HD radio module.



There’s a lot of space available underneath the trim, and installing the carputer here could be a good way to go—if you give it enough ventilation.



The GPS antenna was mounted to where I think it nominally would be placed if it was the OEM one. The WiFi antenna is magnetic and was stuck down on the rear deck sheet metal.



I secured the HD radio (Visteon HDZ300) to the rear deck as well and ran the antenna extension over to the diversity antenna amp, running power, WiFi antenna, GPS USB connection, etc.. down into the trunk via the speaker opening.
Orion329 is offline   Reply With Quote
Old 01-15-2010, 07:17 PM   #3
Orion329
Registered User
 
Join Date: Jun 2007
Location: Chicago, IL
Posts: 480
My Ride: MKV GTI
Putting it All Together:


The only thing left to be done of the physical install was to prep the computer for the install and put it all back together.


Mounting The DC-DC PSU:



The DC-DC power supply I used was from Opus Solutions, their 360W DC-DC ATX/BTX, though I think I went with the 250 watt version. It needed to be mounted where a standard AC-DC power supply would go in the Lian-Li Q07 case.



The board was mounted on some clear acrylic and secured into place, cables were tied down in the case, and it was nearly done.



To finish the computer up, I had to cover up the opening in the back.


Mounting the Carputer:



The existing LC6i and 6XS were removed to make way for the carpc. I was originally planning to have the computer facing outwards, using the flap in the CD changer trunk liner to access the removable terabyte drive, but due to the size of the case, I wouldn’t have been able to connect the USB, video, audio, power, and other connections on the back.



I used some more clear acrylic to start whipping up a way to mount the PC.



Even though no one will ever see it, I figured I’d clean up the edges with some sandpaper…



The case has rubber feet, but I put down a sheet of rubber ordered from McMaster-Carr that I had laying around to give the case good grip on the mount.



I had some sturdy L-brackets handy and put them to use.



Since I wanted it to be removable for troubleshooting, I used a bungie cable to hold it in place.



The final mounting solution installed.


Everything sealed up and ready to go, the hard drive hot-swappable bay is able to be removed, and due to the intake fan on the front of it, it can pull in ‘fresh’ air to keep the system cooler than if it had been completely covered by the carpeting.



Additional Hardware Used:

Screen: Xenarc 706TSA
GPS Receiver: BU-353
WiFi Antenna: Rosewill RNX-A8-EX 2.4 GHz Indoor 8 dBi Omni-Directional Antenna
Bluetooth: AZiO BTD-V201 USB 2.0 Micro Bluetooth Adapter
Xbox Controller Adapter: Microsoft Wireless Gaming Adapter
HD Radio: Visteon HDZ300
HD Radio Interface: Mitch’s HD Radio PC Interface in conjunction with a TrendNet USB to Serial cable
Steering Wheel Controls: Rolf Resler's IBUS Interface
USB Hub: D-Link DUB-H7
Monitor to Computer cable: Xenarc 5M interconnect cable (purchased at CustomCarputers.com)


Helpful Posts:

Extensive speaker upgrade write-up
Door-mounting your speakers
Speaker sizes overview
AVIC-F90BT Double din install
AVIC-Z2 Double din install
paraklas' carputer DIY
acompgeek's e46 carputer install
Zebel's e46 carputer install at mp3car.com
Lloydy's e46 carputer install at mp3car.com
A decent write-up of carputer installs at mp3car.com
IBUS connectivity guide at mp3car.com

Thoughts:

Currently I'm very happy with the AuzenTech card, though having a drop in sound quality was one of my primary worries when going this route. It definitely sounds better than the stock head unit (and I have 4.1 surround now!) The screen isn't transreflective, but it looks bright enough during the day to be easily seen. At night it may be too bright, but I haven't extensively tested that.

There are still quite a few kinks to work out of the system. I need to get start-up times down a bit still. I'm waiting on a connector that was special ordered from pozitiveconnections.com (the Din-4 connector) to connect my HD radio tuner to the diversity antenna. Bluetooth works well, but I haven't installed a microphone to get it fully functional yet. My IBUS connectivity hasn't been remedied yet, I'm worried that the trunk connection I used isn't active since I don't have a stock head unit...your thoughts are welcome. And the GPS Still needs to be configured.

CentraSkin, a skinning application is in the works for making sleek new skins that will match the interior of an e46 better than the current default Centrafuse 3.0 skin.

A special thanks to Driiven and B-Man for all their advice.

Thanks for reading!
__________________
Orion329 is offline   Reply With Quote
Old 01-15-2010, 11:47 PM   #4
pbsun
Registered User
 
Join Date: May 2005
Location: SoCal
Posts: 38
My Ride: 2001 330ci
wow, well done
pbsun is offline   Reply With Quote
Old 01-16-2010, 02:20 AM   #5
ZZen330
Registered User
 
Join Date: Apr 2009
Location: Canada
Posts: 1,141
My Ride: 2002 330Ci
I don't see any of the pics. Just red X's
ZZen330 is offline   Reply With Quote
Old 01-16-2010, 03:47 AM   #6
Orion329
Registered User
 
Join Date: Jun 2007
Location: Chicago, IL
Posts: 480
My Ride: MKV GTI
hmm, looks good to me. pics are hosted at photobucket....
__________________
Orion329 is offline   Reply With Quote
Old 01-18-2010, 12:42 AM   #7
mastamind518
Registered User
 
Join Date: May 2007
Location: Florida
Posts: 64
My Ride: 2000 323i
very nice. congrats on the carpc. its been an ongoing project for me for the past year, keep finding new things to add...

keeps me busy, so not complaining
__________________
2000 323i
Carputer installed
mastamind518 is offline   Reply With Quote
Old 01-18-2010, 02:38 AM   #8
Orion329
Registered User
 
Join Date: Jun 2007
Location: Chicago, IL
Posts: 480
My Ride: MKV GTI
thanks. i've got plenty of work to do myself.

some people don't enjoy having to tinker with a carputer, but i'm happy to have a head unit with virtually no limit to upgradeability...
__________________
Orion329 is offline   Reply With Quote
Old 01-18-2010, 10:29 AM   #9
starsky
Registered User
 
Join Date: Jan 2010
Location: Los Angeles
Posts: 50
My Ride: 2001 325i
The carputer pics are not showing up for me also. I'm on the fence between a carpc/double din/dynavin.
starsky is offline   Reply With Quote
Old 01-18-2010, 10:39 AM   #10
Custom3
Registered User
 
Join Date: Sep 2005
Location: Dirty Jersey
Posts: 5,444
My Ride: HellRot 330CI
insane....thanks for posting...great job
Custom3 is offline   Reply With Quote
Old 01-18-2010, 11:11 AM   #11
Grande D
Registered User
 
Join Date: Dec 2006
Location: Dirty South
Posts: 3,356
My Ride: E90 M-Sport
Quote:
Originally Posted by Orion329 View Post
thanks. i've got plenty of work to do myself.

some people don't enjoy having to tinker with a carputer, but i'm happy to have a head unit with virtually no limit to upgradeability...
Holy



From your responses in other threads to my questions I was curious to what your setup was. All I can say is wow. Just wow. I had difficulty just getting one amp to sit behind the carpet where you but your pc, and you put your whole carputer there.
Grande D is offline   Reply With Quote
Old 01-18-2010, 07:41 PM   #12
Orion329
Registered User
 
Join Date: Jun 2007
Location: Chicago, IL
Posts: 480
My Ride: MKV GTI
Quote:
Originally Posted by starsky View Post
The carputer pics are not showing up for me also. I'm on the fence between a carpc/double din/dynavin.
not sure why they're not there.... hosted on photobucket, maybe i'll try reposting them somewhere else.

it took me a long while to go for it, ultimately there was just more options with a carputer. of course, you may want to look into using a laptop, pre-built solution for cars, or one of those double-din enclosures to make it an easier install. do a lot of reading before you jump in, but it's well worth it.

Quote:
Originally Posted by Custom3 View Post
insane....thanks for posting...great job
thanks

Quote:
Originally Posted by zhp43867 View Post
Holy



From your responses in other threads to my questions I was curious to what your setup was. All I can say is wow. Just wow. I had difficulty just getting one amp to sit behind the carpet where you but your pc, and you put your whole carputer there.
much appreciated.
__________________
Orion329 is offline   Reply With Quote
Old 01-19-2010, 05:19 AM   #13
Driiven
Registered User
 
Join Date: Dec 2006
Location: north jersey
Posts: 59
My Ride: bimmers
Dude, Install came out slick! For anyone thinking about going this route, if you have the time patience and know how, it is well worth it. You will never look back at an aftermarket unit the same again.

I'm thinking about swapping out my screen for the 706 as well, how do you like it so far?

As far as startup times, are you using standby/hibernate and did try using minlogon yet? Minlogon was major in bringing boot times down for me.







Sorry about the crappy pics, all I have is my cell phone for a camera.

Last edited by Driiven; 01-19-2010 at 05:50 AM.
Driiven is offline   Reply With Quote
Old 01-19-2010, 10:10 AM   #14
GCoop
Registered User
 
Join Date: Jan 2009
Location: Charlottesville VA
Posts: 1,077
My Ride: '04 325xi
Cant see the pics either. Very interested though.
GCoop is offline   Reply With Quote
Old 01-19-2010, 11:36 PM   #15
Orion329
Registered User
 
Join Date: Jun 2007
Location: Chicago, IL
Posts: 480
My Ride: MKV GTI
Quote:
Originally Posted by Driiven View Post
Dude, Install came out slick! For anyone thinking about going this route, if you have the time patience and know how, it is well worth it. You will never look back at an aftermarket unit the same again.

I'm thinking about swapping out my screen for the 706 as well, how do you like it so far?

As far as startup times, are you using standby/hibernate and did try using minlogon yet? Minlogon was major in bringing boot times down for me.
thanks Driiven, your help was invaluable.

regarding the screen: check your PM's

i did try using Minlogon, and didn't really get a boost on boot-up times from it. my issue is that i think my terabyte hard drive is slowing down the boot process. when building the system out of the car, i was under 15 seconds for a cold boot (freaking blazing fast SSD drive), but then i threw the terabyte drive in the mix, and it slowed it to about 35 seconds. i'm not sure why the bios is taking so long to initiate, but that combined with all the peripherals has slowed me down to almost a minute from cold boot....seems like hibernate takes even longer, sadly.

do you have issues with the cold impacting your boot times?

and are you using an OBD-II peripheral?

Quote:
Originally Posted by GCoop View Post
Cant see the pics either. Very interested though.
try visiting this link: http://s757.photobucket.com/albums/x...ter%20Install/

that's the link to the photobucket photo album that those are all shared in, if you can't see them there, then there's something going on with the hosting.
__________________
Orion329 is offline   Reply With Quote
Old 01-20-2010, 12:56 AM   #16
Driiven
Registered User
 
Join Date: Dec 2006
Location: north jersey
Posts: 59
My Ride: bimmers
Hey bud,

I think if you scrapped the 2gb ram and ran w/ hibernate you would find the system come up much faster . I bet you can run with 512 on the setup and notice no detriment to system performance. I am running pretty much the same external components on much slower hardware (single core 1.6 atom, 512mb with a mechanical 2.5" sata drive!) and the system is responsive and boots quickly. I would say to run the bios bare minimum, disable all ports and settings and see where it stands, slowly adding one by one til you find the issue. For example, on my motherboard legacy usb was a killer when it came to booting speed. As far as OS, are you running an n-lited install? This was also very important in getting the system to come up quickly. Disable all services that are fluff. It very well might be that you might have to scrap the 1tb drive in favor of an alternative solution or swap motherboards if its a bios issue.

Regarding my xenarc 700 vs.706. I also had a similar problem with the interior edging of the screen w/ rich's bezel. To be honest Rich's bezel took alot of modification to go into place without warping the screen to one side, affecting the touchscreen layer. Even now, I am not entirely impressed with its fitment. I have noted that your screen as well as other users screens fits recessed like the factory head unit. Mine is quite the opposite, it actually protrudes from the dash a few mm, especially on the bottom. where its maybe 3/8" or more outward than it should be.

Given what you told me in the PM, I am going to run with an aviation grade lcd of some sort. The CFL of my 702 is purple for a good 15 minutes in this cold weather . I did have some issues before with the additional board on the back loosening up, causing garbled images and screen refreshes every 5 seconds.... The epoxy that I use'd the first time didn't handle the temperatures in the summer months that well. It now look's like that is fixed but time will tell. Hopefully by summer, I will have found a proper solution to this lcd issue, probably something sourced for aviation. Xenarc isn't cutting it for me at this point.

Edit : I haven't noted temperatures affecting system boot up time.

Last edited by Driiven; 01-20-2010 at 02:51 AM.
Driiven is offline   Reply With Quote
Old 01-20-2010, 09:48 AM   #17
Orion329
Registered User
 
Join Date: Jun 2007
Location: Chicago, IL
Posts: 480
My Ride: MKV GTI
i'll look into dropping down to 1gb ram here soon. i can't really tweak the bios very easily with the resolution issues i mentioned in that PM. i bought some very low latency ram, and was hoping that it wouldn't be an issue running 2gb, but that would probably help. disabling legacy usb support seems like an interesting idea...

maybe i'll invest in a 250gb ssd drive in the future...

in some ways, i wish i would have fabricated my own bezel, especially considering the cost, but the construction of it is by far superior to the Bondo-tastic solution i would have otherwise.

let me know what screen you end up going with, and how much it costs. in my searching for different screens, i don't recall running into any that mentioned being aviation grade. are the ones at CarTFT.com similar to what you're looking at?

Edit: and i did use an nlited install--bios has been my one hold up in booting. the Windows splash screen would come up and the three blue bars that move across the screen wouldn't even become fully visible when the install was fresh....it was glorious.
__________________

Last edited by Orion329; 01-20-2010 at 09:52 AM.
Orion329 is offline   Reply With Quote
Old 01-20-2010, 10:50 AM   #18
GCoop
Registered User
 
Join Date: Jan 2009
Location: Charlottesville VA
Posts: 1,077
My Ride: '04 325xi
Quote:
Originally Posted by Orion329 View Post


try visiting this link: http://s757.photobucket.com/albums/x...ter%20Install/

that's the link to the photobucket photo album that those are all shared in, if you can't see them there, then there's something going on with the hosting.
Thanks. I can see the thumbnails but when I try to view the large pics they dont display there either.
GCoop is offline   Reply With Quote
Old 01-20-2010, 11:13 AM   #19
laureynsr
Registered User
 
Join Date: Jul 2009
Location: Palmyra, NJ
Posts: 57
My Ride: 2005 330i ZHP
Looks like IE does not like images

Hi All,

Just for S&G I tried viewing the thread in Firefox and all the pics work fine! Looks like IE is being a bugger about the spaces in the names.

Ray
__________________
2005 330i ZHP Imola Red Steptronic
Engine: K&N CAI, K&N Oil filter.
Interior: Carbon Fiber over aluminium pedals
Lights: Bi Xeonon, clear corners, clear sides
ICE: Dyanvin DVN-E46 v5, w/HK 12 speaker, Infinity Baselink and Proclip 5v iPhone mount.



"Imagination is more important than knowledge, for knowledge is limited while imagination embraces the entire world." Albert Einstein
laureynsr is offline   Reply With Quote
Old 01-20-2010, 05:48 PM   #20
Orion329
Registered User
 
Join Date: Jun 2007
Location: Chicago, IL
Posts: 480
My Ride: MKV GTI
good idea laureynsr.

i use Google Chrome.

definitely the fastest and most stable browser i've ever used.
__________________
Orion329 is offline   Reply With Quote
Reply

Tags
carpc, carputer, computer, diy, double din

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 02:42 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use