E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > DIY: Do It Yourself

DIY: Do It Yourself
Post here to share or improve your wrench turning skills! All BMW E46 DIY tips, tales, and projects discussed inside. Learn to work on your car and know the right BMW parts you will need!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 39 votes, 4.79 average.
Old 02-11-2010, 09:30 PM   #201
steve.325i
Registered User
 
Join Date: Aug 2008
Location: Brampton, Ontario, Canada
Posts: 763
My Ride: 2003 325i
Quote:
Originally Posted by JLondon View Post
I was playing with the CK3000 the other day and it appears that the "Magic Words" only works if your phone's "voice command" is turned off.
I have a BB Pearl (still havent replaced it but that is another issue) and I have programmed the magic words. I can confirm that "Hang up" does in fact terminate the call. Also it quite often askes me to "Say a Command" when I am driving in the car and talking to either my wife or son.

This never happens when I am in the car by myself - haha, proof I do not talk to myself - so it HAS to be the magic words kicking in & hearing the word "Phone" or something. I plan to disable the Magic Word feature but I think the only way to do it is to reset it & pair the phone again.

Quote:
Originally Posted by chris1098 View Post
One quick question before I start, If I dont disconnect the battery will any error codes come up on the OBC when the radio is out?
Nope, you will be ok. I do recommend pulling fuses #7 & 41 during the install.
steve.325i is offline   Reply With Quote
Old 02-11-2010, 11:09 PM   #202
green1
Registered User
 
Join Date: Jul 2006
Location: orange county, Ca
Posts: 37
My Ride: ox grn 02 325i
distorted sound

so far i've tried everything guys and no luck. I have checked all my connections twice, I moved the mic and mounted on the rearview mirror mount (tucked somewhat neatly behind it), and i have even tried using a different phone with the kit and still the same thing... great sound coming in and poor distorted sound or voice going out... people are still having trouble hearing me. I also search for the part half hour to see if i could buy a different mic but couldn't find much... anyone know where I could find something of this nature????
green1 is offline   Reply With Quote
Old 02-11-2010, 11:22 PM   #203
steve.325i
Registered User
 
Join Date: Aug 2008
Location: Brampton, Ontario, Canada
Posts: 763
My Ride: 2003 325i
Quote:
Originally Posted by green1 View Post
so far i've tried everything guys and no luck. I have checked all my connections twice, I moved the mic and mounted on the rearview mirror mount (tucked somewhat neatly behind it), and i have even tried using a different phone with the kit and still the same thing... great sound coming in and poor distorted sound or voice going out... people are still having trouble hearing me. I also search for the part half hour to see if i could buy a different mic but couldn't find much... anyone know where I could find something of this nature????
If you were local I would ask you to come over & we'll figure it out. You should be able to sub any mic that is targeted for a computer. Do a google search on "mic 1/8" and find something in your area or go to your local bestbuy & see what they have.

This sony [Model: ECMDS30P] looks very cool. You could add this with a 1/8" extension cable & try it. $50 is a little steep, but I bet its worth it & if it doesn't work out you can return it

http://www.bestbuy.com/site/Sony+-+E...=mic&cp=1&lp=6
steve.325i is offline   Reply With Quote
Old 02-12-2010, 05:25 AM   #204
chris1098
Registered User
 
Join Date: Jan 2010
Location: England
Posts: 60
My Ride: 2003 318ci
Thankyou sycE46, It all makes perfect sense now..!!

Will any error codes come up on the OBC if I dont disconnect the battery?

It started snowing last night so didnt do the install, may do it over the weekend when I get round to doing my window regulator, the frost claimed it last week It broke the clip so it pulled the glass outta line.

Not looking forward to playing with the airbag in the door card though, Im under strict instructions not to disconnect though so it should be all good!!

Chris
chris1098 is offline   Reply With Quote
Old 02-12-2010, 06:14 AM   #205
JLondon
Registered User
 
Join Date: Aug 2002
Location: New Jersey
Posts: 96
My Ride: 2000 328Ci
Quote:
Originally Posted by green1 View Post
so far i've tried everything guys and no luck. I have checked all my connections twice, I moved the mic and mounted on the rearview mirror mount (tucked somewhat neatly behind it), and i have even tried using a different phone with the kit and still the same thing... great sound coming in and poor distorted sound or voice going out... people are still having trouble hearing me. I also search for the part half hour to see if i could buy a different mic but couldn't find much... anyone know where I could find something of this nature????
Are you having the same problem that I and others have had regarding muffled, scratchy, static sound when traveling at speed? Others indicate an inline resistor can fix this problem.
JLondon is offline   Reply With Quote
Old 02-12-2010, 06:45 AM   #206
GT172I
Registered User
 
Join Date: Mar 2009
Location: Atlanta
Posts: 131
My Ride: 2003 & 2004 330Ci
So my Connect2 wire harnesses finally arrived yesterday (ordered on 25th), so yeah like everybody said just be patient with international snail-mail and I'll be attempting the install this weekend.

Had a brief yesterday when looking at the sunroof panel...

I was wondering if anybody has used the factory mic? My car has Assist/pre-wired for bluetooth (not sure which installs it) so has a mic attached the little black grill on the sunroof control panel. It looks almost as if you could use a headphone extension cord ($~4) slice off the end and splice the ends into the harness on the factory mic to get OEM mic quality/positioning advantages by only re-running the wire to the Parrot control box instead of the cars TCU...

Sounds logical in my head, anybody attempted this/have input?
__________________
APEX ARC-8's | UUC EVO3 SSK | UUC TSE3-L | H&R sways
Stebel Truck Horn | Misc cosmetic stuff
GT172I is offline   Reply With Quote
Old 02-12-2010, 11:13 AM   #207
GT172I
Registered User
 
Join Date: Mar 2009
Location: Atlanta
Posts: 131
My Ride: 2003 & 2004 330Ci
eh? eh? anybody?
__________________
APEX ARC-8's | UUC EVO3 SSK | UUC TSE3-L | H&R sways
Stebel Truck Horn | Misc cosmetic stuff
GT172I is offline   Reply With Quote
Old 02-12-2010, 12:51 PM   #208
sycE46
Registered User
 
Join Date: Dec 1969
Location: Bay Area
Posts: 1,889
My Ride: 323ci
Quote:
Originally Posted by chris1098 View Post
Thankyou sycE46, It all makes perfect sense now..!!

Will any error codes come up on the OBC if I dont disconnect the battery?

It started snowing last night so didnt do the install, may do it over the weekend when I get round to doing my window regulator, the frost claimed it last week It broke the clip so it pulled the glass outta line.

Not looking forward to playing with the airbag in the door card though, Im under strict instructions not to disconnect though so it should be all good!!

Chris
yah... don't disconnect the airbag unless you want to reset the SRS light. When I fixed the window regulators in my friend's car, I just moved the air bag and zip tied it to the door. I also disconnected the battery during the times I didn't need to move the window motors.
sycE46 is offline   Reply With Quote
Old 02-13-2010, 10:39 AM   #209
chris1098
Registered User
 
Join Date: Jan 2010
Location: England
Posts: 60
My Ride: 2003 318ci
Quote:
Originally Posted by sycE46 View Post
yah... don't disconnect the airbag unless you want to reset the SRS light. When I fixed the window regulators in my friend's car, I just moved the air bag and zip tied it to the door. I also disconnected the battery during the times I didn't need to move the window motors.
Thanks sycE46!!

Ok well here I am eating my own words when I said the install would be straight forward

I installed the CK3000 setup, followed the instructions to the letter.

I struggled to get the vent out as I was scared about breaking it but I bit the bullet and go it out after 20mins of trying!!

After that everything went well, connected all the cables, neatly placed them around the ducts. I powered the bluetooth which seemed to work fine, it connected to my phone and I could use the steering wheel functions to dial the last called number....

Then......when the 'phone' is on the CD Player and I call out or somebody calls me there is no audio. I cant hear anybodies voice through the speakers..I have tried the obvious such volume of the radio but I cant hear anything..!! when I swith the mode to CD/Radio or the changer the sound is fine..

Anybody tell me what I have done wrong or how I can get audio?

Also to top it off, my E46 for some reason has the strangest problem ever where, if I play around with the electrics the starter motor sounds like it sticks in position. Like I have done the blutooth today and the Starter is stuck and the car wont crank, It has only ever happened to me on 2 previous occasions where I tried my new LED Rear lights (Genuine, not sh!t from Thailand Tim on ebay ).. I have to bump it to get it started then its fine, the starter never sticks and I think its too much of a coincidence for it to only stick on the 3 occasions I have installed something me....

Has anyone else ever had this happen or heard about it?


Chris
chris1098 is offline   Reply With Quote
Old 02-13-2010, 11:41 AM   #210
delmarco
Registered User
 
Join Date: Nov 2008
Location: Westchester, NY
Posts: 6,287
My Ride: 2001 330i
Send a message via ICQ to delmarco Send a message via Yahoo to delmarco
Quote:
Originally Posted by chris1098 View Post
Thanks sycE46!!

Ok well here I am eating my own words when I said the install would be straight forward

I installed the CK3000 setup, followed the instructions to the letter.

I struggled to get the vent out as I was scared about breaking it but I bit the bullet and go it out after 20mins of trying!!

After that everything went well, connected all the cables, neatly placed them around the ducts. I powered the bluetooth which seemed to work fine, it connected to my phone and I could use the steering wheel functions to dial the last called number....

Then......when the 'phone' is on the CD Player and I call out or somebody calls me there is no audio. I cant hear anybodies voice through the speakers..I have tried the obvious such volume of the radio but I cant hear anything..!! when I swith the mode to CD/Radio or the changer the sound is fine..

Anybody tell me what I have done wrong or how I can get audio?

Also to top it off, my E46 for some reason has the strangest problem ever where, if I play around with the electrics the starter motor sounds like it sticks in position. Like I have done the blutooth today and the Starter is stuck and the car wont crank, It has only ever happened to me on 2 previous occasions where I tried my new LED Rear lights (Genuine, not sh!t from Thailand Tim on ebay ).. I have to bump it to get it started then its fine, the starter never sticks and I think its too much of a coincidence for it to only stick on the 3 occasions I have installed something me....

Has anyone else ever had this happen or heard about it?


Chris
Sound like your battery died! and/or is on it's way out.

Same thing happened to me when I was repairing my sunroof. I had my door open and the key in the on position so that I could play the sun roof motor. Darn thing ended up taking me about 3-4 hours and when I was done everything was fine but the car didn't start.

Immediately I realized that the car has been on/engine off for about 4 hours straight.

I jumped the battery and the car started fine. This is a normal side effect of installing something in your car that sort of needs the key in the on position and you end up taking longer than 2-3 hours before starting the engine again. Especially if your car and/or battery is more than 5 years old.


As for your ck3000. Could be the battery but still check ALL your connections and make sure the ck3000 controller's buttons are not being squished in the glove box area.

Quote:
Originally Posted by sycE46 View Post
yah... don't disconnect the airbag unless you want to reset the SRS light. When I fixed the window regulators in my friend's car, I just moved the air bag and zip tied it to the door. I also disconnected the battery during the times I didn't need to move the window motors.
I think you can also pull the airbag fuses as well if you working around the airbags but not necessarily disconnecting them.
__________________




VISIT MY GARAGE TO SEE ALL MY MODS:

http://directory.e46fanatics.com/use...rMod&UcId=7917

Last edited by delmarco; 02-13-2010 at 11:48 AM.
delmarco is offline   Reply With Quote
Old 02-13-2010, 12:15 PM   #211
Born Again
Registered User
 
Born Again's Avatar
 
Join Date: Dec 2004
Location: Tis quite a statement. Where do you live - where do we all live? in our minds? our souls? our bodies?
Posts: 4,660
My Ride: She aint much 330ci
hmm - anyone else bothered that u can't actually see whose calling? besides looking at your phone screen?

i always leave my iphone in the sun glass holder
__________________

best mod to date : OEM grocery bag holder

Quote:
Originally Posted by Zell View Post
E46Fanatics - the Honda community of gun owners. Keep staying classy, I'm sure you all are going to be excellent examples of how to keep gun rights from being infringed. :facepalm:
Born Again is offline   Reply With Quote
Old 02-14-2010, 07:39 AM   #212
PEEBU
Registered User
 
Join Date: Jan 2010
Location: UK
Posts: 61
My Ride: E46 Touring
Del Marco, what a top man you are !!! Just done this install on my 2004 touring (Wagon to you guys) and my wifes 2006 M sport Coupe. Very easy to do and your instructions were spot on. I removed the vent on both installs but found I didnt need to. The original connector from the cars wiring loom to the back of the head unit can be slid to the left (Or right on your cars) and pushed out of the side of the cradle for the headunit. You can then make the connections to the parrot and silver box of tricks just above and to the right (Or left) of the glovebox. The hardest part was remembering where I had put all the screws !!!

Also, a quick question on the headunit. I have a Cassette headunit manufactured in Feb 2004. Has the mode button on and the pins for (What I think is) the Aux input next to the CD changer input. Been checking some previous posts and the the consensus is that you cannot have AUX input with a cassette head unit. If this is the case, what are these pins for on my head unit? Any ideas? Thanks. Picture attached
Attached Thumbnails
Click image for larger version

Name:	back of radio.jpg
Views:	98
Size:	149.7 KB
ID:	348561  
PEEBU is offline   Reply With Quote
Old 02-14-2010, 11:16 AM   #213
delmarco
Registered User
 
Join Date: Nov 2008
Location: Westchester, NY
Posts: 6,287
My Ride: 2001 330i
Send a message via ICQ to delmarco Send a message via Yahoo to delmarco
Quote:
Originally Posted by PEEBU View Post
Del Marco, what a top man you are !!! Just done this install on my 2004 touring (Wagon to you guys) and my wifes 2006 M sport Coupe. Very easy to do and your instructions were spot on. I removed the vent on both installs but found I didnt need to. The original connector from the cars wiring loom to the back of the head unit can be slid to the left (Or right on your cars) and pushed out of the side of the cradle for the headunit. You can then make the connections to the parrot and silver box of tricks just above and to the right (Or left) of the glovebox. The hardest part was remembering where I had put all the screws !!!

Also, a quick question on the headunit. I have a Cassette headunit manufactured in Feb 2004. Has the mode button on and the pins for (What I think is) the Aux input next to the CD changer input. Been checking some previous posts and the the consensus is that you cannot have AUX input with a cassette head unit. If this is the case, what are these pins for on my head unit? Any ideas? Thanks. Picture attached
You are welcome.

Here you go....according to this it should control AUX.

__________________




VISIT MY GARAGE TO SEE ALL MY MODS:

http://directory.e46fanatics.com/use...rMod&UcId=7917
delmarco is offline   Reply With Quote
Old 02-14-2010, 01:01 PM   #214
Born Again
Registered User
 
Born Again's Avatar
 
Join Date: Dec 2004
Location: Tis quite a statement. Where do you live - where do we all live? in our minds? our souls? our bodies?
Posts: 4,660
My Ride: She aint much 330ci
^^^ is it annoying not to know whose calling?

do u always have your phone display visible
__________________

best mod to date : OEM grocery bag holder

Quote:
Originally Posted by Zell View Post
E46Fanatics - the Honda community of gun owners. Keep staying classy, I'm sure you all are going to be excellent examples of how to keep gun rights from being infringed. :facepalm:
Born Again is offline   Reply With Quote
Old 02-17-2010, 02:50 PM   #215
GT172I
Registered User
 
Join Date: Mar 2009
Location: Atlanta
Posts: 131
My Ride: 2003 & 2004 330Ci
Had it installed for a couple days now and I love it. Thanks for the great write-up sync & delmarco!

Only problem I ran into was, like everbody before me, getting the damn vents out and forgetting to route all the wires in exactly the right path. Be sure to check clearances on where youre trying to drag the connectors
All in all about an hour because I didn't have adequate light and had to fumble around with a flashlight

Quote:
Originally Posted by Born Again View Post
^^^ is it annoying not to know whose calling?

do u always have your phone display visible
Not really that annoying for me since I have my contacts sorted into groups with different ringtones for the groups so I can narrow it down by that since the phone still rings like normal and the Parrot (car speakers) ring their own ring at the same time.
__________________
APEX ARC-8's | UUC EVO3 SSK | UUC TSE3-L | H&R sways
Stebel Truck Horn | Misc cosmetic stuff
GT172I is offline   Reply With Quote
Old 02-20-2010, 06:41 PM   #216
Bimmerci330
Registered User
 
Join Date: Mar 2009
Location: New Milford, CT
Posts: 263
My Ride: 02 330CI 3 Pedals :)
Send a message via AIM to Bimmerci330
Finally got my kit from the UK yesterday, ordered on like the 31st shipped the 10th, installed today, love it, with the magic words all I have to do is say "phone" and it connects and "hang up" and it disconnects, don't even have to use the steering wheel buttons if I don't want to, only issue I had was the mic placement, if I use the OEM location people say I sound like I'm in a tunnel so I put it on the other side of the OEM spot and works great, I just don't really like to look at it but oh well, thanks for the great write up
__________________
Bimmerci330 is offline   Reply With Quote
Old 02-20-2010, 06:52 PM   #217
delmarco
Registered User
 
Join Date: Nov 2008
Location: Westchester, NY
Posts: 6,287
My Ride: 2001 330i
Send a message via ICQ to delmarco Send a message via Yahoo to delmarco
Quote:
Originally Posted by Bimmerci330 View Post
....with the magic words all I have to do is say "phone" and it connects and "hang up" and it disconnects, don't even have to use the steering wheel buttons if I don't want to....
I'm so glad that 1 in the hundreds of us that followed the DIY actually read the manual and realized the kit comes with it's own voice command (magic words).

Even I didn't realize that until months after and it was when I was installing something else in the car that I discovered the ck3000 kit had intellegence to listen and talk to me and was mutli lingual as well.



Quote:
Originally Posted by Bimmerci330 View Post
I just don't really like to look at it but oh well, thanks for the great write up
like to look at what? you shouldn't even be able to see anything the kit can be installed behind your glovebox.
__________________




VISIT MY GARAGE TO SEE ALL MY MODS:

http://directory.e46fanatics.com/use...rMod&UcId=7917
delmarco is offline   Reply With Quote
Old 02-20-2010, 06:54 PM   #218
Custom3
Registered User
 
Join Date: Sep 2005
Location: Dirty Jersey
Posts: 5,422
My Ride: HellRot 330CI
awesome
Custom3 is offline   Reply With Quote
Old 02-20-2010, 07:49 PM   #219
ZZen330
Registered User
 
Join Date: Apr 2009
Location: Canada
Posts: 1,141
My Ride: 2002 330Ci
My Parrot (Eclipse) kit and Connects2 kits arrived this past week. Won't get a chance to install for a week or so though. I'm hoping that the sound for callers on the other end will be ok with the mic in the OEM position. Otherwise I'll try to find another hidden spot that works.
ZZen330 is offline   Reply With Quote
Old 02-20-2010, 08:36 PM   #220
Bimmerci330
Registered User
 
Join Date: Mar 2009
Location: New Milford, CT
Posts: 263
My Ride: 02 330CI 3 Pedals :)
Send a message via AIM to Bimmerci330
like to look at what? you shouldn't even be able to see anything the kit can be installed behind your glovebox.[/QUOTE]

im talking about the mic location, i first had the mic where you have yours installed but i had to move it to the other side (outside of the headliner) because people said i sounded like i was in a tunnel.
__________________
Bimmerci330 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 03:29 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use