E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 03-07-2010, 01:23 PM   #1
aggieE46
Keep it clean
 
aggieE46's Avatar
 
Join Date: Aug 2006
Location: Royse City
Posts: 8,048
My Ride: 03 Evo, 07 Passat
Send a message via AIM to aggieE46
P0339 and an odd trip home

So, I was leaving the grocery store today and suddenly my DSC light and Brake light lit up yellow like I had turned off traction control. I quickly noticed that the car was in limp mode. Really odd, as nothing out of the ordinary has happened and I haven't messed with the car in a while.

I pulled over and the car had a hard time starting back up. I cruised home and pulled over and killed it again. When I cranked it back up, it finally threw a SES. Had the code pulled and got P0339 which I know is for the CPS. What's odd, though, is that when I got back in the car to go home, everything is fine... I'm going to check the wiring and make sure everything is okay and consider changing the sensor (broke right now). Any thoughts?
__________________
aggieE46 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 03-07-2010, 06:32 PM   #2
mrshelley
Registered User
 
Join Date: May 2004
Location: Bethlehem, PA
Posts: 916
My Ride: 2004 330i
FYI: I had the intake cam position sensor fail at Homestead and it cost me a win.
__________________
mrshelley is offline   Reply With Quote
Old 03-07-2010, 07:28 PM   #3
aggieE46
Keep it clean
 
aggieE46's Avatar
 
Join Date: Aug 2006
Location: Royse City
Posts: 8,048
My Ride: 03 Evo, 07 Passat
Send a message via AIM to aggieE46
Boo for sensors

Quote:
Originally Posted by mrshelley View Post
FYI: I had the intake cam position sensor fail at Homestead and it cost me a win.
__________________
aggieE46 is offline   Reply With Quote
Old 03-07-2010, 07:38 PM   #4
mrshelley
Registered User
 
Join Date: May 2004
Location: Bethlehem, PA
Posts: 916
My Ride: 2004 330i
It only cost me $12K in prize money.
__________________
mrshelley is offline   Reply With Quote
Old 03-08-2010, 01:13 AM   #5
SL Blak Soldier
Registered User
 
Join Date: Oct 2006
Location: Woodland Hills < SFV < LA < SoCal
Posts: 27,360
My Ride: 3 Pedal SG S54B32
Send a message via AIM to SL Blak Soldier
^Wow, that sucks.

But yeah... I had a CPS go a while ago. It was an on & off occurrence. I drove around one mine for a while until it got super annoying, then i changed it.
__________________
SL Blak Soldier is offline   Reply With Quote
Old 03-08-2010, 11:19 AM   #6
aggieE46
Keep it clean
 
aggieE46's Avatar
 
Join Date: Aug 2006
Location: Royse City
Posts: 8,048
My Ride: 03 Evo, 07 Passat
Send a message via AIM to aggieE46
You win That really sucks.

Quote:
Originally Posted by mrshelley View Post
It only cost me $12K in prize money.
__________________
aggieE46 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 07:45 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use