E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > BMW Regional Forums > Regional Forums > California

California
Have you seen another BMW while driving around in your area? Maybe you can find their car in the E46Fanatics Garage!
Northern California Southern California

If you don't have your garage setup, sign up today HERE

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 4 votes, 5.00 average. Display Modes
Old 04-08-2010, 11:07 AM   #1
Scott87
Registered User
 
Join Date: Feb 2010
Location: UK
Posts: 590
My Ride: 325ci 2001
Smile Instrument Cluster LED Conversion (pics)

Ok first up, thanks to wooboodoo for his thread here on how to make this possible. This is my first DIY so i'm going to try do it right!

This is how my Instrument Cluster (IKE) looked before I started:


I wanted it to have white dials/clocks, a blue LCD, red needles and the silver gauge surrounds. The red needles were done with the usual Sharpie DIY, i got a set of silver gauge rings off ebay for 18 delivered and bought all my LED + soldering equipment from led-depot.co.uk.

OK first up removing the cluster, there are 2 x T20 screws above the clusters front 'window'. Remove those and the unit will slide forward. Depending on your driving style you may need to drop the steering wheel and pull it back. Use the lever underneath. The IKE will come a way out before the cables snag. There are 2, if you look they are similar in style, push the catch down and the lever arm will slide over and release the clips. You will be left with a nice hole:


To dismantle the cluster first remove the 'brow' from the top of the unit on the front. This is simply 2 little clips you press and it will slide out:


Next flip it over and remove the screws. Not all of the holes on any cluster i have seen seem to be populated so remove any Torx screw. Screws removed:


There are then a set of plastic clips around the two halves holding it together. Gently release them:


Now with the cluster sat on its back hold the front face down and pull off the trip reset and clock adjust knobs. They are just rubber covers and will pull off, do it slowly. Once these are off simply lift the cover up and it will come away from the unit:


You can lift the gauges out of the back cover but i found it makes a perfect holder so i didn't damage components on the back and left it there. The two plastic overlays at the bottom (one on the left and right) that cover your warning light areas just lift off, remove them. Now the tricky part, the needles. Starting with a less important one (I did fuel and temp first) pinch the centre cap of the needle between thumb and finger and rotate it anti-clockwise whilst lifting. Ignore any slight resistance you feel this is fine and lift the needles off. Remove the MPG before RPM or you will get stuck!


Once the needles are off the plastic overlay with the markings on simply lifts off. If you lift the PCB out of the back half of the housing there are 4 metal clips where the LCD is that need to be unclipped before the front white plastic cover will come off:


Now i have not soldered anything for well over 10 years (the last time i did it was in school for some lame project) so you do not need to be a whizz at it. All you need is patience, you don't want to lift any traces or break anything. The little cluster of LED's around each pin is what illuminates that dial. Wooboodoo has a great image in his thread. There are 4 LEDs on the RPM and Speed, 2 on fuel and temp and 1 on the MPG. Please remember LEDs have a polarity, indicated by a notch on the corner of the LED. When fitting a new LED please make sure you put them back the right way! Here is my first LED removed from the Speed gauge, you can see it just behind the pin sticking up.


They are easy to remove. Gently heat the solder joint on one side of the LED and using a pair of tweezers or very small pliers gently lift that side once the solder has melted. Repeat on the other side and the LED will come off the board. PLEASE DO NOT RUSH THIS. You could lift a trace off the board which would be a PITA to fix. I did this whole thing with no muck ups in around 2 hours. Here is my first 'aftermarket' LED installed. You can see it has a yellow top compared to the BMW ones which have a white top.


Now after i had done the speed and rpm LEDs i plugged it in with the car lights on to test if they worked. If you can imagine the centre of each dial you can see the new white LEDs. Excuse the bad photo it was broad daylight outside...


Now i know it was working i carried on with the rest of the LEDs. Once these are done it is on with the LCD. IMPORTANT - As soon as you lift the LCD out mark which of the two 'foam bits' is top and bottom, this will save you big headaches. The LCD is fragile glass so be careful with it.


In the above image i have already removed the orange backing on the LCD to get rid of the orange glow it has. This simply peels off the back of the screen. IMPORTANT - There is a very fine blue film under this orange film, make sure you do not lift this as it is a part of the LCD and will break it. With this film removed you can pop it back in place as that is now ready. After putting it all back together i didnt like how the LCD looked, the orange film made it glow rather than be a bright illumination. I cut around the orange film on a piece of normal white paper and put this in its place. Perfect. The paper 'glows' blue from the LEDs behind and the LCD looks good. Camera was crap so you can't see the LCD well and the blue looks a different colour...


At this point you can swap any LED in the cluster you want. Simply hold the plastic overlays on the board to see which LEDs do what and away you go. I swapped the ones that do the picture of the car which shows when doors are open. Thats now white also.

This is the finished product, i will get some night shots in a few hours when it goes dark. The neighbours think i'm a moron for taking pictures of my dash with a towel over my head...


As the saying goes, re-assembly is a reversal of removal or something like that.

**When you come to put the needles back on start with the needle at the top end of the dial. As you SLOWLY and GENTLY push it down and turn it anti-clockwise you will have to push it down enough to be on firmly but not to touch the dial face. As you turn it you will feel a point where it kind of stops. Keep pushing this anti-clockwise until it reaches where the needle should stop normally. It should now turn clockwise freely to the top of the gauge and then freely back until it hits the stop point.***

This is my first DIY and constructive criticism is welcome. I did break my clusters the first time i did this and had to buy a new set and get them coded to my car. Cost me just over 100 to do this so i hope this DIY means other people can do it without that expense. If you want larger images emailing to you PM me and i will fire them over. There are also a lot more than shown here.

Thanks!

Last edited by Scott87; 04-08-2010 at 11:12 AM. Reason: More Image Links...
Scott87 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 04-08-2010, 12:50 PM   #2
wooboodoo
Registered User
 
wooboodoo's Avatar
 
Join Date: Aug 2006
Location: New York
Posts: 761
My Ride: is alpine white...
Great job !!!

did you paint the needles red?

Regards,
mark
__________________


No matter which BMW model you drive, pure chiseled performance is the
pulsating heart of its DNA. Yet the 13th letter of the alphabet takes every
BMW built-in performance advantage and amps it up to the Mth degree.
Call it the Year of M.
D. Randy Riggs
wooboodoo is offline   Reply With Quote
Old 04-08-2010, 01:01 PM   #3
Scott87
Registered User
 
Join Date: Feb 2010
Location: UK
Posts: 590
My Ride: 325ci 2001
Nah i gave them 3 'coats' with a red Sharpie!!! Seems to look better if you let it dry and give it another layer
Scott87 is offline   Reply With Quote
Old 04-08-2010, 02:48 PM   #4
Scott87
Registered User
 
Join Date: Feb 2010
Location: UK
Posts: 590
My Ride: 325ci 2001
As promised some shots of the new IKE LEDs in the dark:

















Let me know what you think. The blue really hasn't come out well, the camera has the colour way off and it looks a lot brighter in the pics. I like the white back light though, not harsh on the eyes and looks really clean.

Thanks.
Scott87 is offline   Reply With Quote
Old 04-08-2010, 03:06 PM   #5
sillieidiot
Registered User
 
Join Date: Sep 2004
Location: the OC
Posts: 44,135
My Ride: '06 AW 330ci
Send a message via AIM to sillieidiot
nice job. that's exactly what i did with my spare cluster. the only problem i have is the LCD part and the orange film. I'm trying to make that white as well, but can't find anything good to use as a filter. it seems to glow peach lol

btw, for your LCD, might want to try using one of those clear plastic folder (cheap ones that are kind of flimsy), and a piece of paper behind that. that's what i did and it turned out well. even for red too. they just don't sell those damn folders in white lol
__________________
I like to reply to threads with 0 posts




Have a lighting problem? Read this first:
Lighting-related Troubleshooting Guide
sillieidiot is offline   Reply With Quote
Old 04-08-2010, 03:27 PM   #6
Scott87
Registered User
 
Join Date: Feb 2010
Location: UK
Posts: 590
My Ride: 325ci 2001
Thumbs Up

Try a piece of paper and one of those A4 pockets you can put them in. I liked the look of white dials and white needles, tempted to swap them out, it was very clean. Might try tinkering with a white LCD setup on my spare cluster and see what happens.

Thanks for the feedback.
Scott87 is offline   Reply With Quote
Old 04-08-2010, 03:54 PM   #7
Scott87
Registered User
 
Join Date: Feb 2010
Location: UK
Posts: 590
My Ride: 325ci 2001
I have made a RAR file of all the pictures i took whilst doing this mod.

You can get the file HERE.

If you don't have WinRar you can get it HERE.
Scott87 is offline   Reply With Quote
Old 04-08-2010, 04:01 PM   #8
nowerelsetoroam
Registered User
 
Join Date: Jul 2009
Location: Colorado Rockies
Posts: 539
My Ride: E46,740i
Send a message via MSN to nowerelsetoroam
This looks amazing!
__________________

Swicthed from
a 323 to a 740
nowerelsetoroam is offline   Reply With Quote
Old 04-15-2010, 10:53 PM   #10
mvrk10256
Registered User
 
Join Date: Jul 2009
Location: Austin, Tx
Posts: 3,904
My Ride: E30 325i
Send a message via AIM to mvrk10256
the while looks not very bright at all?

did you have it turned down? can you post a few better pics plz?
__________________
mvrk10256 is offline   Reply With Quote
Old 04-16-2010, 07:00 AM   #11
Scott87
Registered User
 
Join Date: Feb 2010
Location: UK
Posts: 590
My Ride: 325ci 2001
Yes it is turned down as the blue is way too bright. This weekend I'm adding another filter to the blue LCD or maybe changing to White so I can have it on full power and not have a mega bright blue screen. Will post up pics when it's sorted.
Scott87 is offline   Reply With Quote
Old 04-16-2010, 01:02 PM   #12
330ciandr6
Registered User
 
Join Date: May 2007
Location: .
Posts: 6,605
My Ride: .
Send a message via AIM to 330ciandr6 Send a message via Yahoo to 330ciandr6
may attempt this on an old cluster first
__________________
Have a oil or coolant leak? Click here!:http://forum.e46fanatics.com/showthr...732&highlight=
ABS/DSC/Brake/Airbag light on?? Click here!:http://forum.e46fanatics.com/showthr...648&highlight=
330ciandr6 is offline   Reply With Quote
Old 04-16-2010, 03:08 PM   #13
mvrk10256
Registered User
 
Join Date: Jul 2009
Location: Austin, Tx
Posts: 3,904
My Ride: E30 325i
Send a message via AIM to mvrk10256
Quote:
Originally Posted by 330ciandr6 View Post
may attempt this on an old cluster first
lol. i am trying to decide if i want to get another cluster and do this or just go ahead and do this on my cluster.

probably just do it on mine. please turn it up and post a few pics. i want to see what the white looks like turned up bright. also i cant decide if i want blue. i wonder if there is anyway to change the radio screen to another color.
__________________
mvrk10256 is offline   Reply With Quote
Old 04-16-2010, 03:53 PM   #14
sillieidiot
Registered User
 
Join Date: Sep 2004
Location: the OC
Posts: 44,135
My Ride: '06 AW 330ci
Send a message via AIM to sillieidiot
Quote:
Originally Posted by Scott87 View Post
Try a piece of paper and one of those A4 pockets you can put them in. I liked the look of white dials and white needles, tempted to swap them out, it was very clean. Might try tinkering with a white LCD setup on my spare cluster and see what happens.

Thanks for the feedback.
i've done the piece of paper by itself, or with multiple layers but it's not uniform enough

could you link me to the a4 pocket you're referring to? i'm not coming up with anything lol. yea i'm doing the same thing, figuring out all the kinks on my spare cluster before doing it on my car.
__________________
I like to reply to threads with 0 posts




Have a lighting problem? Read this first:
Lighting-related Troubleshooting Guide
sillieidiot is offline   Reply With Quote
Old 04-16-2010, 03:57 PM   #15
sillieidiot
Registered User
 
Join Date: Sep 2004
Location: the OC
Posts: 44,135
My Ride: '06 AW 330ci
Send a message via AIM to sillieidiot
Quote:
Originally Posted by mvrk10256 View Post
lol. i am trying to decide if i want to get another cluster and do this or just go ahead and do this on my cluster.

probably just do it on mine. please turn it up and post a few pics. i want to see what the white looks like turned up bright. also i cant decide if i want blue. i wonder if there is anyway to change the radio screen to another color.
this is how it would look with the LEDs turned up. but in my pictures you can see i didn't really paint the needles perfectly, and the trouble i had with the LCD.



__________________
I like to reply to threads with 0 posts




Have a lighting problem? Read this first:
Lighting-related Troubleshooting Guide
sillieidiot is offline   Reply With Quote
Old 04-27-2010, 06:36 PM   #16
Pat-UK
Registered User
 
Join Date: Mar 2006
Location: Kent UK
Posts: 83
My Ride: 325i Auto
Send a message via ICQ to Pat-UK
Cool

Quote:
Originally Posted by Scott87 View Post
Yes it is turned down as the blue is way too bright. This weekend I'm adding another filter to the blue LCD or maybe changing to White so I can have it on full power and not have a mega bright blue screen. Will post up pics when it's sorted.
Small Blob of hot glue on top of the LEDs to act as a diffuser and also change the current limiting resistor to a higher value to bring the brightness in line with the rest of the cluster.

Easy Peasy
__________________
Pat-UK is offline   Reply With Quote
Old 04-28-2010, 11:50 AM   #17
Scott87
Registered User
 
Join Date: Feb 2010
Location: UK
Posts: 590
My Ride: 325ci 2001
I would try the blob of glue but then it may be a PITA to remove the LEDs in the future i can simply add a slightly thicker piece of paper in front of them to filter out more light. also changing resistors again makes it harder to change in the future. thanks for the thought though
Scott87 is offline   Reply With Quote
Old 05-01-2010, 11:52 AM   #18
undetterred
Registered User
 
Join Date: Apr 2010
Location: Uk
Posts: 1
My Ride: 320i
Top thread..............

I've got an issue with the 'oil can' not illuminating on my dash?are these bulbs/leds in the dash,can they be replaced are they plug and play.
undetterred is offline   Reply With Quote
Old 05-09-2010, 11:52 AM   #19
Scott87
Registered User
 
Join Date: Feb 2010
Location: UK
Posts: 590
My Ride: 325ci 2001
Quote:
Originally Posted by undetterred View Post
Top thread..............

I've got an issue with the 'oil can' not illuminating on my dash?are these bulbs/leds in the dash,can they be replaced are they plug and play.
The only thing that is a bulb is the headlight 'main beam' blue icon at the top. I have no idea why all the others are LEDs and this is a filament bulb... You would need to remove the old LED, simply de-solder, and solder a new LED in its place. That should fix it if it's the LED that is broken.
Scott87 is offline   Reply With Quote
Old 05-23-2010, 06:52 PM   #20
XANDERCOM
Registered User
 
Join Date: May 2010
Location: Bournemouth UK
Posts: 48
My Ride: E46 318i SE
Hey everyone
I'm new to this site and new to BMW ownership!
Just wanted to say what a fantastic guide this is, and what a great place this is to talk to other owners!

Following this guide I got stuck in and swapped out some LED's in my dash. I ordered 10 LEDs to get started from ebay for a couple of quid.
Now I have ordered more and am going to finish the job and get started on other elements in the car such as the aircon controls etc. Will do my bit by posting guides as I go!

Anyway, here is the picture of my dash! I'm so pleased! I will go back in and swap out the LED's behind the LCD later in the week when more LEDs arrive!

XANDERCOM is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 03:44 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use