E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 04-06-2010, 08:01 PM   #1
Radi27
Registered User
 
Join Date: Apr 2010
Location: Cleveland, OH
Posts: 2
My Ride: 2004 330xi
2004 330xi has rough idle--need help please

Hi, I recently purchased a 2004 330xi, with less than 50k miles from a Lexus dealer. I drove it approximately 250 miles home, then maybe another 50 miles rountrip. When the car is in park, it has a strange noise, like a belt or something might be loose. At first, I thought it was just when the AC was on (which I thought might be further proof of a belt issue), but I was wrong. It is like that all the time. If I accelerate, it goes away. Any ideas? I am not a huge tech guy, but I was hoping to avoid a dealer, especially given I just got the thing. Any suggestions would be appreciated. New to the board, so thanks for the help.
Radi27 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 04-09-2010, 07:51 AM   #2
Nachos23
Registered User
 
Join Date: Nov 2009
Location: Brampton, Ontario
Posts: 633
My Ride: 2004 330Xi
Send a message via MSN to Nachos23
I have an 04 300Xi that was experiencing a weird "squeeking" sound almost constantly... We replaced piece-by-piece the parts driven or in contact with main drive belt (not AC belt) and it turned out to be my mechanical tensioner. Sounded fine when the belt was off and spun normally, but attach the belt and the noise came back. We replaced, idler, water pump and alternator forst because it DID NOT sound like a tensioner issue.... squeek gone now. Could just be your belt. Get some talcom powder and lightly dust it over all the components on the drive and AC belts. See if weird noise goes away. Dust each piece separately (water pump, alternator, idler, tensioner, AC compressor and harmonic balancer (main drive for both belts) and then the belts themselves. If the dusting causes the weird noise to go away, determine which piece it was and change it.... Could be a bad belt too....
__________________
My Ride:
2009 335i Xdrive
Loaded

Build thread started.

Nachos23 is offline   Reply With Quote
Old 04-09-2010, 11:17 AM   #3
e46bonestock
Registered User
 
Join Date: Oct 2009
Location: toronto
Posts: 188
My Ride: 325
Quote:
Originally Posted by Nachos23 View Post
I have an 04 300Xi that was experiencing a weird "squeeking" sound almost constantly... We replaced piece-by-piece the parts driven or in contact with main drive belt (not AC belt) and it turned out to be my mechanical tensioner. Sounded fine when the belt was off and spun normally, but attach the belt and the noise came back. We replaced, idler, water pump and alternator forst because it DID NOT sound like a tensioner issue.... squeek gone now. Could just be your belt. Get some talcom powder and lightly dust it over all the components on the drive and AC belts. See if weird noise goes away. Dust each piece separately (water pump, alternator, idler, tensioner, AC compressor and harmonic balancer (main drive for both belts) and then the belts themselves. If the dusting causes the weird noise to go away, determine which piece it was and change it.... Could be a bad belt too....
+1
the belt tensioner is one of the biggest oversights ever when replacing the belts. There's a tech video on youtube. Even if its still smooth, if you spin it, and you hear it, the tensioner pulley is dry and will fail soon. When you change your belts, it's a good idea to change the belt tensioner.
e46bonestock is offline   Reply With Quote
Old 04-09-2010, 12:36 PM   #4
Radi27
Registered User
 
Join Date: Apr 2010
Location: Cleveland, OH
Posts: 2
My Ride: 2004 330xi
Thanks!

I will definitely take these suggestions and see what I can do. I appreciate the help. Thanks!
Radi27 is offline   Reply With Quote
Old 04-09-2010, 01:39 PM   #5
Nachos23
Registered User
 
Join Date: Nov 2009
Location: Brampton, Ontario
Posts: 633
My Ride: 2004 330Xi
Send a message via MSN to Nachos23
actually mine spun perfectly normal. I actually think the sqeek came from the tensioner assembly itself.... likely a little rust or corrosion starting.... we had spun all the bearings the first time we pulled the main belt and the idler needed replacing.... but all others sounded fine. thats why we ended up changing out the other pieces first, because there was NO sound coming from tensioner when spinning. Sound only returned when belt reinstalled.....became a process of elimination. last part to try was tensioner, but I replaced entire tensioner from another engine he had rather than messing around further. That did the trick. Likely why BMW moved to hydralic tensioners.
__________________
My Ride:
2009 335i Xdrive
Loaded

Build thread started.

Nachos23 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 01:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use