E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 03-19-2010, 05:28 PM   #1
s1cke92
Registered User
 
Join Date: Mar 2009
Location: elk grove
Posts: 12
My Ride: e92 335i aw/cr 6mt
Send a message via AIM to s1cke92
my e46 330ci 2001 is throwing CEL and drive weird

hey guys, i just bought a e46 330ci for my little sister and the codes went off and drives weird. the codes are being thrown are:

P0619 Undefined Code
P0011 Camshaft Position - Timing Over Advance or System Performance (Bank 1)
P0444 Evaporative Emission Control System - Purge Control Valve Circuit Open
P0128 Coolant Temperature (Coolant Temperature Below Thermostat Regulating Temperature)

if anyone knows how to resolve these codes please post your thoughts.

TIA
s1cke92 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 03-21-2010, 03:32 PM   #2
s1cke92
Registered User
 
Join Date: Mar 2009
Location: elk grove
Posts: 12
My Ride: e92 335i aw/cr 6mt
Send a message via AIM to s1cke92
Anyone?
s1cke92 is offline   Reply With Quote
Old 03-21-2010, 03:40 PM   #3
phrozen06
Banned User
 
phrozen06's Avatar
 
Join Date: Mar 2004
Location: 3927'33"N 7758'04"W
Posts: 7,535
My Ride: E46, E92 M3, R32 VW
Send a message via Yahoo to phrozen06
Check your DISA Valve.
phrozen06 is offline   Reply With Quote
Old 03-22-2010, 06:58 PM   #4
s1cke92
Registered User
 
Join Date: Mar 2009
Location: elk grove
Posts: 12
My Ride: e92 335i aw/cr 6mt
Send a message via AIM to s1cke92
i checked a youtube video about that and it doesnt make that sound. it has something to do with:

P0011 Camshaft Position - Timing Over Advance or System Performance (Bank 1)

and that prolly triggers P0444 Evaporative Emission Control System - Purge Control Valve Circuit Open
s1cke92 is offline   Reply With Quote
Old 04-09-2010, 09:33 AM   #5
Nachos23
Registered User
 
Join Date: Nov 2009
Location: Brampton, Ontario
Posts: 650
My Ride: 2004 330Xi
Send a message via MSN to Nachos23
Although I personally have not had an issue with the Camshaft position sensor, it apparently does fail. There are lots of threads in regards to this and the related codes/issues it creates when it fails....
__________________
My Ride:
2009 335i Xdrive
- 500+hp.
2000 Z3M

Nachos23 is offline   Reply With Quote
Old 04-09-2010, 03:46 PM   #6
e46crooser
Registered User
 
Join Date: Jul 2009
Location: Brentwood, CA
Posts: 63
My Ride: 99 328 5spd
Replace intake and exhaust cam position sensor and o-rings with OE bmw parts. Do not use junk vaico sensors, they will bite you in the a**. Also replace your thermostat too. Then clear codes. If the water pump hasn't been done, do that too since you'll be right there when doing the thermostat.
e46crooser is offline   Reply With Quote
Old 04-09-2010, 04:20 PM   #7
s1cke92
Registered User
 
Join Date: Mar 2009
Location: elk grove
Posts: 12
My Ride: e92 335i aw/cr 6mt
Send a message via AIM to s1cke92
well someone should of post this before. i sold the car n took a lost of 1800 already.
s1cke92 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 02:18 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use