E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > BMW Regional Forums > Regional Forums > UK

UK
Have you seen another BMW while driving around in your area? Find other members from your area in the E46Fanatics Garage HERE

If you don't have your garage setup, sign up today HERE

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 04-15-2010, 12:53 PM   #1
philaellis
Registered User
 
Join Date: Mar 2009
Location: coventry, uk
Posts: 5
My Ride: e46 318 ci
rough running and stuttering.

hi everyone,
I have an e46 318 {03} that has thrown up a few codes and as a result it has been fitted with new o2 sensors and a new MAF sensor, the problem has improved but is still there, the only code im now suffering is P1168 FRP Sensor In Range But Low. I can erase the code but it does little to improve the issue as im not actually curing the problem! My question is, has anyone else had the same issues? and would a new fuel filter put me outta my misery!? thanks Phil.

ok, update..fitted the new filter, worked great, til the next morning, the same problem keeps coming up so i took it to a nearby independant specialist, he diagnosed a blocked/failed cat and fitted another { 325} great, til the next morning!!
running out of ideas and would appreciate any advice before i go the the stealership for some dynamic tests at god only knows what price. all I can think thats left to play with are two cam sensors, 1 crank sensor, fuel pump relay or fuel pump.. and this all started 1 day after i replaced the oil, the filters and plugs!! arghhhhhh.
Thanks for reading my rant and feel free to make constructive suggestions.

ok, this morning i decided to have another play with the car from hell... having spent a fortnight putting off going to the main dealer I decided to remove and clean up both crakshaft sensors, just because they were there and I had'nt! having done it I took her out for a spin and same old same old..rough and sluggish. enough, time for an Italian tune up! I put the pedal down and it struggled..wheezed and objected so much that I almost relented..no I kept on pressing and hey presto!! it gave a great big shudder, cough and sneezed then all was calm..normal running was restored! ive put 200 miles on over the last 24hrs and mostly with a smile on my face:]

So my conclusion is that the cat was blocked as my independant suggested all the crap had backed up inside and made the bank 1 sensor 1 and 2 lamdas sooty and this started tricking the car into over and under fueling, in short everything was doing its job but it all took time to clear through and give accurate readings after the replacement cat was fitted. obviously my actions were based on pure frustration and i wouldnt recommend them to anyone, the point is everything is logical and needs thinking through, i coulda thrown more money at the car but it would have been wasted, think it all through and cross reference everything in these and other forums... the answers are out there!

Last edited by philaellis; 04-29-2010 at 08:28 AM. Reason: update
philaellis is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Reply

Tags
idle, maf, sensors

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is ON





All times are GMT -5. The time now is 11:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use