E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 03-24-2010, 08:08 AM   #21
StephWithStars
Registered User
 
Join Date: Jul 2009
Location: San Diego
Posts: 313
My Ride: A magical unicorn.
Send a message via AIM to StephWithStars Send a message via Yahoo to StephWithStars
I had that exact same problem on my 04 330i and I took it in yesterday to the dealership and had a DME update. It completely fixed the lag problem at the 2-3k mark. Cost me $150, car runs like a dream now.
__________________
StephWithStars is offline   Reply With Quote
Old 03-24-2010, 08:33 PM   #22
frankymofe
Registered User
 
Join Date: Sep 2009
Location: Texas
Posts: 44
My Ride: 2000 323i
ive been to the dealership a few times and theyve told me that i do not need an update...so im guessing that it already has been before i bought it
frankymofe is offline   Reply With Quote
Old 03-29-2010, 04:39 PM   #23
snakepirates
Registered User
 
Join Date: Jan 2009
Location: toronto
Posts: 13
My Ride: 330ci
Having the exact same thing. I'd be curious to know what fixes your problem.





Quote:
Originally Posted by frankymofe View Post
im curious if anyone here would have some advice or suggestions for me.
i have a 2000 323i.
when im driving the car hard, full throttle, ill notice that my power seems to "pulsate" at times..almost like its not very constant. its not extremely noticable but can be noticed enough. its not a fast pulsing of power, just slightly at around 2500-3000rpms and again around 4000...it seems like the power dips just a little then comes back. kind of odd.

has anyone else experienced this? i have no codes or anything. but after a while it has bothered me. im completely stumped.
any suggestions would be helpful. thank you.
snakepirates is offline   Reply With Quote
Old 05-02-2010, 09:36 PM   #24
MoE46
Registered User
 
Join Date: Aug 2007
Location: Dallas, Texas
Posts: 251
My Ride: 2002 325Ci
OP do you have an update? I'm also having similar issues
MoE46 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 05:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use