E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 57 votes, 4.21 average. Display Modes
Old 05-02-2010, 12:48 AM   #141
maxi
Registered User
 
Join Date: Apr 2006
Location: Qatif -Awamiah
Posts: 367
My Ride: BMW E46 328I, 1999
Quote:
Originally Posted by Pipebomb View Post
Update: I will be pulling out my valve body this weekend starting tonight. I plan on cleaning it thoroughly and taking a lot of pictures. Wish me luck
Good luck friend, I'm waiting.
__________________
http://forum.e46fanatics.com/signaturepics/sigpic64570_1.gif
maxi is offline   Reply With Quote
Old 05-04-2010, 12:04 PM   #142
Toad21
Registered User
 
Join Date: Feb 2009
Location: Normal IL
Posts: 893
My Ride: 00' 328CI
Quote:
Originally Posted by Pipebomb View Post
Update: I will be pulling out my valve body this weekend starting tonight. I plan on cleaning it thoroughly and taking a lot of pictures. Wish me luck
Good luck buddy, I would really love all the pictures you can take.



Update for me: 3 weeks (700 miles ish) and Reverse is still working.
__________________
Toad21 is offline   Reply With Quote
Old 05-05-2010, 05:44 AM   #143
maxi
Registered User
 
Join Date: Apr 2006
Location: Qatif -Awamiah
Posts: 367
My Ride: BMW E46 328I, 1999
good news
__________________
http://forum.e46fanatics.com/signaturepics/sigpic64570_1.gif
maxi is offline   Reply With Quote
Old 05-05-2010, 08:32 PM   #144
K33m03
Registered User
 
Join Date: May 2010
Location: Princeton nj
Posts: 1
My Ride: 323 ci
Thank you!

Thanks to this great post I was able to replace the solenoid and clean the valve spring myself. The parts cost $150.00 it took about three hours to complete. I just wanted to thank you for posting this, you have been a great help!! Reverse now works great every time!! Thanks again!

2000 323ci 105,000 miles
K33m03 is offline   Reply With Quote
Old 05-08-2010, 02:22 AM   #145
maxi
Registered User
 
Join Date: Apr 2006
Location: Qatif -Awamiah
Posts: 367
My Ride: BMW E46 328I, 1999
Quote:
Originally Posted by K33m03 View Post
Thanks to this great post I was able to replace the solenoid and clean the valve spring myself. The parts cost $150.00 it took about three hours to complete. I just wanted to thank you for posting this, you have been a great help!! Reverse now works great every time!! Thanks again!

2000 323ci 105,000 miles
Oh.. it good to know that there some nice result of that.
__________________
http://forum.e46fanatics.com/signaturepics/sigpic64570_1.gif
maxi is offline   Reply With Quote
Old 05-08-2010, 12:23 PM   #146
Toad21
Registered User
 
Join Date: Feb 2009
Location: Normal IL
Posts: 893
My Ride: 00' 328CI
3 weeks, 5 days since fix. Reverse did not work today.

So reverse has failed twice in under 4 weeks since repair.

Once I embarrassingly pushed my car out of the spot, I drove it to some back street and floored it from a stop up to about 50mph twice. Then reverse started working again.


Either I take apart the Valve body, or I buy a new, or I ship it off to be repaired.


Does anyone know where I can ship the valve body to be repaired?

I contacted Mike over at the bimmerboard, he had his valve body rebuilt. I will let you know what he says when he gets back to me.
__________________

Last edited by Toad21; 05-08-2010 at 12:43 PM.
Toad21 is offline   Reply With Quote
Old 05-11-2010, 10:47 PM   #147
rd995
Registered User
 
Join Date: Dec 2009
Location: orlando
Posts: 14
My Ride: 2000 bmw 323ci
i just finished doing this it took me about 3 hours when i was pulling out the old solenoid it broke and i didnt force it. also the green clip that holds the wire together with the solenoid that broke i guess the plastic was toasted
my car a 2000 323ci has 178000 miles had once flush the oil when it was around 80000 miles. this time oil looked like chocolate i was looking at the oil like hum i remember putting a red color oil. my car never had the pan removed so you can imagine all that sludge in the magnet.
i want to thank neil1138 for bringing up this post and Toad21 for putting that detail picture about removing the solenoid i was going crazy when i found out i couldn't put the new one in since the old one broke when i pulled the pin
rd995 is offline   Reply With Quote
Old 05-15-2010, 11:21 PM   #148
rd995
Registered User
 
Join Date: Dec 2009
Location: orlando
Posts: 14
My Ride: 2000 bmw 323ci
My reverse not working again so i might be in the same boat and need to clean the valves or do a complete rebuilt not good
rd995 is offline   Reply With Quote
Old 05-16-2010, 11:11 PM   #149
Wrench266
Registered User
 
Join Date: May 2010
Location: Lakewood, NJ
Posts: 2
My Ride: 1999 323i
Thanks for the GM tranny no-reverse info. You just saved me a lot of money!
Wrench266 is offline   Reply With Quote
Old 05-19-2010, 12:49 PM   #150
rd995
Registered User
 
Join Date: Dec 2009
Location: orlando
Posts: 14
My Ride: 2000 bmw 323ci
Anyone with pics of how to clean the valves?
rd995 is offline   Reply With Quote
Old 05-20-2010, 02:57 PM   #151
joebob23
Registered User
 
Join Date: Jul 2008
Location: texas
Posts: 1
My Ride: 328i
Omg, I LOVE YOU ..YOUR A !@#@!!$@ GEinus....Been trying to figure this out for so long, Took it too like a Gazzilion mech...and they put it on their machine and everything the damn thing would reverse just fine and When I'm comming home from work late at night is when it won't reverse..
joebob23 is offline   Reply With Quote
Old 05-31-2010, 07:11 PM   #152
hanna
Registered User
 
Join Date: May 2010
Location: USA
Posts: 303
My Ride: BMW 328i
Got my car back from the shop last week with new transmission fluid and reverse solenoid. My reverse still works on and off. $526 down the drain
hanna is offline   Reply With Quote
Old 05-31-2010, 07:22 PM   #153
neil1138
Registered User
 
Join Date: Jan 2008
Posts: 4,240
You need to get your valve body rebuilt/replaced. There are other solutions but they require special tools and aren't DIY-able (and they cost more than just getting your VB rebuilt). Cheapest solution at this point is to look into getting an entirely new valve body.

http://www.sonnax.com/tech-articles/TASC-TIP-02-09.pdf

Look into this thread, it summarizes the sonnax article and gives you different options on what you can do if the solenoid fix fails. Well written thread

http://www.bimmerfest.com/forums/sho...d.php?t=458451

Unfortunately the solenoid route was found out to be one of many different problems. Sometimes it's the solution and sometimes it's not.
neil1138 is offline   Reply With Quote
Old 06-01-2010, 04:00 PM   #154
BMWGirl4Life
Registered User
 
Join Date: May 2010
Location: Connecticut
Posts: 1
My Ride: 325XI
No Reverse, Car drives in Neutral

Hi,

I'm an owner of a 2004 BMW 325xi with just over 72,000 miles. I was reversing out of my driveway on Saturday morning (just 3 days ago) and when I shifted my car into D, it would not go forward. I kept trying to get the car to drive, but it would not drive forward - so naively I stepped on the gas, revved it forward, and it drove forward. That was the 1st drive of the day.

Fast forward to Saturday evening when I had driven home (never had to reverse) parked, and then wanted to leave my drive way. My car would not reverse! I was baffled. I disconnected the battery. Move the car into various gears...nothing. I did notice that the car drove forward in neutral, though.

Then I came online and found this board. I tried one of Niel's (OP) suggestion and got some help to push the car out of the driveway. After pushing it out of the driveway, I drove around town for a few minutes, and then tried to get the car to reverse; reverse would not engage.

On Monday (yesterday), a friend of a friend suggested I visit a foreign car repair shop. I visited the shop today and they ran a diagnostic test to see if anything electrical could be causing the issue. According to the mechanic, there are no apparent electrical failures. He's suggesting that I replace the transmission.

I don't even know how much that will cost, and to be honest - After losing a well paying job last year, and starting up my own gig doing web design - I am not exactly prepared to pay costly transmission costs.

I guess I'm just venting here, because there isn't much else I can do at this point. All I can say is that this really really hurts.
BMWGirl4Life is offline   Reply With Quote
Old 06-01-2010, 04:54 PM   #155
Toad21
Registered User
 
Join Date: Feb 2009
Location: Normal IL
Posts: 893
My Ride: 00' 328CI
500$ for a rebuilt Valve body sounds the right solution to me. I am still working at a 1 in 50 times it reverse doesn't work, I think I can live with that for now.

Thanks for the info Neil.
__________________
Toad21 is offline   Reply With Quote
Old 06-01-2010, 05:02 PM   #156
neil1138
Registered User
 
Join Date: Jan 2008
Posts: 4,240
No problem, thank Starless. I was too lazy to summarize the sonnax article and he took the time to do that. Props to him
neil1138 is offline   Reply With Quote
Old 06-01-2010, 09:41 PM   #157
ntempy101
Registered User
 
Join Date: May 2010
Location: New Hampshire
Posts: 6
My Ride: Audi S4
Quote:
Originally Posted by ///OSS View Post
Amazing, thanks for the post and a priceless read
That car is dope [img]https://www.fitnessphreaks.info/workout/upload/51*************[/img]
ntempy101 is offline   Reply With Quote
Old 06-08-2010, 06:10 PM   #158
aluseni
Registered User
 
Join Date: Jun 2010
Location: Chicago
Posts: 8
My Ride: 1999 BMW 328i Sedan
my 1999 bmw 328i sedan (e46) wont reverse at all... i see most posts say its off and on but i dont got it at all... could there be another reason other then what ive been reading? if i get a remanufactured valve body should the issue of no reverse be taken care of or would there be a chance of the issue continuing?
input is appreciated.. thanks

Last edited by aluseni; 06-08-2010 at 06:30 PM.
aluseni is offline   Reply With Quote
Old 06-08-2010, 08:00 PM   #159
Starless
Registered User
 
Join Date: Jul 2009
Location: St. Louis, MO
Posts: 275
My Ride: 02' 325i
Quote:
Originally Posted by aluseni View Post
my 1999 bmw 328i sedan (e46) wont reverse at all... i see most posts say its off and on but i dont got it at all... could there be another reason other then what ive been reading? if i get a remanufactured valve body should the issue of no reverse be taken care of or would there be a chance of the issue continuing?
input is appreciated.. thanks
When I talked on the phone to a VBX transmission tech he said the problem was 90% of the time in the valve body with GM. It could also be a cross leak at the pump. Also at least 1 person commented that in his case it was a problem with a reverse drum (yes, GM [according to him] transmission). That's all I can tell you...
Starless is offline   Reply With Quote
Old 06-08-2010, 08:05 PM   #160
aluseni
Registered User
 
Join Date: Jun 2010
Location: Chicago
Posts: 8
My Ride: 1999 BMW 328i Sedan
by any chance would the issue of "no reverse" be caused by the wrong trans fluid put in?
aluseni is offline   Reply With Quote
Reply

Tags
neilgotastickiedthread!, no reverse, reverse, tranny, transmission

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 08:24 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use