E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > DIY: Do It Yourself

DIY: Do It Yourself
Post here to share or improve your wrench turning skills! All BMW E46 DIY tips, tales, and projects discussed inside. Learn to work on your car and know the right BMW parts you will need!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 18 votes, 5.00 average. Display Modes
Old 01-18-2010, 02:03 PM   #41
kyle808
Registered User
 
Join Date: Jun 2003
Location: Houston,TX
Posts: 936
My Ride: 00 328CI
Quote:
Originally Posted by n2Bimmer View Post
Great DIY, thank you. I really need to do this soon, I have a few questions, What exactly do we have to replace for the Vanos bolt?? Do i really have to remove the fan (auto)?, Can i rent the tool at pepboys?. Thank you. Also i assume we need to drain the oil first, no one mentioned it.
You will need a 17mm or maybe 19mm wrench for the Vanos bolt. I don't remember exactly.

I don't see how you can do it without taking off the fan. You really need the space.

No need to drain the oil.

not sure about rental at pep boys.
__________________

"I'm gonna die! Jesus, Allah, Buddha - I love you all!
-Homer Simpson
kyle808 is offline   Reply With Quote
Old 01-18-2010, 03:27 PM   #42
n2Bimmer
Registered User
 
Join Date: May 2007
Location: calii
Posts: 9,670
My Ride: Loves Corners
Thank you, Also i will need a new Vanos crush washer?.
__________________
n2Bimmer is offline   Reply With Quote
Old 01-18-2010, 03:46 PM   #43
genuity
Registered User
 
Join Date: Sep 2009
Location: *
Posts: 1,404
My Ride: '1 E46
Quote:
Originally Posted by n2Bimmer View Post
Thank you, Also i will need a new Vanos crush washer?.
I would replace it. I did...I went even as far as replacing that vanos hex bolt.
genuity is offline   Reply With Quote
Old 01-18-2010, 04:12 PM   #44
n2Bimmer
Registered User
 
Join Date: May 2007
Location: calii
Posts: 9,670
My Ride: Loves Corners
Thank you guys
__________________
n2Bimmer is offline   Reply With Quote
Old 01-19-2010, 07:59 AM   #45
bmwFreakazoid
Registered User
 
Join Date: Mar 2009
Location: Washington, DC
Posts: 40
My Ride: 03 325 I
I recently got my filter housing gasket changed for $396 got it down from $980. I will have to check to see if the engine was cleaned thouroughly I like the pristine factory look in the pics above.
bmwFreakazoid is offline   Reply With Quote
Old 01-19-2010, 11:18 AM   #46
NoVaDreier
Registered User
 
Join Date: Nov 2002
Location: Alexandria, Va.
Posts: 521
My Ride: 2001 325i
Who did the job in D.C. for $396?
NoVaDreier is offline   Reply With Quote
Old 01-19-2010, 05:22 PM   #47
n2Bimmer
Registered User
 
Join Date: May 2007
Location: calii
Posts: 9,670
My Ride: Loves Corners
Got my oil, fitler, washers and gaskets from the dealers today. I need only two crusher washers right?
__________________
n2Bimmer is offline   Reply With Quote
Old 01-23-2010, 08:02 AM   #48
E-rock
Registered User
 
Join Date: Aug 2009
Location: Philly
Posts: 310
My Ride: '01 330xi
Anybody have a PN for the washers? [edit] Should be 32411093596, right?

Last edited by E-rock; 01-23-2010 at 09:04 AM.
E-rock is offline   Reply With Quote
Old 01-24-2010, 06:33 AM   #49
NoVaDreier
Registered User
 
Join Date: Nov 2002
Location: Alexandria, Va.
Posts: 521
My Ride: 2001 325i
Corrrect. That's the right part number and the washer is also required for one of the banjo bolts (#6) in the power steering lubrication system.
NoVaDreier is offline   Reply With Quote
Old 04-12-2010, 09:44 AM   #50
rayv99
Registered User
 
Join Date: Apr 2010
Location: Granite Bay CA
Posts: 5
My Ride: 2002 330i
VERY Rough cold idle

Over the weekend I replaced the oil filter housing gasket, vanos tube,both belts, fan clutch, spark plugs and valve cover gasket - whew! Fired right up - no leaks, however after starting the car started to idle very badly - RPM's up and down - almost stalling. Under road conditions the car runs fine, at a stop sign the engine idle is rough. After the car warms up the idle smooths. I pulled the plugs - no signs of fouling, with the engine running (and warmed up - and ) I dissconnected each of the "coil connectors" to the plugs one at a time to see if one of them wasn't firing. Effect was same on each plug - I minor decrease in idle speed - my conlclusion - ignitition system is okay. I suspect I dissconnected "something" related to cold start and forgot to reconnect it - ANY IDEAS OUT THERE?
rayv99 is offline   Reply With Quote
Old 04-12-2010, 09:53 AM   #51
Focal E46
Registered User
 
Join Date: Aug 2008
Location: Norfolk, Va
Posts: 1,871
My Ride: is a DIYer
^ I just did mine this weekend too!

Sounds like your VANOS is shitting. Check/test here:

http://forum.e46fanatics.com/showthr...ght=vanos+idle
__________________
Focal E46 is offline   Reply With Quote
Old 04-12-2010, 06:34 PM   #52
rayv99
Registered User
 
Join Date: Apr 2010
Location: Granite Bay CA
Posts: 5
My Ride: 2002 330i
doh

I just don't want to believe it - but I think you're right - I'll do the test tomorrow but I oredered the repair kit (beisan systems) today. I was trying to understand WHY it started happening after all the repairs I made. The only thing I can think of is that there is some relationship to the fact that I changed the Vanos line (it was leaking)?

Another opinion needed - since I JUST changed the valve cover gasket over the weekend - I'm assuming that I don't need to REPLACE it when I do the Vanos repair since the rubber is nice and soft right now. Thoughts?
rayv99 is offline   Reply With Quote
Old 04-13-2010, 06:42 AM   #53
Focal E46
Registered User
 
Join Date: Aug 2008
Location: Norfolk, Va
Posts: 1,871
My Ride: is a DIYer
Nah, you can reuse the valve cover gasket. I did mine last year and didn't do the nut seals and now one of them are leaking so I'll be back in mine this weekend, lol.
__________________
Focal E46 is offline   Reply With Quote
Old 04-13-2010, 02:23 PM   #54
rayv99
Registered User
 
Join Date: Apr 2010
Location: Granite Bay CA
Posts: 5
My Ride: 2002 330i
Okay - Thanks, I'll tackle the vanos this weekend!
rayv99 is offline   Reply With Quote
Old 08-22-2010, 07:02 PM   #55
X-vert
Registered User
 
Join Date: Mar 2005
Location: Clayton, CA
Posts: 99
My Ride: 01 330i & 04 Tahoe
Service Engine Soon Light????

Excellent DIY! Everything went really well. The hardest thing to do was to make lunch during the job!

No leaks and runs smooth but the Service Engine Light popped on. Any ideas before I take her to a dealer??
X-vert is offline   Reply With Quote
Old 08-28-2010, 09:10 PM   #56
phamine
Registered User
 
Join Date: Apr 2008
Location: Brooklyn, NY
Posts: 1,226
My Ride: 01 Orient Blue 330i
Send a message via AIM to phamine Send a message via Yahoo to phamine
How much oil came out after you removed the oil filter housing?
__________________
phamine is offline   Reply With Quote
Old 08-29-2010, 11:12 PM   #57
spencers
Registered User
 
Join Date: Jul 2005
Location: Location, Location
Posts: 1,363
My Ride: 2006 330i sport
Quote:
Originally Posted by phamine View Post
How much oil came out after you removed the oil filter housing?
I'd like to know too.
__________________
spencers is offline   Reply With Quote
Old 08-30-2010, 11:41 PM   #58
island330i
Registered User
 
Join Date: Aug 2010
Location: Hawaii
Posts: 19
My Ride: 2002 330i, 1990 M3
Quote:
Originally Posted by phamine View Post
How much oil came out after you removed the oil filter housing?
Just finished mine last week and only a little oil came out, nothing to worry about.
island330i is offline   Reply With Quote
Old 08-31-2010, 02:14 AM   #59
X-vert
Registered User
 
Join Date: Mar 2005
Location: Clayton, CA
Posts: 99
My Ride: 01 330i & 04 Tahoe
Not much after a while. I "reset" the service engine light (key in on position and gas pedal).
Cleaned and degreased.
I still have a tiny leak.
Changed all the applicable gaskets and near by hoses. What else could it be? It's not ATF/Power steering for sure.
X-vert is offline   Reply With Quote
Old 08-31-2010, 04:05 PM   #60
kib
Registered User
 
Join Date: Feb 2010
Location: surrey
Posts: 64
My Ride: bmw 04 e46 330 vert
a bit off subject but have any of you changed the small filter in the vanos and were is it .
thanks keith
kib is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 08:55 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use