E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > E46 Xi Forum

E46 Xi Forum
The E46 XI was produced from 01-05 in sedan and touring body styles. Powered by either a 2.5L inline 6 in the 325xi or a 3.0L inline 6 330xi. Discuss all thing about BMW AWD E46 'Xi' here.

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 3 votes, 4.67 average. Display Modes
Old 09-13-2010, 07:14 PM   #61
Kubica
Registered User
 
Join Date: Apr 2008
Location: Boston
Posts: 4,487
My Ride: 2003 325xi
Quote:
Originally Posted by xixixi View Post
150k.. but i've replaced damn near everything. The list of what i haven't replaced would be smaller.. ecu.. um...
rack?
Kubica is offline   Reply With Quote
Old 09-13-2010, 07:19 PM   #62
LittleChrist12
Registered User
 
Join Date: Jan 2010
Location: Albany, NY
Posts: 533
My Ride: 2003 BMW 325xi
Broken rear spring, 2 window regulators, axle boots, valve cover gasket and return have all broken on me.

Items that have worn out and been replaced: FCABs, RTABs, belts, shocks/struts. Mostly uneventful.
__________________
2003 BMW 325xi
2010 BMW M3 Sedan
LittleChrist12 is offline   Reply With Quote
Old 09-13-2010, 07:36 PM   #63
qmainracing
Registered User
 
Join Date: Apr 2010
Location: Central PA
Posts: 28
My Ride: E46 xit
Quote:
Originally Posted by bombguy View Post
I'm not busting your balls, but seriously, where are you guys getting this info? Lowering will do nothing to your control arms. CV joints, maybe, control arms....no.
Lowering the car doesn't do it as long as the lowering is within the motion range of the ball joint. Higher rate springs and dampers kill ball joints.

I have an Xi at 197k...it needs axles, slight vibration at highway speeds but due to the cost of axles, I'll deal with a little vibration....Just rebuilt inner and outer of the front axles. Completely cleaned them out and regreased them, has helped a little with the vibration.

Anyone have any experiences with aftermarket front axles?? I have gone this route on other fwd cars, but not with BMWs.
qmainracing is offline   Reply With Quote
Old 09-13-2010, 07:40 PM   #64
mp333
Registered User
 
Join Date: Nov 2009
Location: EastCoast
Posts: 315
My Ride: 2003 325XI
Yes anybody replace with aftermarket front axles. OE are way too expensive.
mp333 is offline   Reply With Quote
Old 09-13-2010, 10:18 PM   #65
Kubica
Registered User
 
Join Date: Apr 2008
Location: Boston
Posts: 4,487
My Ride: 2003 325xi
Quote:
Originally Posted by qmainracing View Post
Lowering the car doesn't do it as long as the lowering is within the motion range of the ball joint. Higher rate springs and dampers kill ball joints.

I have an Xi at 197k...it needs axles, slight vibration at highway speeds but due to the cost of axles, I'll deal with a little vibration....Just rebuilt inner and outer of the front axles. Completely cleaned them out and regreased them, has helped a little with the vibration.

Anyone have any experiences with aftermarket front axles?? I have gone this route on other fwd cars, but not with BMWs.
Quote:
Originally Posted by mp333 View Post
Yes anybody replace with aftermarket front axles. OE are way too expensive.

Do not use aftermarket axles. They are chinese junk. Buy A1 Cardone rebuilt axles.

I killed the right front chinese axle in two weeks, and the left front three months later. The A1 cardone axles are doing great with a year of very tough driving under them.
Kubica is offline   Reply With Quote
Old 09-14-2010, 03:21 PM   #66
Cool33
Registered User
 
Join Date: Aug 2009
Location: Montreal
Posts: 45
My Ride: Modded E46 330xi
Quote:
Originally Posted by Kubica View Post
Do not use aftermarket axles. They are chinese junk. Buy A1 Cardone rebuilt axles.

I killed the right front chinese axle in two weeks, and the left front three months later. The A1 cardone axles are doing great with a year of very tough driving under them.
Ditto on this. Got a pair of aftermarket CV axles on eBay and had problems almost the moment I left the garage. After a few days, I had to change them back to OEM, which have been great since then. For that kind of parts, don't waste your time with cheap "jobber" parts - go for OEM.

Last edited by Cool33; 09-14-2010 at 03:24 PM.
Cool33 is offline   Reply With Quote
Old 09-14-2010, 04:05 PM   #67
xixixi
Banned User
 
Join Date: Aug 2009
Location: St Louis, MO
Posts: 3,008
My Ride: 01 330x-xi
Quote:
Originally Posted by Kubica View Post
rack?
had to replace the rack when i did the swap. Anyone need a rack? lol
xixixi is offline   Reply With Quote
Old 09-14-2010, 04:07 PM   #68
xixixi
Banned User
 
Join Date: Aug 2009
Location: St Louis, MO
Posts: 3,008
My Ride: 01 330x-xi
Quote:
Originally Posted by qmainracing View Post
Lowering the car doesn't do it as long as the lowering is within the motion range of the ball joint. Higher rate springs and dampers kill ball joints.

I have an Xi at 197k...it needs axles, slight vibration at highway speeds but due to the cost of axles, I'll deal with a little vibration....Just rebuilt inner and outer of the front axles. Completely cleaned them out and regreased them, has helped a little with the vibration.

Anyone have any experiences with aftermarket front axles?? I have gone this route on other fwd cars, but not with BMWs.
I have oem axles with 15k miles on em. toss an offer
xixixi is offline   Reply With Quote
Old 09-14-2010, 04:44 PM   #69
MileHiXi
Banned
 
Join Date: Mar 2009
Location: Colorado
Posts: 884
My Ride: '02 330xi
Anyone swapped out the steering guibo? I'm planning on doing this soon. It looks like I'll either need to remove the driver's side CA or else go in from the top. Or maybe both. I don't want to have to lower the subframe, but it looks like that could be a requirement too.
MileHiXi is offline   Reply With Quote
Old 09-14-2010, 04:44 PM   #70
330exeye
Registered User
 
Join Date: Jun 2010
Location: Philla PA
Posts: 473
My Ride: 2004 330xi
Bought the car with 70k, now has 77, since I've had it, replaced DESA/adjuster, and battery.
Prior to purchase:
Drive Belts
Lower radiator hoses and temp sensor
right side outter cv boot
and collapsed engine mount.
and that was only the work done at the dealership near me under factory warranty. I later found out all the work on the car was done all extended work was done at the dealer up the rd. still haven't gotten the list from them yet.
Car needs
tension/idler replaced
axles are clicking
valve cover gasket
I'm regreting the extended warranty as nothing so far has been covered. Need new rear pads as well.
__________________

Quote:
Originally Posted by DJ Reminisce View Post
It is indeed called E46fanatics, not E46wellthiscarisokthewayitissowhymodit
330exeye is offline   Reply With Quote
Old 09-14-2010, 07:26 PM   #71
mp333
Registered User
 
Join Date: Nov 2009
Location: EastCoast
Posts: 315
My Ride: 2003 325XI
From the top. easy access. It may be a good time to do a DIY, since there isnt one on XI.
Quote:
Originally Posted by MileHiXi View Post
Anyone swapped out the steering guibo? I'm planning on doing this soon. It looks like I'll either need to remove the driver's side CA or else go in from the top. Or maybe both. I don't want to have to lower the subframe, but it looks like that could be a requirement too.
mp333 is offline   Reply With Quote
Old 09-15-2010, 04:05 PM   #72
Kubica
Registered User
 
Join Date: Apr 2008
Location: Boston
Posts: 4,487
My Ride: 2003 325xi
Quote:
Originally Posted by xixixi View Post
had to replace the rack when i did the swap. Anyone need a rack? lol
I'm thinking about putting in a new rack- but I don't want your abused rack, haha. I want a rack from a 2005 325xi automatic female driven car that was totalled in a rear-end accident with 15k miles.



Quote:
Originally Posted by mp333 View Post
From the top. easy access. It may be a good time to do a DIY, since there isnt one on XI.
Definitely doable if the front is on ramps and the airbox is removed. Like someone said above, it may be doable from the top only. Takes two seconds to drive up on ramps or put it up on jackstands.
Kubica is offline   Reply With Quote
Old 09-15-2010, 04:20 PM   #73
MileHiXi
Banned
 
Join Date: Mar 2009
Location: Colorado
Posts: 884
My Ride: '02 330xi
Quote:
Originally Posted by mp333 View Post
From the top. easy access. It may be a good time to do a DIY, since there isnt one on XI.
Quote:
Originally Posted by Kubica View Post
I'm thinking about putting in a new rack- but I don't want your abused rack, haha. I want a rack from a 2005 325xi automatic female driven car that was totalled in a rear-end accident with 15k miles.





Definitely doable if the front is on ramps and the airbox is removed. Like someone said above, it may be doable from the top only. Takes two seconds to drive up on ramps or put it up on jackstands.

Sweet! I'll make a DIY when I do this.
MileHiXi is offline   Reply With Quote
Old 09-15-2010, 04:21 PM   #74
Kubica
Registered User
 
Join Date: Apr 2008
Location: Boston
Posts: 4,487
My Ride: 2003 325xi
Oh- I have a new one:

I'm on my third front-center jack pad. It has failed on me twice now, and the second time could have done some damage if I hadn't put a jackstand under the left front pad about 10 seconds earlier.

As you know, it's sticks into the front subframe. Make sure to jack in a perfectly vertical motion and definitely make sure the jack is centered on the pad. I think mine got twisted slightly a few times from not being perfectly lifted- it's just plastic that sticks into the subframe, not metal.

I will eventually just weld something on the subframe as a permenant jack point.
Kubica is offline   Reply With Quote
Old 09-15-2010, 04:22 PM   #75
Kubica
Registered User
 
Join Date: Apr 2008
Location: Boston
Posts: 4,487
My Ride: 2003 325xi
Quote:
Originally Posted by MileHiXi View Post
Sweet! I'll make a DIY when I do this.
What are your symptoms, MileHIXi?
Kubica is offline   Reply With Quote
Old 09-15-2010, 04:52 PM   #76
MileHiXi
Banned
 
Join Date: Mar 2009
Location: Colorado
Posts: 884
My Ride: '02 330xi
Quote:
Originally Posted by Kubica View Post
What are your symptoms, MileHIXi?
I've got severe tramlining, vibrations and slightly loose steering. CA's and bushings are also on my list (the parts have been sitting in my garage for months). I'm also going to drain/fill both diffs.

The tramlining could just be my low profile tires and 18s but I'm hoping it gets a lil better.

Once I install the guibo and CA's I will have replaced pretty much the entire front end except for the swaybar endlinks and steering rack.

Last edited by MileHiXi; 09-15-2010 at 04:55 PM.
MileHiXi is offline   Reply With Quote
Old 09-15-2010, 05:34 PM   #77
xixixi
Banned User
 
Join Date: Aug 2009
Location: St Louis, MO
Posts: 3,008
My Ride: 01 330x-xi
[QUOTE=Kubica;12243593]I'm thinking about putting in a new rack- but I don't want your abused rack, haha. I want a rack from a 2005 325xi automatic female driven car that was totalled in a rear-end accident with 15k miles.

my rack is in good shape!!! and I'll let it go for 115 shipped! with the tie rod ends!
xixixi is offline   Reply With Quote
Old 09-15-2010, 05:42 PM   #78
Kubica
Registered User
 
Join Date: Apr 2008
Location: Boston
Posts: 4,487
My Ride: 2003 325xi
Quote:
Originally Posted by MileHiXi View Post
I've got severe tramlining, vibrations and slightly loose steering. CA's and bushings are also on my list (the parts have been sitting in my garage for months). I'm also going to drain/fill both diffs.

The tramlining could just be my low profile tires and 18s but I'm hoping it gets a lil better.

Once I install the guibo and CA's I will have replaced pretty much the entire front end except for the swaybar endlinks and steering rack.
Yeah I have a slightly loose steering feeling since the last autox. I had a BIG understeer to snap oversteer slide which I think caused it.

I got another alignment last night and three of four wheels were out on toe. I just had it aligned three months ago so i was a bit surprised. Left rear was toed out, and both fronts were pointing to the right a bit.

I have a tiny click from the guibo, but I'm afraid the majority of the play is coming from the rack.
Kubica is offline   Reply With Quote
Old 09-15-2010, 05:50 PM   #79
xi325xi02
Registered User
 
Join Date: Jan 2010
Location: Oregon
Posts: 533
My Ride: 325xi
125xxx on mine, still running strong. Cooling system overhaul and all scheduled maintenance.
Treat it right and it will continue to run with no flaws.
__________________



Quote:
Originally Posted by onebad328i View Post
you want ladys damm, get a punchin hard ass sound system
I HATE CVT'S
xi325xi02 is offline   Reply With Quote
Old 09-16-2010, 01:29 PM   #80
Revisa69
Registered User
 
Join Date: Apr 2010
Location: Toronto, ON
Posts: 116
My Ride: 2002 325xi TITANSILB
What to fix

So far the mileage is at 227000kms! no rust, but the right rear axle pooched, ignition coils, window regulators, heated mirrors have stained.
Revisa69 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 06:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use