E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

 
 
Thread Tools Search this Thread Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 09-17-2010, 06:08 PM   #1
LiNk504
Registered User
 
Join Date: Jun 2009
Location: OlyPen in the PAC NW
Posts: 174
My Ride: 2000 323i
Question i think my transmission may have just blown

so i was driving home from work and i stopped at a red and when it turned green i started driving again (i didn't gun it, i drove it nice and normal) there was a clunk and a grinding noise. it originally sounded like a wheel on the pavement and thats what i thought it was (my tires are really bad right now) until i pulled over and all four were still intact so i looked under my car and there was a fluid leaking. i was really close to my house and since there was no one to come tow me and my insurance company is a bunch of dicks i drove it home and the weird part was that it shifted fine just sounded really bad intermediately . when i got home i immediately jacked it up to find out what the liquid was and it was coolant. i don't have any lights on on the dash except and airbag one and the coolant one (coolant sensor is broken when i had to change the expansion tank so i monitor it every few days and i filled it up last night so i know it was full). anyone know what the hell happened to my car?
__________________
Stupid f**king plastic parts!
LiNk504 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
 

Tags
323i transmission, problem, transmission blown

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 09:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use