E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 11-04-2010, 09:02 AM   #1
nughaud
Registered User
 
Join Date: Sep 2003
Location: NW FL
Posts: 138
My Ride: '01 330CI / '11 335i
Suggestions on car not starting, after sitting overnight

2001 330CI
Car drove fine yesterday, had about 1.5 gallons in the tank and filled up at normal gas station with 93 octane.
Car is turning over but won't start. Also hooked up a charger/starter and switched it to starter mode and won't not start.
Fuel filter replaced less than 15,000 miles ago
New spark plugs in the last year.
O2 sensors changed in the last 80k miles
There are no error codes on the system.

I've had 2 similar problems in the past due to incorrect fuel gauge reading, but I have a full tank this time so that's not the issue.
The other time while the engine would crank just fine it ended up being the battery and a new one fixed the issue.

Any suggestions?

My thoughts are fuel pump, possible dirty fuel filter, maybe ignition coils?

Thanks
__________________

Last edited by nughaud; 11-04-2010 at 09:21 AM.
nughaud is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 11-04-2010, 02:26 PM   #2
nughaud
Registered User
 
Join Date: Sep 2003
Location: NW FL
Posts: 138
My Ride: '01 330CI / '11 335i
Well I was able to borrow a friend's vehicle so hopefully I'll figure it out myself or get it fixed.
I'm going to buy a new battery as it's been probably 4 years give or take anyway.
I'll check the fuses for the fuel pump, and check my plugs for corrosion, white, black or if they are wet.
I'd be delighted if it is a fuse or possibly clogged fuel filter. Just find it odd it stopped overnight with no issues before.
It wasn't cold either, probably low 50s overnight.
__________________
nughaud is offline   Reply With Quote
Old 12-03-2010, 07:27 PM   #3
nughaud
Registered User
 
Join Date: Sep 2003
Location: NW FL
Posts: 138
My Ride: '01 330CI / '11 335i
It ended up being the fuel pump. I ended up changing it out with a full tank of gas which is supposedly safer due to less fumes, but harder to work with since you will get gas on things to include your hands, so wear gloves. I disconnected the battery and had a fan blowing from inside my house out through the garage to disperse any fumes.
There is a good set of videos on Youtube that involves a replacement fuel pump and housing but it shows the steps for replacing the new pump and housing. The hardest part is getting off the locking cap/ring, removing and put the pump back in and then putting back on the locking cap/ring back on.

I knew for sure it was an issue when I turned the key and could hear the pump priming. I did this a few times to get gas back in the lines, about 4-5 and then the car started right up.

Just thought I'd update my issue in case anyone else had the same problem.

Here are the 3 part videos I used to due the fuel pump change out
This gives you a general idea of how to remove the fuel pump and then replace it. Even though it's for a M3, it's the same basic process.





__________________

Last edited by nughaud; 12-03-2010 at 07:32 PM.
nughaud is offline   Reply With Quote
Old 12-07-2010, 10:19 AM   #4
TX_Bullet
Registered User
 
Join Date: Feb 2008
Location: Houston
Posts: 951
My Ride: 2001 325Xi
Did you do like they did in the video and just do the pump or the complete assembly. I plan on just doing the pump like them
__________________
Quote:
Originally Posted by jbeurotech View Post
Sometimes the Cheapest quote is the most expensive in the end
Number of Destroyed Newb Destroyers- 1
The Mods

Power Flex FCAB
Much more coming.....
TX_Bullet is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 02:09 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use