E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Bavarian Soundwerks' Mobile Electronics Forum

Bavarian Soundwerks' Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by Bavarian Soundwerks

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 01-05-2011, 08:09 PM   #1
jbost002
Registered User
 
Join Date: Aug 2007
Location: Roanoke, VA
Posts: 118
My Ride: 2003 BMW 325i
Replaced Front Speakers

So I replaced my front OEM (non-HK) speakers on my 2003 325i saloon. I replaced them with Kickers. The problem is, they are 4 ohm speakers and the OEM speakers were 8 ohm. Now, I can hear the tweeter and mid-range too well but my new 5.5" Kicker speakers are very underpowered (I realize that I probably should have bought component, but I didn't).

I currently have a double-din Sony but I'm buying the Dynavin ASAP.

Any ideas on how I can correct my issue here? Sound is way out of whack...perhaps adjust the levels on my factory amp?
jbost002 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 01-06-2011, 01:13 AM   #2
MindFK
Registered User
 
Join Date: Sep 2010
Location: Northern NJ
Posts: 245
My Ride: 330Ci
call up parts express and explain your problem, a simple resistor might be a solution for you, im not sure what kind of resistor but people at parts express might help you out

if you sort it out let us know what you did
__________________
MindFK is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 02:09 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use