E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 1 votes, 5.00 average. Display Modes
Old 01-13-2011, 01:03 AM   #1
redmarble
Registered User
 
Join Date: Dec 2010
Location: Ca, USA
Posts: 4
My Ride: 2002 BMW 330i
HELP: car is not responsive and accelerates at a slow...

Hello everyone.

I need help. I tried the search function but it was of no avail.

Problem:
Engine light came on... Car (2002 330i) stutters and feels like if it is going to turn off on idle. When I drive, car is not responsive and accelerates at a slow rate. I step on the gas pedal but car won't speed up like it should- It speeds up, more like constant but slow until it reaches the speed I want to go!!

So, now car is in my garage.

What could the problem be?

I visually checked the hood and the underside but did not notice anything abnormal.

Any help would be really appreciated.

Has anyone experienced this problem?

Thank you, for reading.
Joey
redmarble is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 01-13-2011, 01:06 AM   #2
hahalife
Registered User
 
Join Date: Jun 2008
Location: North Jersey
Posts: 113
My Ride: Hellrot 323i
Research camshaft position sensors. I'd say thats the first area you should be concerned about.
hahalife is offline   Reply With Quote
Old 01-13-2011, 01:31 AM   #3
GRIDLOCK
Registered User
 
Join Date: May 2006
Location: OC
Posts: 2,281
My Ride: E36 / E46
Quote:
Originally Posted by redmarble View Post
Hello everyone.

I need help. I tried the search function but it was of no avail.

Problem:
Engine light came on... Car (2002 330i) stutters and feels like if it is going to turn off on idle. When I drive, car is not responsive and accelerates at a slow rate. I step on the gas pedal but car won't speed up like it should- It speeds up, more like constant but slow until it reaches the speed I want to go!!

So, now car is in my garage.

What could the problem be?

I visually checked the hood and the underside but did not notice anything abnormal.

Any help would be really appreciated.

Has anyone experienced this problem?

Thank you, for reading.
Joey

Joey, first and foremost...GET THE CODES PULLED!
__________________

Have an EVAP code? Replacing gas cap did not fix? Give me a holler, I can do a smoke test for ya.
GRIDLOCK is offline   Reply With Quote
Old 01-13-2011, 04:18 PM   #4
redmarble
Registered User
 
Join Date: Dec 2010
Location: Ca, USA
Posts: 4
My Ride: 2002 BMW 330i
Quote:
Originally Posted by hahalife View Post
Research camshaft position sensors. I'd say thats the first area you should be concerned about.

I will look into that, tomorrow, as I won't have time today.

Thank you, for your advice.
redmarble is offline   Reply With Quote
Old 01-13-2011, 04:20 PM   #5
redmarble
Registered User
 
Join Date: Dec 2010
Location: Ca, USA
Posts: 4
My Ride: 2002 BMW 330i
Quote:
Originally Posted by GRIDLOCK View Post
Joey, first and foremost...GET THE CODES PULLED!
I need to do that tomorrow.

Does anyne know of a place where they can do that for a minimal fee? I'm in the Whittier area.

Thank you.
redmarble is offline   Reply With Quote
Old 01-13-2011, 04:25 PM   #6
jayx2
Registered User
 
Join Date: Dec 2010
Location: Long Island
Posts: 130
My Ride: 2001 BMW 325i
autozone, fo freeeeeeeeeeeee
__________________

Big Gulps Aye? ... Welp See Ya Lata

www.eemilitia.com
jayx2 is offline   Reply With Quote
Old 01-13-2011, 04:53 PM   #7
E46 S54B32
Registered User
 
Join Date: Feb 2009
Location: Miami,Fl
Posts: 1,256
My Ride: 323ci
dude codes checked

run the codes on the search bar and bam answers

just desrcrbing it isnt going to do anything...misfire, cam sensor, vacuum leak it could be alot of things...go to autozone its free and youll know more or less what it is
__________________


-oem m3 front -oem m3 hood -oem m3 sideskirts-conforti intake -h&r race springs -TR Motorsport C2's -smoked corners/sidemarkers -smoked LED tails-CF CSL trunk-Black roof vinyl
E46 S54B32 is offline   Reply With Quote
Reply

Tags
330i, accelerator, bmw 330i, non-responsive, slow acceleration

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 07:06 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use