E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 01-17-2011, 03:02 PM   #1
morrow12
Registered User
 
Join Date: Sep 2010
Location: bradenton florida
Posts: 51
My Ride: 2003 m3 e46
problem after installing headers

Hey guys,a friend of mine has a 03 M3 SMG.He purchased some headers from ebay and went to install them,he came across some issues with fitment so in the end reinstalled the stock headers.However since he did this the car hasnt ran properly since! It was throwing misfire codes and also bank1-3 rich,bank 4-6 lean.So I went over and took a look at the car for him and it appeared that the o2 sensors had been put back in the wrong holes.we swapped them around and also replaced spark plugs.
After the work was completed,i started up the car and it ran rough for a few minutes then smoothed out and seemed ok.So we went to drive it to get the codes deleted and it bogged out before we got onto the main road,wont accelerate,just all around running like crap.So we couldnt get it to the store to erase or check the codes.No other work has been done to the car and all of these problems started after the header swap.
Any suggestions would be greatly appreciated,we are both out of ideas and cant drive it to get codes checked again.
morrow12 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 01-17-2011, 08:27 PM   #2
cnotesdip
Registered User
 
Join Date: Jan 2009
Location: Bx
Posts: 817
My Ride: 330ci
i had a similar problem, and it may be the position of the o2 sensors if you mess up the position you will have the car running like crap, the plug for bank 1 sensor one needs to be on bank 1 the plug for bank 2 sensor 1 needs to be on bank 2, also check the lines you may have burned one of the lines you need to feel the line.
cnotesdip is offline   Reply With Quote
Old 01-17-2011, 08:29 PM   #3
cnotesdip
Registered User
 
Join Date: Jan 2009
Location: Bx
Posts: 817
My Ride: 330ci
disconnect one of the sensors and see have code you get if you disconnect, lets say you disconnect bank 1 sensor 1 you should get a code for that bank if you get a code for bank 2 then just switch the plugs, check the lines make sure they did not get burned
cnotesdip is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 11:49 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use