E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 01-29-2011, 08:24 AM   #1
rob88ix
Registered User
 
Join Date: May 2003
Location: Manassas, VA
Posts: 13
My Ride: 2001 325xiT
Electronic Transmission Control Module

Hello All,

Starting this thread for help because I searched by this topic, but didn't find anything that seems to match my circumstances exactly.

2001 325Xi Steptronic trans (GM I think) 160k on the car. It has the warning light on the dash that corresponds in the owner's manual to Electronic Transmission Control Module. The manual describes getting it to reset just by shutting off and restarting the car, that's not working - the light is staying on. But the funny thing is that the trans seems to be acting normally - it's not in limp mode. I'm also able to put it in the Manual mode and shift it through all the gears.

Anyone run into this before? The car is overdue for a fluid change, think that would take care of it? If I have to change that module, is it true that I have to take it to the dealer for programming to match my VIN? Some have said so, others say as long as you get the exact matching P/N it will work.

Thanks in advance for your help!
__________________
1988 325ix
2001 325xi SportWagon
Weather or Not!
rob88ix is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 01-29-2011, 11:24 AM   #2
Zyaltr
Registered User
 
Join Date: Jun 2004
Location: Long Island
Posts: 341
My Ride: 01-325cic,08-750Li
Try disconnecting the battery wait 5 minutes and reconnect, if it comes back you will need to have the codes pulled...You cannot diagnose this system otherwise.
Zyaltr is offline   Reply With Quote
Reply

Tags
control, module, transmission

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 02:41 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use