E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Bavarian Soundwerks' Mobile Electronics Forum

Bavarian Soundwerks' Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by Bavarian Soundwerks

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 04-07-2011, 09:13 PM   #1
Jikenda
Registered User
 
Join Date: Apr 2011
Location: New York, NY
Posts: 3
My Ride: 2003 BMW 330i
Exclamation Navigation Screen frozen

Hey Guys, I've had this issue for about a year now and I want to sell my car soon, so I need to finally get a fix for this:

About 60% of the time (especially if the car has not been driven in a day or two), once I turn the car on, the Navi screen will just look like its frozen blurry white and/or scrambled. I cannot see anything really or make anything out, but all the of buttons still work and I have no loss of functions of the radio / CD player.

After about 5-10mins, the screen will come back on like nothing happened and will stay on and I won't have any problems until the next time.

Also, if I was already using the Navi and stopped for something and turned the car off, if I come back and the screen goes crazy again, I still hear the voice guiding me, so I don't think it's a software issue..

I was thinking maybe its a power issue as I seen the screen in the past kind of brighten and dull every few seconds, but I really don't know how to remedy this issue.

Has anyone else had this problem or does anyone have some advice on what can be done? I know if there's a fix, I'm more than likely to get my answer here before anywhere else..

Thanks for your help
Jikenda is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 04-08-2011, 07:56 AM   #2
Arty
Registered User
 
Join Date: Oct 2009
Location: UK
Posts: 1,030
My Ride: 1999 328i
Sounds like bad connectors or dying video generation circuits.

I recall reading about it in the dim and distant past on this forum.
Arty is offline   Reply With Quote
Old 04-08-2011, 02:34 PM   #3
Jikenda
Registered User
 
Join Date: Apr 2011
Location: New York, NY
Posts: 3
My Ride: 2003 BMW 330i
Cool. I'll look into it there and repost if necessary.. Thanks for the input!
Jikenda is offline   Reply With Quote
Old 04-14-2011, 06:54 PM   #4
Jikenda
Registered User
 
Join Date: Apr 2011
Location: New York, NY
Posts: 3
My Ride: 2003 BMW 330i
I have gotten no response on xoutpost.com. I will have someone take a look at it soon, but was wondering if anyone else has any input before we have her opened up...

I guess not many have had this issue...?

thanks for your input.
Jikenda is offline   Reply With Quote
Reply

Tags
nav, navi, navigation

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 02:49 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use