E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > E46 Convertible

E46 Convertible
The E46 vert forum. Talk about dropping your E46 top here.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 05-01-2011, 03:02 PM   #1
m5james
Registered User
 
Join Date: Mar 2009
Location: Boise, ID
Posts: 23
My Ride: 98 740iL, 01 X5
Send a message via AIM to m5james Send a message via Yahoo to m5james
Converted alternator from Valeo to Bosch, still doesn't charge

Hola guys, I'm always on the X5, M5 and 740iL forums since those are the cars I ahve, so I'm just here posting this for a buddy since we're stumped at to what to do next and would appreciate your help in any way.

Roughly a week ago the battery light come on in his '00 323ci, limping it home to the point where the headlights were dimming and the dash was lite up light a Christmas tree. We read here that the Valeo regulator isn't replaceable, yet the Bosch version is. We also read there that they're physically the same alternator, so he decided to switch to the Bosch alternator since it has a replaceable regulator in case anything happens down the road.

Other than a single bushing that needed to be moved back about 1/8 to 1/4 of an inch, it dropped in perfectly and the harness plug was the same. Once we started the car, I confirmed that I had 14v at the battery and also confirmed the same at the jump start posts inside the engine bay. While he was driving the car home, everything seemed fine, yet it's doing the same thing again where eventually everything dimmed and died again. The battery is fine because it takes and holds a charge and allows his to drive around for about a half an hour or so, but the second we disconnect the battery, the car dies.

He pulled every fuse inside the glovebox, confirmed it wasn't popped, then replaced them all. Oddly, if we charge the battery and start the car, the battery light comes on, yet if I disconnect the harness, the battery light will shut off. At this point we're at a total loss and not sure what is the next step to take.
m5james is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 05-02-2011, 08:39 PM   #2
m5james
Registered User
 
Join Date: Mar 2009
Location: Boise, ID
Posts: 23
My Ride: 98 740iL, 01 X5
Send a message via AIM to m5james Send a message via Yahoo to m5james
So is this really that taboo of a subject? I can't be the only one who's done this.

As for what we've tried, we removed the regulator and the two spring loaded fingers that contact the alternator are plenty long. Using Torque and my OBDII device, I'm reading around 12.2v when running, but it's still slowly trickling down.
m5james is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 12:07 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use