E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > DIY: Do It Yourself

DIY: Do It Yourself
Post here to share or improve your wrench turning skills! All BMW E46 DIY tips, tales, and projects discussed inside. Learn to work on your car and know the right BMW parts you will need!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 05-16-2011, 06:42 PM   #1
skekasaurus
Registered User
 
Join Date: May 2011
Location: San antonio
Posts: 1
My Ride: e46 325i
Help please! Rough Idle/Car dies when turned on (video included)

I have this issue, and i'm just wondering what it may be. I had an O2 sensor replaced a few weeks back. Its kind of having the same symptoms, but idk if it could be related to the sensor again or something else.

Any help is much appreciated. I included a video below:


The first time I turned it on, it died almost immediately. The second time around I turned it on and immediately pressed the gas pedal. The engined rev'd, but it like hiccuped a bit. I had my foot down on the gas the whole time, I was pressing and releasing continuously it was just doing that on its own. I can some what drive it around, as long as I'm not in the lows RPM's, when it hits the lower section it starts acting like it has no gas or something.


Thank guys.

Last edited by skekasaurus; 05-16-2011 at 06:43 PM.
skekasaurus is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 05-17-2011, 02:52 PM   #2
shellback
Registered User
 
Join Date: Jul 2009
Location: FL
Posts: 124
My Ride: BMW
Are you pushing it off a cliff at the end of the video?
Fuel pump?
Fuel filter?
shellback is offline   Reply With Quote
Old 05-17-2011, 03:16 PM   #3
ddombrowski
Registered User
 
Join Date: Jun 2006
Location: South Florida
Posts: 909
My Ride: 01 330ci 5spd
Send a message via AIM to ddombrowski
First thing I always do with cars like this is to clean the idle air motor and throttle body. That fixes a majority of them, and its free. If not, then I start diagnosing.
__________________
ddombrowski is offline   Reply With Quote
Old 05-18-2011, 06:59 AM   #4
tractioncircle
Registered User
 
Join Date: Nov 2009
Location: Santa Clara, CA
Posts: 18
My Ride: 02 325i
+1

Sounds like s stuck ICV. There are multiple DIY's in here on how to remove and clean the ICV. While you are at it, clean your DISA vavle and CCV too.
Here a DIY with pics from bimmerfest. Also inspect all the intake hoses for cracks leaks and clean you MAF.

http://www.bimmerfest.com/forums/sho...d.php?t=323335
tractioncircle is offline   Reply With Quote
Old 05-18-2011, 07:31 AM   #5
InDiGlOM3
Registered User
 
Join Date: Jan 2006
Location: Copperas Cove
Posts: 1,502
My Ride: HPF M3 stg 2.5
Send a message via AIM to InDiGlOM3 Send a message via Yahoo to InDiGlOM3
cam/crank sensor. and sometimes this wont even throw a code.
__________________
InDiGlOM3 is offline   Reply With Quote
Old 05-18-2011, 05:51 PM   #6
muly
Registered User
 
Join Date: Apr 2007
Location: UK
Posts: 103
My Ride: 330 sport vert
Have you tried it with the maf sensor unplugged?
__________________
muly is offline   Reply With Quote
Old 05-20-2011, 09:40 AM   #7
tractioncircle
Registered User
 
Join Date: Nov 2009
Location: Santa Clara, CA
Posts: 18
My Ride: 02 325i
Check this thread.

http://forum.e46fanatics.com/showthread.php?t=773551

I've been struggling with rough idle and SES light with P1085,1083,0171,0174 codes.

The fix was a 17$ vent hose that goes from the CCV to the dipstick. Its a 20 min diy and you only need to take the Airbox out.
tractioncircle is offline   Reply With Quote
Reply

Tags
325i, car, dies, idle, rough

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 02:09 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use