E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 04-25-2011, 02:41 AM   #1
Hobblenobble
Registered User
 
Join Date: Sep 2008
Location: Blackpool
Posts: 9
My Ride: bmw 320d SE 2003
Unhappy Rough Engine @ 1600-2300 rpm

Apologies if I have repeated this thread but I cannot find the issue in any forum I have a 2003 3 series E46 diesel 320SD. I have had it serviced recently with no error codes on the diagnostics. However, the issue I have got is that if the car is at a standstill and I press the accelerator, the engine seems to misfire between 1600 and 2300 rpm as though the engine is juddering. If I am driving normally, the engine seems to judder at 1600rpm regardless of which gear, but if you keep accelerating, the engine picks up and the car accelerates normally. When I use cruise control and the rpm is in the ‘judder zone’, the speed control hunts. I have used jet cleaner in my fuel to try and clean the injector nozzles, but this has not helped. My mpg has not been affected by this issue, this is normal. Any ideas or suggestions would be more than appreciated. Thank you.
Hobblenobble is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 04-25-2011, 03:18 AM   #2
Ixi640
Registered User
 
Join Date: Jul 2010
Location: Chicago
Posts: 47
My Ride: 2000 323i
ignition coil/boot?

http://forums.bimmerforums.com/forum...d.php?t=628626

I'm having the exact same problem, and I ordered a $25 FCP coil off of ebay that should be here tomorrow, I'll let ya know how it goes
Ixi640 is offline   Reply With Quote
Old 04-25-2011, 03:36 AM   #3
Drizzles
Registered User
 
Join Date: Dec 2009
Location: Australia
Posts: 964
My Ride: 1999 BMW 318i E46 4D
A few things, do you have a CAI or any kind of intake mod? If so, replace with stock.

Secondly, check for cracks etc in boots and vacuum lines. They are another possibility ...
__________________
Drizzles is offline   Reply With Quote
Old 04-25-2011, 03:38 AM   #4
mack89
Registered User
 
Join Date: Jan 2009
Location: Texas
Posts: 2,334
My Ride: '02 TIAG 330i 5spd
^Good thinking, but vacuum leak will cause constant rough idle. And it'll throw SES codes as well
__________________
mack89 is offline   Reply With Quote
Old 04-25-2011, 03:39 AM   #5
mack89
Registered User
 
Join Date: Jan 2009
Location: Texas
Posts: 2,334
My Ride: '02 TIAG 330i 5spd
Quote:
Originally Posted by Ixi640 View Post
ignition coil/boot?

http://forums.bimmerforums.com/forum...d.php?t=628626

I'm having the exact same problem, and I ordered a $25 FCP coil off of ebay that should be here tomorrow, I'll let ya know how it goes
^As far as I know, diesel engines don't have spark plugs/ignition coils. Glow plugs do their job.
Anyway, I'd check fuel supply system. Pressure might be little bit low, makes judder. Check glow plugs as well..
__________________
mack89 is offline   Reply With Quote
Old 04-25-2011, 04:27 AM   #6
Drizzles
Registered User
 
Join Date: Dec 2009
Location: Australia
Posts: 964
My Ride: 1999 BMW 318i E46 4D
Quote:
Originally Posted by mack89 View Post
^As far as I know, diesel engines don't have spark plugs/ignition coils. Glow plugs do their job.
Anyway, I'd check fuel supply system. Pressure might be little bit low, makes judder. Check glow plugs as well..
Ummm ... yeah why didn't I pick that up

Diesel engines use compression and the heat at the top of the cylinder to recombust .. they don't have coils or plugs ................

The only plug they have is a Glow Plug to initially warm the cylinder to operating temp so the engine can start, after this initial warm up, the glow plugs are not used again till the engine cools down.
__________________

Last edited by Drizzles; 04-25-2011 at 04:41 AM.
Drizzles is offline   Reply With Quote
Old 04-25-2011, 12:09 PM   #7
Hobblenobble
Registered User
 
Join Date: Sep 2008
Location: Blackpool
Posts: 9
My Ride: bmw 320d SE 2003
Guys, thanks for your replies. My car is stock and no mods have been carried out. I did clean the ERV today due to the good post on this website. Thought it may help, but unfortunately not. However, when I restarted the engine after the clean i did notice a sucking/blowing sound coming from the rights hand side of the ERV. I could not locate it properly due to the rotating belts ????? How do you check/amend the pressure for the fuel system? Is there a post that would give clear instructions how to do this? Also the glow plugs too! Although, do the glow plugs have any function after the negine has started? Nevertheless, thank you for all the replies.
Hobblenobble is offline   Reply With Quote
Old 05-21-2011, 10:19 AM   #8
Hobblenobble
Registered User
 
Join Date: Sep 2008
Location: Blackpool
Posts: 9
My Ride: bmw 320d SE 2003
HElp pleeeeez
Hobblenobble is offline   Reply With Quote
Old 05-21-2011, 10:45 AM   #9
Drizzles
Registered User
 
Join Date: Dec 2009
Location: Australia
Posts: 964
My Ride: 1999 BMW 318i E46 4D
Glow plugs do not affect the normal running of the vehicle once properly running.

Grab yourself a can of MAF cleaner or Carby Cleaner, remove anything obstructing the engine i.e. Cabin Filter Housing etc (never worked on a Diesel E46 so I couldn't tell you what you have to and don't have to remove.)

Start her running and spray that stuff everywhere, all over the Engine, the Vacuum Fittings and intake assembly etc.

I've also heard a Sucking/Blowing sound can be Secondary Air Pump.

I would get your codes read anyway, as you can have codes without having a CEL.
__________________
Drizzles is offline   Reply With Quote
Old 06-24-2011, 05:14 AM   #10
Hobblenobble
Registered User
 
Join Date: Sep 2008
Location: Blackpool
Posts: 9
My Ride: bmw 320d SE 2003
I sprayed every where but no difference. i disconnected the MAF and it seemed a little better. Although the juddering did occur but not as frequently. What i also noticed is that in Cruise Control Mode (CCM), at 80mph/1500rpm the engine pulls the car along in a juddery manner. Also the speed would drop to 76mph and then pick back up to 80mph every two or three minutes. If I ran at 82mph on CCM then the car cruised along perfectly.
Hobblenobble is offline   Reply With Quote
Old 06-25-2011, 09:42 AM   #11
Hobblenobble
Registered User
 
Join Date: Sep 2008
Location: Blackpool
Posts: 9
My Ride: bmw 320d SE 2003
Today I removed the MAF and EGR Valve. I cleaned both, but it still has the same issue.
Hobblenobble is offline   Reply With Quote
Old 07-02-2011, 02:34 AM   #12
Hobblenobble
Registered User
 
Join Date: Sep 2008
Location: Blackpool
Posts: 9
My Ride: bmw 320d SE 2003
Well, through luck I think it is cured! Cleaned my MAF with brake cleaner and disconnected the battery for 30 minutes.

I do not think there is a forum out there that can actually pi point the true reason and remedy for this issue
Hobblenobble is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 11:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use