E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 07-02-2011, 11:41 AM   #1
k_landa
Registered User
 
Join Date: Sep 2008
Location: Leeds
Posts: 10
My Ride: E46 330Ci convertibl
PDC problem

I own a 330Ci Convertible 2001, and am having an intermittent fault.
When I engaged reverse my reversing sensors appear to be working well but after about 20 seconds give a continuous tone. If I return to neutral and then back to reverse exactly the same problem
Can anyone advise whether this is a faulty sensor or module.
k_landa is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 07-02-2011, 11:56 AM   #2
NE1L
Registered User
 
Join Date: Sep 2006
Location: Scotland
Posts: 152
My Ride: 320Cd M-Sport
Most likely a sensor problem. To check which one(s), turn the ignition on (do not start the engine), put the car into reverse (the reverse light should light up), then at the back of the car carefully listen to each sensor. There should be a pretty strong and regular clicking / ticking sound coming from them. If one or more is silent or emits a weak clicking noise, then that is your culprit. If you do need a new sensor apparently LandRover use compatible ones on the Freelander, but I don't know that part number off by hand. The LandRover ones are around 20 each, where as the BMW ones are around 60 each.
NE1L is offline   Reply With Quote
Old 07-02-2011, 02:40 PM   #3
k_landa
Registered User
 
Join Date: Sep 2008
Location: Leeds
Posts: 10
My Ride: E46 330Ci convertibl
Sorry I failed to say that I had listened to all four sensors and all appeared to be clicking in both beep mode and continuous mode.
Is there any other method of testing PDC sensors and PDC module.
k_landa is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 11:51 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use