E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 06-26-2011, 07:25 PM   #1
tanzi
Registered User
 
Join Date: Nov 2007
Location: Mass
Posts: 1,239
My Ride: 02' 325i
Turn Signal Not working

My front driver side turn signal and side marker are not working. I dont have bulb out warning either.

I checked the bulbs and they are good.

Ideas?
__________________
tanzi is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 06-26-2011, 07:40 PM   #2
dmax
Registered User
 
dmax's Avatar
 
Join Date: Aug 2006
Location: NJ
Posts: 22,789
My Ride: '99 328i 1.04646 mu
I don't think a fuse controls just those two things, so I'd say look at the comb connector between the two, sort of well hidden. If you look through the hole where your turn signal housing is, you'll see it. That's the first connection that I think is common to both of those lights and I believe it's all ground connections. Make sure it's clean and tight.

You might just try to pull up the bottom tabs on both sockets just a bit, so the bulb is held more firmly, clean any corrosion you see on either bulb or in socket...doublecheck, maybe even clean the electrical contacts...plug and unplug a few times.

One guy lost one of his gaskets for an electrical connector recently...if you have, that would explain things really easily.

Work out from the bulb (maybe even break down and buy genuine bmw bulbs...as they are better than most).

Edit: I just realized that when my socket was the problem, I did have a bulb out warning...and also a fast blinking light.

So, one other thing...make sure the rear turn signal is working. If it isn't, then consider the switch itself. Maybe give it some vigorous exercise?
__________________


Performing at the Comedy Cove--595 Morris Ave. Springfield NJ reservations 973 376-3840

A recent set

dmax on the radio every Wednesday 7-9 p.m. NYC time. Call in! (661) 449-9340 watsonnwatson.com

Last edited by dmax; 06-26-2011 at 07:42 PM.
dmax is offline   Reply With Quote
Old 06-26-2011, 08:23 PM   #3
RSteckhahn
Registered User
 
Join Date: Nov 2008
Location: Oakhurst, NJ
Posts: 390
My Ride: '05 325i
Make sure you use your hand signals as to avoid a ticket... the same signals that bicyclists use are acceptable for car use.
RSteckhahn is offline   Reply With Quote
Old 06-27-2011, 04:46 PM   #4
tanzi
Registered User
 
Join Date: Nov 2007
Location: Mass
Posts: 1,239
My Ride: 02' 325i
my rear turn signal does work so its got to be that bad connection
__________________
tanzi is offline   Reply With Quote
Old 06-27-2011, 04:55 PM   #5
dmax
Registered User
 
dmax's Avatar
 
Join Date: Aug 2006
Location: NJ
Posts: 22,789
My Ride: '99 328i 1.04646 mu
Quote:
Originally Posted by tanzi View Post
my rear turn signal does work so its got to be that bad connection
Well...hopefully. Just work out one step at a time. You know it's not the switch. You said it's not the bulbs and I believe you (mostly)! Sockets might both be loose or corroded, as could connections...that comb connector for the grounds would be after that, as if not disturbed, I imagine they'd be good for 'almost' ever!

Unless, of course, you've got aftermarket things added on you didn't mention because you thought they weren't related.
__________________


Performing at the Comedy Cove--595 Morris Ave. Springfield NJ reservations 973 376-3840

A recent set

dmax on the radio every Wednesday 7-9 p.m. NYC time. Call in! (661) 449-9340 watsonnwatson.com
dmax is offline   Reply With Quote
Old 07-03-2011, 06:54 AM   #6
tanzi
Registered User
 
Join Date: Nov 2007
Location: Mass
Posts: 1,239
My Ride: 02' 325i
Well not that you mention it...... haha

I run both the front turn signal and side marker off of the side marker. I ran two wires from the side marker up to the front corner turn signal.


So this means the problems relates directly to the power going to the side marker since thats the source of power for both lights.
__________________
tanzi is offline   Reply With Quote
Old 07-04-2011, 11:36 AM   #7
tanzi
Registered User
 
Join Date: Nov 2007
Location: Mass
Posts: 1,239
My Ride: 02' 325i
where do the wires from the side marker go? I need to follow that power source
__________________
tanzi is offline   Reply With Quote
Old 07-04-2011, 03:27 PM   #8
dmax
Registered User
 
dmax's Avatar
 
Join Date: Aug 2006
Location: NJ
Posts: 22,789
My Ride: '99 328i 1.04646 mu
Quote:
Originally Posted by tanzi View Post
where do the wires from the side marker go? I need to follow that power source
Work back from the light...or get online wiring diagram...don't all lights go to the light control module?

I'm pretty sure it could also be a ground issue, or maybe the way you wired it too. Check the connections you did first...nothing personal!
__________________


Performing at the Comedy Cove--595 Morris Ave. Springfield NJ reservations 973 376-3840

A recent set

dmax on the radio every Wednesday 7-9 p.m. NYC time. Call in! (661) 449-9340 watsonnwatson.com
dmax is offline   Reply With Quote
Old 07-11-2011, 05:12 PM   #9
tanzi
Registered User
 
Join Date: Nov 2007
Location: Mass
Posts: 1,239
My Ride: 02' 325i
i re-did all the connections and everything looks good.

Where is the ground for the side marker?

Is the LCM messed up?

Anyway to check?
__________________
tanzi is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 11:29 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use